summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-08 22:44:58 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-08 22:52:35 -0500
commitaab7960f5ed621d66db18b1c8e5f31d2d72af551 (patch)
treeeb65a2ea44d63c8901eed5cc69039565931ea2f6 /sci-libs
parentgames-kids/lletters: EAPI7->8, drop dead urls, fix w/ clang16 (diff)
downloadgentoo-aab7960f5ed621d66db18b1c8e5f31d2d72af551.tar.gz
gentoo-aab7960f5ed621d66db18b1c8e5f31d2d72af551.tar.bz2
gentoo-aab7960f5ed621d66db18b1c8e5f31d2d72af551.zip
sci-libs/inchi: fix build w/ clang16, install ixa.h
Also add the lacking quotes around tc-getCC/CXX. Just quickfixes, ebuild feels rather fragile. Closes: https://bugs.gentoo.org/834488 Closes: https://bugs.gentoo.org/874696 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/inchi/inchi-1.06-r1.ebuild (renamed from sci-libs/inchi/inchi-1.06.ebuild)8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-libs/inchi/inchi-1.06.ebuild b/sci-libs/inchi/inchi-1.06-r1.ebuild
index 96578dc57371..48d6556426ff 100644
--- a/sci-libs/inchi/inchi-1.06.ebuild
+++ b/sci-libs/inchi/inchi-1.06-r1.ebuild
@@ -27,8 +27,8 @@ src_compile() {
append-cxxflags \${P_INCL} -ansi -frtti -c
common_opts=(
- C_COMPILER=$(tc-getCC)
- CPP_COMPILER=$(tc-getCXX)
+ C_COMPILER="$(tc-getCC)"
+ CPP_COMPILER="$(tc-getCXX)"
AR="$(tc-getAR)"
RANLIB="$(tc-getRANLIB)"
LINKER="$(tc-getCXX)"
@@ -40,7 +40,7 @@ src_compile() {
# Compile the library
target_opts=(
LINKER_OPTIONS="${LDFLAGS} "
- C_OPTIONS="${CFLAGS} -DTARGET_API_LIB -D_LIB "
+ C_OPTIONS="${CFLAGS} -DTARGET_API_LIB -D_LIB -D_XOPEN_SOURCE=500 " #874696
CPP_OPTIONS="${CXXFLAGS} -DTARGET_API_LIB -D_LIB "
CREATE_MAIN=
)
@@ -71,5 +71,5 @@ src_install() {
fi
dobin "${S}/INCHI_EXE/bin/Linux/inchi-1"
dolib.so "${S}/INCHI_API/bin/Linux/"lib*so*
- doheader "${S}/INCHI_BASE/src/inchi_api.h"
+ doheader "${S}/INCHI_BASE/src/"{inchi_api,ixa}.h
}