summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-26 02:15:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-26 02:32:05 +0200
commit048b5cc13c0a62e9104d769b51157c5cf771acf6 (patch)
treeb9d337aa27191b4b8e9db65b0944a62fdc501879 /sci-mathematics
parentsci-mathematics/lean: drop old 3.44.1 (diff)
downloadgentoo-048b5cc13c0a62e9104d769b51157c5cf771acf6.tar.gz
gentoo-048b5cc13c0a62e9104d769b51157c5cf771acf6.tar.bz2
gentoo-048b5cc13c0a62e9104d769b51157c5cf771acf6.zip
sci-mathematics/mathlib-tools: bump to 1.1.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathlib-tools/Manifest1
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/Manifest b/sci-mathematics/mathlib-tools/Manifest
index ae52335bd324..6eb9b1e10ad5 100644
--- a/sci-mathematics/mathlib-tools/Manifest
+++ b/sci-mathematics/mathlib-tools/Manifest
@@ -1,2 +1,3 @@
DIST mathlib-tools-1.1.0.tar.gz 32374 BLAKE2B f470927cae1dc66478efd44de6a5fd7c8df9656351ee342d14a1e75e8774383616cedf01b21ef1b92220fb03b1f1ccb326e3363dd0fec4fb5876f43c5ddb4010 SHA512 bc59d2e41c42ecc22c5768ac3adb209f0b170e2e97fe68483d8518b78a6b4fa163c1d46e4e3996c6f3e0aaa329c642fd111b3e16d850f40b6edc81c81215d03f
DIST mathlib-tools-1.1.1.tar.gz 32456 BLAKE2B 2cb81a6072aecc8a9c298c8bd0ac2edc7f44fecd290add5254a0c35b5e16fca4cfef32727acff883366d99101f7e62ad12709e59b317e34547fa49c404600366 SHA512 17e6105d48071ab41aaa436d3fd35774227b242e6026b30ac82fd0b4f7ea8310a9bc0abe6abe5eca3e77ec62d6a48e7584222381dc7071803215cc3189ce973b
+DIST mathlib-tools-1.1.2.tar.gz 32477 BLAKE2B d49d8b05974b70db52e55dea7fdd91f82b05266a6ab2db50e12963b1d9991500088d4aa897a65c391b82e0996d57f5cad5ade8cc85ae85fccb0a03ed63a2f2c8 SHA512 2c0d4faa7a7610f16eca539f1ee369a18ffb6b947bd0ac55983dee8b651c258b9d1819d066dafcfdaf23e612c6e9fb7a3239ccb0b6ca5e51dabcc761bf9b815a
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild
new file mode 100644
index 000000000000..bc7818d3db62
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}