summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/install-xattr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/install-xattr')
-rw-r--r--sys-apps/install-xattr/Manifest2
-rw-r--r--sys-apps/install-xattr/install-xattr-0.4.ebuild45
-rw-r--r--sys-apps/install-xattr/install-xattr-0.5.ebuild45
-rw-r--r--sys-apps/install-xattr/install-xattr-9999.ebuild45
-rw-r--r--sys-apps/install-xattr/metadata.xml9
5 files changed, 146 insertions, 0 deletions
diff --git a/sys-apps/install-xattr/Manifest b/sys-apps/install-xattr/Manifest
new file mode 100644
index 000000000000..1a8e8a7dc0b4
--- /dev/null
+++ b/sys-apps/install-xattr/Manifest
@@ -0,0 +1,2 @@
+DIST install-xattr-0.4.tar.bz2 16073 SHA256 d769908e738d876bdd35308e3a9555c97872fb8633255e23eaa5a0d68cd10c6f SHA512 f682da111b9803e0ebe3dbc01bf7b921e0c3b12edce3f0f64b9d70e7e8fc84d586bf9612cd2bdc5c49a300cb4bd40b562f218a98e63951f5644d81aeab468361 WHIRLPOOL 719da63f05be2f277a9c968309306df5071d5804473fbd327d85e320ac8b86813face041098bef33723c5ea5aaa4c2862f47fa9accbc4de51638ddb3500354ba
+DIST install-xattr-0.5.tar.bz2 16136 SHA256 6062fbcb8f463a54be8c2eedff7bd12ab682972d688784054f4abdad4e050834 SHA512 0bbde3a548fc5062041b38f90ac09c402f3cb0aebf4f0c331552fc44d39dd3d5e4d73bca0811de36c53af8afa5d22e543a7c90107d272f2a1b97c819b244eb7c WHIRLPOOL 1aa3a06b069bb12b3933f2dfc81ff5bce8295c93c64421b898b70440427d5dde05f88ccac3eb7361c372a8656b42df8e24592f60bab7acc758bec9c672c81847
diff --git a/sys-apps/install-xattr/install-xattr-0.4.ebuild b/sys-apps/install-xattr/install-xattr-0.4.ebuild
new file mode 100644
index 000000000000..d85a1a9dca6f
--- /dev/null
+++ b/sys-apps/install-xattr/install-xattr-0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
+HOMEPAGE="http://dev.gentoo.org/~blueness/install-xattr/"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
+ KEYWORDS=""
+ inherit git-2
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+ S=${WORKDIR}/${PN}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+src_install() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+# We need to fix how tests are done
+src_test() {
+ true
+}
diff --git a/sys-apps/install-xattr/install-xattr-0.5.ebuild b/sys-apps/install-xattr/install-xattr-0.5.ebuild
new file mode 100644
index 000000000000..d882c819ccae
--- /dev/null
+++ b/sys-apps/install-xattr/install-xattr-0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
+HOMEPAGE="http://dev.gentoo.org/~blueness/install-xattr/"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
+ KEYWORDS="alpha arm hppa ia64 sparc"
+ inherit git-2
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+ S=${WORKDIR}/${PN}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+src_install() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+# We need to fix how tests are done
+src_test() {
+ true
+}
diff --git a/sys-apps/install-xattr/install-xattr-9999.ebuild b/sys-apps/install-xattr/install-xattr-9999.ebuild
new file mode 100644
index 000000000000..b5baeb7ef650
--- /dev/null
+++ b/sys-apps/install-xattr/install-xattr-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
+HOMEPAGE="http://dev.gentoo.org/~blueness/install-xattr/"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
+ KEYWORDS=""
+ inherit git-2
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S=${WORKDIR}/${PN}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+src_install() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+# We need to fix how tests are done
+src_test() {
+ true
+}
diff --git a/sys-apps/install-xattr/metadata.xml b/sys-apps/install-xattr/metadata.xml
new file mode 100644
index 000000000000..3f1a615f77ac
--- /dev/null
+++ b/sys-apps/install-xattr/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+</maintainer>
+<herd>base-system</herd>
+</pkgmetadata>