summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-15 00:52:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-19 18:47:49 +0300
commitc707d9cb9f19868bff269ea9af8bd104aada42ca (patch)
tree55975328efd9fb637b85c3a2d46b94e2d0316781 /sys-apps/qdirstat
parentsys-process/numad: chmod -x files/numad.initd (diff)
downloadgentoo-c707d9cb9f19868bff269ea9af8bd104aada42ca.tar.gz
gentoo-c707d9cb9f19868bff269ea9af8bd104aada42ca.tar.bz2
gentoo-c707d9cb9f19868bff269ea9af8bd104aada42ca.zip
sys-apps/qdirstat: bump to version 1.6
Also bumped to EAPI=7 and added myself as maintainer. Closes: https://bugs.gentoo.org/637400 Closes: https://bugs.gentoo.org/668742 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12927 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest1
-rw-r--r--sys-apps/qdirstat/metadata.xml10
-rw-r--r--sys-apps/qdirstat/qdirstat-1.6.ebuild53
3 files changed, 63 insertions, 1 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index 3dcad4c52891..7b2965fcf90e 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1 +1,2 @@
DIST qdirstat-1.4.tar.gz 2534241 BLAKE2B 70b84376a949ab3d74879bc78dac9d41c592ee9a4c60d27ad9d85ab09378f85a65209c78f7030f76e86e8e418803eef5ed1dadb07a1058ec38c13d753f6e3e61 SHA512 5711a78297f4224e4471ac14d8e42ee9ac746cc31315ff894dafa1db578eff4ff2a5c62edc525a49c523154a0de402f878200d96601c7924bf0273f0eac9ab74
+DIST qdirstat-1.6.tar.gz 6398935 BLAKE2B dba15df3f9dd34276ee38ccdd97d1b8158596198b22a807b4d0a68c7d33d146a25ef5b987c4a6e3dc16df421422ddc0cad2e9f60a80493ac668bcb023c15c31c SHA512 8d1350bc8995dac2de90a32ca5ddaac47a317c7e7044f39ed87a7b2e208cda0b84f04c147f7a2414d7a0c5c731479847a879aedcf5781ca772fbfa8fa360cc77
diff --git a/sys-apps/qdirstat/metadata.xml b/sys-apps/qdirstat/metadata.xml
index b811e95a6aec..b73ce0a34ae8 100644
--- a/sys-apps/qdirstat/metadata.xml
+++ b/sys-apps/qdirstat/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>
Qt-based directory statistics: KDirStat without any KDE -- from
the author of the original KDirStat.
@@ -15,6 +22,7 @@
and other Unix-like systems.
</longdescription>
<upstream>
+ <bugs-to>https://github.com/shundhammer/qdirstat/issues</bugs-to>
<remote-id type="github">shundhammer/qdirstat</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-apps/qdirstat/qdirstat-1.6.ebuild b/sys-apps/qdirstat/qdirstat-1.6.ebuild
new file mode 100644
index 000000000000..3a907d9e667c
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt-based directory statistics"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ dev-perl/URI
+"
+
+src_prepare() {
+ default
+
+ # Fix QA warning about incorrect use of path
+ sed -e "10s:/qdirstat:/${P}:" -i doc/doc.pro || die
+ sed -e "10s:/qdirstat:/${P}:" -i doc/stats/stats.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}