summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-09-15 15:35:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-09-15 15:35:40 +0200
commit45386d41d7eefb42f8d4096172649cde2e309519 (patch)
tree04e19479f548343dbb0eb4a3306d843a93906347 /sys-apps
parentsys-auth/AusweisApp: add 2.2.1 (diff)
downloadgentoo-45386d41d7eefb42f8d4096172649cde2e309519.tar.gz
gentoo-45386d41d7eefb42f8d4096172649cde2e309519.tar.bz2
gentoo-45386d41d7eefb42f8d4096172649cde2e309519.zip
sys-apps/cpuid: add 20240912
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20240912.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 181327529a15..5bb4931fa7e8 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20240716.src.tar.gz 155562 BLAKE2B 52625a547c70b7fd45d63fea88acfcc938443f1f53c686896f88ef193240b7b9ea76020a48b187689c27fddad4cba8cdd41044ab57f731e488af14fd1a608fa3 SHA512 1efbd3f98253700d2948573025733fb7a3354d008b968c83078d36ddac834c4adae4eeef288214066ad520d23fa1eb0ea2036f878cde20d982a1810e7305b7a4
+DIST cpuid-20240912.src.tar.gz 156818 BLAKE2B c44bf5687f00703815d854cf4d71cbb9d1e6e33561ae9809d90f16a9effd68a6dbdfafd77001aeaccb3be4092807fce4b682f4f243aa362fdbf23edabb319c12 SHA512 fa6bfbcadfd6847bd2224498e02879a3708bff49d3bbf90d80ba2ad4e92b4db8a717185079fa044b50bfbebc798069bf1450a2869c394b0911b92b509d29c013
diff --git a/sys-apps/cpuid/cpuid-20240912.ebuild b/sys-apps/cpuid/cpuid-20240912.ebuild
new file mode 100644
index 000000000000..c2868c0d5525
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20240912.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}