summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-17 18:22:09 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-17 18:26:41 +0200
commit7163e2c7f86bef3a089f3e6cf249d0340ce28aae (patch)
tree0262cadcd1756330d444a3d8882949db14e32aa9 /sys-apps
parentsys-apps/cinit: drop 0.2.1 (diff)
downloadgentoo-7163e2c7f86bef3a089f3e6cf249d0340ce28aae.tar.gz
gentoo-7163e2c7f86bef3a089f3e6cf249d0340ce28aae.tar.bz2
gentoo-7163e2c7f86bef3a089f3e6cf249d0340ce28aae.zip
sys-apps/cinit: update EAPI 7 -> 8
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cinit/cinit-0.2.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/cinit/cinit-0.2.1-r2.ebuild b/sys-apps/cinit/cinit-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..4a302895f556
--- /dev/null
+++ b/sys-apps/cinit/cinit-0.2.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="a fast, small and simple init with support for profiles"
+HOMEPAGE="http://linux.schottelius.org/cinit/"
+SRC_URI="http://linux.schottelius.org/${PN}/archives/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.1-musl-clang16-build-fix.patch
+)
+
+src_prepare() {
+ sed -i "/contrib+tools/d" Makefile || die
+ sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I." \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP=/bin/true \
+ all
+}
+
+src_install() {
+ emake LD="$(tc-getCC)" DESTDIR="${D}" install
+ rm -f "${D}"/sbin/{init,shutdown,reboot} || die
+ dodoc Changelog CHANGES CREDITS README TODO
+ use doc && dodoc -r doc
+}