summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-20 09:40:58 +0100
committerSam James <sam@gentoo.org>2024-09-20 09:40:58 +0100
commite26677b097faaba5e792321baa15bb43ab571629 (patch)
treeb9a802c083ce5bc84cecb831d0a6b3fe33d37371 /sys-apps
parentdev-vcs/git: add 2.46.1 (diff)
downloadgentoo-e26677b097faaba5e792321baa15bb43ab571629.tar.gz
gentoo-e26677b097faaba5e792321baa15bb43ab571629.tar.bz2
gentoo-e26677b097faaba5e792321baa15bb43ab571629.zip
sys-apps/moar: add 1.27.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.27.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 5e8488f91f3e..c0f38a76e9d1 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -10,3 +10,5 @@ DIST moar-1.24.6-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c
DIST moar-1.24.6.tar.gz 2806800 BLAKE2B c412c62f7a1c9dba73e1ae7b31d43ffa58789e93a22b357dc4469168fd5cef95732a2363fadb4b4266169de5aaf3e541c4212730425e4c2ad91f194c7e9107f7 SHA512 77d5b789449806e8355702af762cd4cd604a885e7ffdebfcd6601073ea8cd0893c12999662352780d9915a9fbcb3bbc35e1e5b637e1ae15f73a5e65ca632193e
DIST moar-1.26.0-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
DIST moar-1.26.0.tar.gz 2811931 BLAKE2B 8f0ed34aeb5a4116a8a42cbef2f40f0ed81a60f5bb9160ec743694263e35674f126b0ec359e0ec390baed7f8cf6c4d457cf4e401c4ef951cc7dd9163b0a0e2f7 SHA512 e3de7183df6b4e29ffa43f1681b8c5bc207a7f4e33ad42c3021a4260da91bb8ade3bb4f3c7d9cd6603cb416c7f4c976d2525d96862deff3080c9d1ec17c127ef
+DIST moar-1.27.1-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
+DIST moar-1.27.1.tar.gz 2812825 BLAKE2B 11998da52d8eebf0a2b1e9e82af5e78b5c559efdcc033dabc8d98dc9e324795c481e51dd63ef5eb7f46c544d60215708a967a5a47f2f87e974fc02f4cab78690 SHA512 6363bbb7399af16f844d61a630b192f866a2f9dd9a9f34caee14c7d704c52f193b3c0643053892b0483dbe0378bd87ed40bae5915bf366a877115b060d64d4b9
diff --git a/sys-apps/moar/moar-1.27.1.ebuild b/sys-apps/moar/moar-1.27.1.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.27.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}