summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-16 15:29:53 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-16 15:29:53 +0200
commit1be2c2aec3431058f787a20e999e3ae56417932c (patch)
treea4548a44bbc4a89e462baf9fb88676f33d0fa027 /sys-block
parentsys-block/mbuffer: Remove old (diff)
downloadgentoo-1be2c2aec3431058f787a20e999e3ae56417932c.tar.gz
gentoo-1be2c2aec3431058f787a20e999e3ae56417932c.tar.bz2
gentoo-1be2c2aec3431058f787a20e999e3ae56417932c.zip
sys-block/partimage: Remove old
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/partimage/Manifest1
-rw-r--r--sys-block/partimage/partimage-0.6.8.ebuild142
2 files changed, 0 insertions, 143 deletions
diff --git a/sys-block/partimage/Manifest b/sys-block/partimage/Manifest
index c5763260cb7c..4d387ce33a63 100644
--- a/sys-block/partimage/Manifest
+++ b/sys-block/partimage/Manifest
@@ -1,2 +1 @@
-DIST partimage-0.6.8.tar.bz2 631193 SHA256 98f91bf6baa108e390989ce963f75bc30f40ba9c6eb4e953abeedca9a6e6e4b4 SHA512 51fcfc81890b4091102b7a2f665bfba66ac15260f9ae79c45104cd5c525f6805a6f31e20e852532df3d9d9203a6f0f7e5d256e75dac8ee060dc4f1c846168cdb WHIRLPOOL f07b3e76f615c9fd889fde055c4720da5ff4fb952721a120463e7c5db56500c6bd9e20c5ebe1a4c51012e5f119929164486cb6a72d7a36e0620cb6361e0a4f19
DIST partimage-0.6.9.tar.bz2 666522 SHA256 753a6c81f4be18033faed365320dc540fe5e58183eaadcd7a5b69b096fec6635 SHA512 252885921b23933fdcdf0bb6efa4b82066b08ca95cc653296912d384ae875b421c1d39f347a90115315139176d4eab4a930c24919c2d38cf00ed29c764cd14d9 WHIRLPOOL a4e30ea6240c89b568fd5959f4d72130e3737a409270d9336e45f2c4f85c2e6c1c66b5b60abdf47aa238ec4159010cbbcc75c02c6e5a1cb309e2fceee1df7750
diff --git a/sys-block/partimage/partimage-0.6.8.ebuild b/sys-block/partimage/partimage-0.6.8.ebuild
deleted file mode 100644
index 6577a82a8905..000000000000
--- a/sys-block/partimage/partimage-0.6.8.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=3
-inherit autotools eutils flag-o-matic pam user
-
-DESCRIPTION="Console-based application to efficiently save raw partition data to an image file"
-HOMEPAGE="http://www.partimage.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE="nls nologin pam ssl static"
-
-LIBS_DEPEND="app-arch/bzip2
- >=dev-libs/newt-0.52
- >=sys-libs/slang-2
- sys-libs/zlib
- ssl? ( dev-libs/openssl )"
-PAM_DEPEND="!static? ( pam? ( virtual/pam ) )"
-RDEPEND="${PAM_DEPEND}
- !static? ( ${LIBS_DEPEND} )"
-DEPEND="${PAM_DEPEND}
- ${LIBS_DEPEND}
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- enewgroup partimag 91
- enewuser partimag 91 -1 /var/lib/partimage partimag
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-destdir.patch \
- "${FILESDIR}"/${P}-openssl-1.patch
- eautoreconf
-}
-
-src_configure() {
- # XXX: Do we still need these?
- filter-flags -fno-exceptions
- use ppc && append-flags -fsigned-char
-
- local myconf
-
- use nologin && myconf="${myconf} --disable-login"
-
- if use pam && ! use static; then
- myconf="${myconf} --enable-pam"
- fi
-
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --sysconfdir="${EPREFIX}"/etc \
- $(use_enable nls) \
- --disable-dependency-tracking \
- $(use_enable ssl) \
- --disable-pam \
- $(use_enable static all-static) \
- --with-log-dir="${EPREFIX}"/var/log/partimage \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc BOOT-ROOT.txt FORMAT FUTURE THANKS
- prepalldocs
-
- keepdir /var/lib/partimage
- keepdir /var/log/partimage
-
- insinto /etc/partimaged
- doins "${FILESDIR}"/servercert.cnf || die
-
- newinitd "${FILESDIR}"/partimaged.init partimaged || die
- newconfd "${FILESDIR}"/partimaged.conf partimaged || die
-
- if use pam; then
- newpamd "${FILESDIR}"/partimaged.pam partimaged || die
- fi
-}
-
-confdir=${ROOT}etc/partimaged
-privkey=${confdir}/partimaged.key
-cnf=${confdir}/servercert.cnf
-csr=${confdir}/partimaged.csr
-cert=${confdir}/partimaged.cert
-
-pkg_config() {
- if use ssl; then
- ewarn "Please customize /etc/partimaged/servercert.cnf before you continue!"
- ewarn "Press Ctrl-C to break now for it, or press enter to continue."
- read
- if [ ! -f ${privkey} ]; then
- einfo "Generating unencrypted private key: ${privkey}"
- openssl genrsa -out ${privkey} 1024 || die "Failed!"
- else
- einfo "Private key already exists: ${privkey}"
- fi
- if [ ! -f ${csr} ]; then
- einfo "Generating certificate request: ${csr}"
- openssl req -new -x509 -outform PEM -out ${csr} -key ${privkey} -config ${cnf} || die "Failed!"
- else
- einfo "Certificate request already exists: ${csr}"
- fi
- if [ ! -f ${cert} ]; then
- einfo "Generating self-signed certificate: ${cert}"
- openssl x509 -in ${csr} -out ${cert} -signkey ${privkey} || die "Failed!"
- else
- einfo "Self-signed certifcate already exists: ${cert}"
- fi
- einfo "Setting permissions"
- partimagesslperms || die "Failed!"
- einfo "Done"
- else
- einfo "SSL is disabled, not building certificates"
- fi
-}
-
-partimagesslperms() {
- local ret=0
- chmod 600 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chown partimag:0 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chmod 644 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- chown root:0 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- return $ret
-}
-
-pkg_postinst() {
- if use ssl; then
- einfo "To create the required SSL certificates, please do:"
- einfo "emerge --config =${PF}"
- partimagesslperms
- return 0
- fi
- chown partimag:0 "${ROOT}"etc/partimaged/partimagedusers || die
-}