summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars <polynomial-c@gentoo.org>2017-01-14 19:17:36 +0100
committerRobin H. Johnson <robbat2@gentoo.org>2017-07-10 15:22:42 -0700
commit78beda8bdbf94b62a586e38d6ac00e32180f3eb8 (patch)
treec725c2b9e5a95a2f2b2a8a0bee4013f6f2ec2a3e /sys-libs/db
parentwww-apps/moodle: version bumps to 3.1.7, 3.2.4, 3.3.1, remover older (diff)
downloadgentoo-78beda8bdbf94b62a586e38d6ac00e32180f3eb8.tar.gz
gentoo-78beda8bdbf94b62a586e38d6ac00e32180f3eb8.tar.bz2
gentoo-78beda8bdbf94b62a586e38d6ac00e32180f3eb8.zip
sys-libs/db: Security revbumps to disable usage of bundled sqlite.
This fixes Gentoo bug #605688 (cherry picked from commit 953247c8dda0eec48bf7f019583003077d008ba1) Fixes: https://bugs.gentoo.org/show_bug.cgi?id=605688 Fixes: https://github.com/gentoo/gentoo/pull/3480/ Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/db-5.3.28-r3.ebuild (renamed from sys-libs/db/db-5.3.28-r2.ebuild)6
-rw-r--r--sys-libs/db/db-6.0.35-r1.ebuild (renamed from sys-libs/db/db-6.0.35.ebuild)6
-rw-r--r--sys-libs/db/db-6.1.29-r1.ebuild (renamed from sys-libs/db/db-6.1.29.ebuild)6
-rw-r--r--sys-libs/db/db-6.2.23-r1.ebuild (renamed from sys-libs/db/db-6.2.23.ebuild)6
4 files changed, 16 insertions, 8 deletions
diff --git a/sys-libs/db/db-5.3.28-r2.ebuild b/sys-libs/db/db-5.3.28-r3.ebuild
index c9c47add3360..e5330769b212 100644
--- a/sys-libs/db/db-5.3.28-r2.ebuild
+++ b/sys-libs/db/db-5.3.28-r3.ebuild
@@ -143,6 +143,8 @@ multilib_src_configure() {
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
+ # Don't --enable-sql* because we don't want to use bundled sqlite.
+ # See Gentoo bug #605688
ECONF_SOURCE="${S_BASE}"/dist \
STRIP="true" \
econf \
@@ -150,8 +152,8 @@ multilib_src_configure() {
--enable-dbm \
--enable-o_direct \
--without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
+ --disable-sql \
+ --disable-sql_codegen \
--disable-sql_compat \
$([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
diff --git a/sys-libs/db/db-6.0.35.ebuild b/sys-libs/db/db-6.0.35-r1.ebuild
index feca1dcaa8ba..0c5fe167e084 100644
--- a/sys-libs/db/db-6.0.35.ebuild
+++ b/sys-libs/db/db-6.0.35-r1.ebuild
@@ -141,6 +141,8 @@ multilib_src_configure() {
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
+ # Don't --enable-sql* because we don't want to use bundled sqlite.
+ # See Gentoo bug #605688
ECONF_SOURCE="${S_BASE}"/dist \
STRIP="true" \
econf \
@@ -148,8 +150,8 @@ multilib_src_configure() {
--enable-dbm \
--enable-o_direct \
--without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
+ --disable-sql \
+ --disable-sql_codegen \
--disable-sql_compat \
$([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
diff --git a/sys-libs/db/db-6.1.29.ebuild b/sys-libs/db/db-6.1.29-r1.ebuild
index 75d89109cd91..1055a51317b6 100644
--- a/sys-libs/db/db-6.1.29.ebuild
+++ b/sys-libs/db/db-6.1.29-r1.ebuild
@@ -141,6 +141,8 @@ multilib_src_configure() {
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
+ # Don't --enable-sql* because we don't want to use bundled sqlite.
+ # See Gentoo bug #605688
ECONF_SOURCE="${S_BASE}"/dist \
STRIP="true" \
econf \
@@ -148,8 +150,8 @@ multilib_src_configure() {
--enable-dbm \
--enable-o_direct \
--without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
+ --disable-sql \
+ --disable-sql_codegen \
--disable-sql_compat \
$([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
diff --git a/sys-libs/db/db-6.2.23.ebuild b/sys-libs/db/db-6.2.23-r1.ebuild
index af25495f83e3..2d4ba9b44373 100644
--- a/sys-libs/db/db-6.2.23.ebuild
+++ b/sys-libs/db/db-6.2.23-r1.ebuild
@@ -146,6 +146,8 @@ multilib_src_configure() {
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
+ # Don't --enable-sql* because we don't want to use bundled sqlite.
+ # See Gentoo bug #605688
ECONF_SOURCE="${S_BASE}"/dist \
STRIP="true" \
econf \
@@ -153,8 +155,8 @@ multilib_src_configure() {
--enable-dbm \
--enable-o_direct \
--without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
+ --disable-sql \
+ --disable-sql_codegen \
--disable-sql_compat \
$([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \