summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-10-18 12:51:08 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-18 12:51:35 +0300
commit39f8f74082547a2b236b9b8b1a5728098f939d21 (patch)
tree098a0c7bd0a98215664a9e654607ffd4c303cfd2 /virtual/rust
parentdev-lang/rust: add 1.82.0, compress man pages (diff)
downloadgentoo-39f8f74082547a2b236b9b8b1a5728098f939d21.tar.gz
gentoo-39f8f74082547a2b236b9b8b1a5728098f939d21.tar.bz2
gentoo-39f8f74082547a2b236b9b8b1a5728098f939d21.zip
virtual/rust: add 1.82.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.82.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.82.0.ebuild b/virtual/rust/rust-1.82.0.ebuild
new file mode 100644
index 000000000000..2f9c39eae887
--- /dev/null
+++ b/virtual/rust/rust-1.82.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-19"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt profiler"
+
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"