summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/bugzilla
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/bugzilla')
-rw-r--r--www-apps/bugzilla/Manifest3
-rw-r--r--www-apps/bugzilla/bugzilla-4.0.15.ebuild142
-rw-r--r--www-apps/bugzilla/bugzilla-4.2.11.ebuild142
-rw-r--r--www-apps/bugzilla/bugzilla-4.4.6.ebuild142
-rw-r--r--www-apps/bugzilla/files/4.0/bugzilla-queue.confd4
-rw-r--r--www-apps/bugzilla/files/4.0/bugzilla-queue.initd39
-rw-r--r--www-apps/bugzilla/files/4.0/bugzilla.cron.daily5
-rw-r--r--www-apps/bugzilla/files/4.0/bugzilla.cron.tab1
-rw-r--r--www-apps/bugzilla/files/4.0/postinstall-en.txt13
-rw-r--r--www-apps/bugzilla/files/4.0/reconfig19
-rw-r--r--www-apps/bugzilla/metadata.xml20
11 files changed, 530 insertions, 0 deletions
diff --git a/www-apps/bugzilla/Manifest b/www-apps/bugzilla/Manifest
new file mode 100644
index 000000000000..ed04c2ba0ee7
--- /dev/null
+++ b/www-apps/bugzilla/Manifest
@@ -0,0 +1,3 @@
+DIST bugzilla-4.0.15.tar.gz 2875815 SHA256 4751da395f1d439505e07b80a36120186cf3d1f02c8505293d76eb66eeb3c779 SHA512 4394268dbf5a82e1693d63661296650155b8b44e39c69d06997c0e07fb71f1421050992b75240e13a9d149f847a38be9c354e95471c98328e3019136f2019a02 WHIRLPOOL dd81e4fa0cad2194d011d1fab15fed0b44d80be5c3f527fcf9925d4bdc93890e2994c703ee1e9fe76b2ce5f71900bbfc45d416b27cbd81f67d2dcc78edb511a8
+DIST bugzilla-4.2.11.tar.gz 2955315 SHA256 b3f94024a405469b62fb1aec47cea25fb4d52c8e6009b2723c43c7d9442c7d17 SHA512 80c400c6887e4dd15201de61651dabcf709a019c3a17323d94a845ae899bcbe43d81ca46f1ae2e41a173e1a06e4d4edc147cfd62dbce08a23df90a6f8c21631c WHIRLPOOL a1445cbd05fd9730ffbe70e2f9740e64ee9b7e5344c4ade77f7237fbefde698bd598f95af5dedabc4ca581465f6be681a700ef329216fbeec107d8c5f29f1a38
+DIST bugzilla-4.4.6.tar.gz 2956046 SHA256 ac3547195f2ce156488aac2cc537620775e08a9d888441daab2b40ab66ab01f4 SHA512 af95af117f7d5ada390a94716f1d3ed9b97e06f47c028c57635b2b4a720827e4749bee23842b7ff7d3a2ee8cc6257ccf2dc2b135c821838e78a31ceb63ce1b68 WHIRLPOOL 90daa07e1f9c064f4954d413348af958544091ffa71e27d0fb8ba7e4265a96e8d1d6e5903edd71e90ddd34f9c6a44d1cdab3e7bc2db2c97cb576182692be8743
diff --git a/www-apps/bugzilla/bugzilla-4.0.15.ebuild b/www-apps/bugzilla/bugzilla-4.0.15.ebuild
new file mode 100644
index 000000000000..b2bd4033fbc9
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-4.0.15.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp depend.apache versionator eutils
+
+#MY_PB=$(get_version_component_range 1-2)
+MY_PB="4.0"
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="modperl extras graphviz mysql postgres sqlite test"
+
+COMMON_DEPS="
+ >=dev-lang/perl-5.8.8
+
+ >=dev-perl/CGI-3.510
+ virtual/perl-Digest-SHA
+ >=dev-perl/TimeDate-1.16
+ >=dev-perl/DateTime-0.50
+ >=dev-perl/DateTime-TimeZone-0.71
+ >=dev-perl/DBI-1.601
+ >=dev-perl/Template-Toolkit-2.22
+ >=dev-perl/Email-Send-2.190
+ >=dev-perl/Email-MIME-1.904
+ dev-perl/URI
+ >=dev-perl/List-MoreUtils-0.22
+
+ virtual/perl-File-Path
+ virtual/perl-Scalar-List-Utils
+
+ >=virtual/perl-File-Spec-3.27.01
+ >=virtual/perl-MIME-Base64-3.07
+
+ dev-perl/Math-Random-Secure
+"
+
+DEPEND="test? ( ${COMMON_DEPS} )"
+RDEPEND="
+ virtual/httpd-cgi
+
+ ${COMMON_DEPS}
+
+ postgres? ( >=dev-perl/DBD-Pg-1.49 )
+ mysql? ( >=dev-perl/DBD-mysql-4.00.5 )
+ sqlite? ( >=dev-perl/DBD-SQLite-1.29 )
+
+ extras? (
+ >=dev-perl/GD-2.35[png,truetype]
+ >=dev-perl/Chart-2.4.1
+ dev-perl/Template-GD
+ dev-perl/GDTextUtil
+ dev-perl/GDGraph
+ dev-perl/XML-Twig
+ >=dev-perl/MIME-tools-5.427
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.6
+ dev-perl/perl-ldap
+ dev-perl/RadiusPerl
+ dev-perl/Authen-SASL
+ >=dev-perl/SOAP-Lite-0.712
+ dev-perl/JSON-RPC
+ >=dev-perl/JSON-XS-2.0
+ dev-perl/Test-Taint
+ >=dev-perl/HTML-Parser-3.67
+ dev-perl/HTML-Scrubber
+ >=virtual/perl-Encode-2.21
+ dev-perl/Encode-Detect
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ dev-perl/TheSchwartz
+ dev-perl/Daemon-Generic
+ dev-perl/File-MimeInfo
+
+ || ( media-gfx/imagemagick[perl] media-gfx/graphicsmagick[imagemagick,perl] )
+ dev-perl/MIME-tools
+ )
+
+ modperl? (
+ www-apache/mod_perl:1
+ >=dev-perl/Apache-SizeLimit-0.96
+ )
+
+ graphviz? ( media-gfx/graphviz )
+"
+
+# RadiusPerl for extras? bug 252128
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # Get a rid of the bzr files
+ rm -rf .bzr*
+
+ # Remove bundled perl modules
+ rm -rf lib/
+}
+
+src_test() {
+ # Shall we remove runtests.pl and t/,xt/ on install?
+ perl runtests.pl || die
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die
+ doins "${FILESDIR}"/${MY_PB}/bugzilla.cron.{daily,tab} || die
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ if use extras; then
+ newconfd "${FILESDIR}"/${MY_PB}/bugzilla-queue.confd bugzilla-queue || die
+ newinitd "${FILESDIR}"/${MY_PB}/bugzilla-queue.initd bugzilla-queue || die
+ fi
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+
+ chmod u+x "${D}${MY_HTDOCSDIR}"/jobqueue.pl
+
+ # configuration must be executable
+ chmod u+x "${D}${MY_HTDOCSDIR}"/checksetup.pl
+
+ # bug 487476
+ mkdir "${D}${MY_HTDOCSDIR}"/lib
+}
diff --git a/www-apps/bugzilla/bugzilla-4.2.11.ebuild b/www-apps/bugzilla/bugzilla-4.2.11.ebuild
new file mode 100644
index 000000000000..5a29bfb59a84
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-4.2.11.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp depend.apache versionator eutils
+
+#MY_PB=$(get_version_component_range 1-2)
+MY_PB="4.0"
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1"
+KEYWORDS="amd64 x86"
+
+IUSE="modperl extras graphviz mysql postgres sqlite test"
+
+COMMON_DEPS="
+ >=dev-lang/perl-5.8.8
+
+ >=dev-perl/CGI-3.510
+ virtual/perl-Digest-SHA
+ >=dev-perl/TimeDate-1.16
+ >=dev-perl/DateTime-0.50
+ >=dev-perl/DateTime-TimeZone-0.71
+ >=dev-perl/DBI-1.601
+ >=dev-perl/Template-Toolkit-2.22
+ >=dev-perl/Email-Send-2.190
+ >=dev-perl/Email-MIME-1.904
+ dev-perl/URI
+ >=dev-perl/List-MoreUtils-0.22
+
+ virtual/perl-File-Path
+ virtual/perl-Scalar-List-Utils
+
+ >=virtual/perl-File-Spec-3.27.01
+ >=virtual/perl-MIME-Base64-3.07
+
+ dev-perl/Math-Random-ISAAC
+"
+
+DEPEND="test? ( ${COMMON_DEPS} )"
+RDEPEND="
+ virtual/httpd-cgi
+
+ ${COMMON_DEPS}
+
+ postgres? ( >=dev-perl/DBD-Pg-1.49 )
+ mysql? ( >=dev-perl/DBD-mysql-4.00.5 )
+ sqlite? ( >=dev-perl/DBD-SQLite-1.29 )
+
+ extras? (
+ >=dev-perl/GD-2.35[png,truetype]
+ >=dev-perl/Chart-2.4.1
+ dev-perl/Template-GD
+ dev-perl/GDTextUtil
+ dev-perl/GDGraph
+ dev-perl/XML-Twig
+ >=dev-perl/MIME-tools-5.427
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.6
+ dev-perl/perl-ldap
+ dev-perl/RadiusPerl
+ dev-perl/Authen-SASL
+ >=dev-perl/SOAP-Lite-0.712
+ dev-perl/JSON-RPC
+ >=dev-perl/JSON-XS-2.0
+ dev-perl/Test-Taint
+ >=dev-perl/HTML-Parser-3.67
+ dev-perl/HTML-Scrubber
+ >=virtual/perl-Encode-2.21
+ dev-perl/Encode-Detect
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ dev-perl/TheSchwartz
+ dev-perl/Daemon-Generic
+ dev-perl/File-MimeInfo
+
+ || ( media-gfx/imagemagick[perl] media-gfx/graphicsmagick[imagemagick,perl] )
+ dev-perl/MIME-tools
+ )
+
+ modperl? (
+ www-apache/mod_perl:1
+ >=dev-perl/Apache-SizeLimit-0.96
+ )
+
+ graphviz? ( media-gfx/graphviz )
+"
+
+# RadiusPerl for extras? bug 252128
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # Get a rid of the bzr files
+ rm -rf .bzr*
+
+ # Remove bundled perl modules
+ rm -rf lib/
+}
+
+src_test() {
+ # Shall we remove runtests.pl and t/,xt/ on install?
+ perl runtests.pl || die
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die
+ doins "${FILESDIR}"/${MY_PB}/bugzilla.cron.{daily,tab} || die
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ if use extras; then
+ newconfd "${FILESDIR}"/${MY_PB}/bugzilla-queue.confd bugzilla-queue || die
+ newinitd "${FILESDIR}"/${MY_PB}/bugzilla-queue.initd bugzilla-queue || die
+ fi
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+
+ chmod u+x "${D}${MY_HTDOCSDIR}"/jobqueue.pl
+
+ # configuration must be executable
+ chmod u+x "${D}${MY_HTDOCSDIR}"/checksetup.pl
+
+ # bug 487476
+ mkdir "${D}${MY_HTDOCSDIR}"/lib
+}
diff --git a/www-apps/bugzilla/bugzilla-4.4.6.ebuild b/www-apps/bugzilla/bugzilla-4.4.6.ebuild
new file mode 100644
index 000000000000..5a29bfb59a84
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-4.4.6.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp depend.apache versionator eutils
+
+#MY_PB=$(get_version_component_range 1-2)
+MY_PB="4.0"
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1"
+KEYWORDS="amd64 x86"
+
+IUSE="modperl extras graphviz mysql postgres sqlite test"
+
+COMMON_DEPS="
+ >=dev-lang/perl-5.8.8
+
+ >=dev-perl/CGI-3.510
+ virtual/perl-Digest-SHA
+ >=dev-perl/TimeDate-1.16
+ >=dev-perl/DateTime-0.50
+ >=dev-perl/DateTime-TimeZone-0.71
+ >=dev-perl/DBI-1.601
+ >=dev-perl/Template-Toolkit-2.22
+ >=dev-perl/Email-Send-2.190
+ >=dev-perl/Email-MIME-1.904
+ dev-perl/URI
+ >=dev-perl/List-MoreUtils-0.22
+
+ virtual/perl-File-Path
+ virtual/perl-Scalar-List-Utils
+
+ >=virtual/perl-File-Spec-3.27.01
+ >=virtual/perl-MIME-Base64-3.07
+
+ dev-perl/Math-Random-ISAAC
+"
+
+DEPEND="test? ( ${COMMON_DEPS} )"
+RDEPEND="
+ virtual/httpd-cgi
+
+ ${COMMON_DEPS}
+
+ postgres? ( >=dev-perl/DBD-Pg-1.49 )
+ mysql? ( >=dev-perl/DBD-mysql-4.00.5 )
+ sqlite? ( >=dev-perl/DBD-SQLite-1.29 )
+
+ extras? (
+ >=dev-perl/GD-2.35[png,truetype]
+ >=dev-perl/Chart-2.4.1
+ dev-perl/Template-GD
+ dev-perl/GDTextUtil
+ dev-perl/GDGraph
+ dev-perl/XML-Twig
+ >=dev-perl/MIME-tools-5.427
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.6
+ dev-perl/perl-ldap
+ dev-perl/RadiusPerl
+ dev-perl/Authen-SASL
+ >=dev-perl/SOAP-Lite-0.712
+ dev-perl/JSON-RPC
+ >=dev-perl/JSON-XS-2.0
+ dev-perl/Test-Taint
+ >=dev-perl/HTML-Parser-3.67
+ dev-perl/HTML-Scrubber
+ >=virtual/perl-Encode-2.21
+ dev-perl/Encode-Detect
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ dev-perl/TheSchwartz
+ dev-perl/Daemon-Generic
+ dev-perl/File-MimeInfo
+
+ || ( media-gfx/imagemagick[perl] media-gfx/graphicsmagick[imagemagick,perl] )
+ dev-perl/MIME-tools
+ )
+
+ modperl? (
+ www-apache/mod_perl:1
+ >=dev-perl/Apache-SizeLimit-0.96
+ )
+
+ graphviz? ( media-gfx/graphviz )
+"
+
+# RadiusPerl for extras? bug 252128
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ # Get a rid of the bzr files
+ rm -rf .bzr*
+
+ # Remove bundled perl modules
+ rm -rf lib/
+}
+
+src_test() {
+ # Shall we remove runtests.pl and t/,xt/ on install?
+ perl runtests.pl || die
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die
+ doins "${FILESDIR}"/${MY_PB}/bugzilla.cron.{daily,tab} || die
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ if use extras; then
+ newconfd "${FILESDIR}"/${MY_PB}/bugzilla-queue.confd bugzilla-queue || die
+ newinitd "${FILESDIR}"/${MY_PB}/bugzilla-queue.initd bugzilla-queue || die
+ fi
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+
+ chmod u+x "${D}${MY_HTDOCSDIR}"/jobqueue.pl
+
+ # configuration must be executable
+ chmod u+x "${D}${MY_HTDOCSDIR}"/checksetup.pl
+
+ # bug 487476
+ mkdir "${D}${MY_HTDOCSDIR}"/lib
+}
diff --git a/www-apps/bugzilla/files/4.0/bugzilla-queue.confd b/www-apps/bugzilla/files/4.0/bugzilla-queue.confd
new file mode 100644
index 000000000000..2eec355a0986
--- /dev/null
+++ b/www-apps/bugzilla/files/4.0/bugzilla-queue.confd
@@ -0,0 +1,4 @@
+#JOBQUEUE_USER=bugzilla
+#JOBQUEUE_GROUP=bugzilla
+
+JOBQUEUE_PATH=/var/www/bugzilla/jobqueue.pl
diff --git a/www-apps/bugzilla/files/4.0/bugzilla-queue.initd b/www-apps/bugzilla/files/4.0/bugzilla-queue.initd
new file mode 100644
index 000000000000..f4038abd8d59
--- /dev/null
+++ b/www-apps/bugzilla/files/4.0/bugzilla-queue.initd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PIDFILE="/var/run/bugzilla/${SVCNAME}.pid"
+JOBQUEUE_USER=${JOBQUEUE_USER:-root}
+JOBQUEUE_GROUP=${JOBQUEUE_GROUP:-root}
+
+checkconfig() {
+ [[ -z "${JOBQUEUE_USER}" || -z "$(getent passwd ${JOBQUEUE_USER})" ]] && { eerror "JOBQUEUE_USER not set or doesn't exist"; return 1; }
+ [[ -z "${JOBQUEUE_GROUP}" || -z "$(getent group ${JOBQUEUE_GROUP})" ]] && { eerror "JOBQUEUE_GROUP not set or doesn't exist"; return 1; }
+ [[ -z "${JOBQUEUE_PATH}" && ! -x "${JOBQUEUE_PATH}" ]] && { eerror "JOBQUEUE_PATH not set or not executable"; return 1; }
+ return 0
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ checkconfig || return 1
+
+ piddir="${PIDFILE%/*}"
+ if [ ! -d "${piddir}" ]; then
+ checkpath -q -d -o $JOBQUEUE_USER:$JOBQUEUE_GROUP -m 0770 "${piddir}" || {
+ eend 1
+ return 1
+ }
+ fi
+
+ start-stop-daemon --start --pidfile $PIDFILE --user $JOBQUEUE_USER --group $JOBQUEUE_GROUP \
+ --exec $JOBQUEUE_PATH -- -p $PIDFILE -n $SVCNAME start 1>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ checkconfig || return 1
+ start-stop-daemon --pidfile $PIDFILE --stop --exec $JOBQUEUE_PATH -- -p $PIDFILE -n $SVCNAME stop
+ eend $?
+}
diff --git a/www-apps/bugzilla/files/4.0/bugzilla.cron.daily b/www-apps/bugzilla/files/4.0/bugzilla.cron.daily
new file mode 100644
index 000000000000..e3e86589891d
--- /dev/null
+++ b/www-apps/bugzilla/files/4.0/bugzilla.cron.daily
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla/
+./collectstats.pl
+./whineatnews.pl
+echo "*** Bugzilla nighlty flush has done! ***"
diff --git a/www-apps/bugzilla/files/4.0/bugzilla.cron.tab b/www-apps/bugzilla/files/4.0/bugzilla.cron.tab
new file mode 100644
index 000000000000..3cf2d4a66240
--- /dev/null
+++ b/www-apps/bugzilla/files/4.0/bugzilla.cron.tab
@@ -0,0 +1 @@
+0 0 * * * /var/www/bugzilla/bugzilla.cron.daily
diff --git a/www-apps/bugzilla/files/4.0/postinstall-en.txt b/www-apps/bugzilla/files/4.0/postinstall-en.txt
new file mode 100644
index 000000000000..2d18de0b810f
--- /dev/null
+++ b/www-apps/bugzilla/files/4.0/postinstall-en.txt
@@ -0,0 +1,13 @@
+0. Bugzilla has been installed into ${MY_INSTALLDIR}
+
+1. To finish the installation, please read
+ http://www.bugzilla.org/docs/${MY_PB}/en/html/installing-bugzilla.html
+ You will need to run ${MY_INSTALLDIR}/checksetup.pl
+
+2. Please read the Release Notes, especially if you are upgrading:
+ http://www.bugzilla.org/releases/${MY_PB}/release-notes.html
+
+3. Please note that Apache2 sets AllowOverride None by default. You may have
+ to edit it to process the .htaccess file provided by Bugzilla. Please see
+ http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride and
+ http://www.bugzilla.org/docs/${MY_PB}/en/html/configuration.html#http for more info.
diff --git a/www-apps/bugzilla/files/4.0/reconfig b/www-apps/bugzilla/files/4.0/reconfig
new file mode 100644
index 000000000000..71b0acea2585
--- /dev/null
+++ b/www-apps/bugzilla/files/4.0/reconfig
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+FILE="bugzilla.cron.daily bugzilla.cron.tab"
+
+function die ()
+{
+ echo
+ echo "***"
+ echo "*** Fatal error: $*"
+ echo "***"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ cd "${MY_INSTALLDIR}" || die "Cannot find install dir ${MY_INSTALLDIR}"
+ sed -e "s|/var/www/bugzilla|${MY_INSTALLDIR}|g" -i ${FILE} || die "sed failed"
+else
+ echo "done."
+fi
diff --git a/www-apps/bugzilla/metadata.xml b/www-apps/bugzilla/metadata.xml
new file mode 100644
index 000000000000..5a628ae30a39
--- /dev/null
+++ b/www-apps/bugzilla/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>andrew@ahamilto.net</email>
+ <name>Andrew Hamilton</name>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <herd>web-apps</herd>
+ <herd>proxy-maintainers</herd>
+ <use>
+ <flag name="extras">Optional Perl modules</flag>
+ <flag name="modperl">Enable <pkg>www-apache/mod_perl</pkg> support</flag>
+ </use>
+</pkgmetadata>