summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-06-08 09:08:43 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-09 09:37:56 +0200
commit70a9bf22d1224acaea489501a8894f00ddd78e19 (patch)
tree8c6a1f050a443d8a1216e9f164fb138df627d209 /www-client
parentwww-client/surf: add xdg desktop entry (diff)
downloadgentoo-70a9bf22d1224acaea489501a8894f00ddd78e19.tar.gz
gentoo-70a9bf22d1224acaea489501a8894f00ddd78e19.tar.bz2
gentoo-70a9bf22d1224acaea489501a8894f00ddd78e19.zip
www-client/surf: sync live
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/25810 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/surf/surf-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index 49c122b93dac..236324b24ec6 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit savedconfig toolchain-funcs desktop xdg
-DESCRIPTION="a simple web browser based on WebKit/GTK+"
+inherit desktop savedconfig toolchain-funcs xdg
+
+DESCRIPTION="A simple web browser based on WebKit/GTK+"
HOMEPAGE="https://surf.suckless.org/"
if [[ ${PV} == "9999" ]] ; then
@@ -74,12 +75,12 @@ src_install() {
save_config config.h
- newicon "${S}"/"${PN}".png "${PN}".png
+ newicon "${S}/${PN}.png" "${PN}.png"
local mime_types="text/html;text/xml;application/xhtml+xml;"
mime_types+="x-scheme-handler/http;x-scheme-handler/https;"
make_desktop_entry \
- "surf" \
+ "surf %u" \
"Surf" \
"surf" \
"Network;WebBrowser" \