summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-08 10:02:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-08 10:16:14 -0400
commitf7ea967d210c66a14adf12c5c6b177a76aba6b1b (patch)
treecb269af91ed375001a2553dad40123dc78f11da4 /x11-drivers
parentdev-util/cucumber-rails: enable ruby32 (diff)
downloadgentoo-f7ea967d210c66a14adf12c5c6b177a76aba6b1b.tar.gz
gentoo-f7ea967d210c66a14adf12c5c6b177a76aba6b1b.tar.bz2
gentoo-f7ea967d210c66a14adf12c5c6b177a76aba6b1b.zip
x11-drivers/nvidia-drivers: drop additional framebuffer/drm warnings
Warnings were mostly added to help the transition to newer kernels for unsuspecting users. May have helped in some cases, not in others. But with 6.1.x being stable for a while, there's little reason to keep this wall of warnings *here* and try to keep it accurate and updated -- especially when we can't tell what's really in-use or what the user needs (this was just vague suggestions). For initial setting up issues, it sounds better to refer to the Wiki. So if anyone has anything to share with their experience with FB (or other issues) feel free to edit it and improve it so it can help others. Also drop the "builtin" nouveau check that was part of this block. Module is already blacklisted and, if users went out of their way to make it builtin, then let's assume they know what they're doing. Closing #910058 but rather than a fix it's more of a dissociation. Closes: https://bugs.gentoo.org/910058 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild68
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild68
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild68
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.47.27.ebuild68
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild68
5 files changed, 15 insertions, 325 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
index 44a0ef4ec290..9abc49b88f6b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
@@ -103,69 +103,6 @@ pkg_setup() {
kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
linux-mod-r1_pkg_setup
-
- # do some extra checks manually as it gets messy to handle builtin-only
- # and some other conditional checks through CONFIG_CHECK
- # TODO?: maybe move other custom checks here for uniformity
- local warn=()
-
- if linux_chkconfig_builtin DRM_NOUVEAU; then
- # suggest =m given keeps KMS_HELPER enabled and can serve as fallback
- warn+=(
- " CONFIG_DRM_NOUVEAU: is builtin (=y), and will prevent loading NVIDIA"
- " modules (can be safely kept as a module (=m) instead)."
- )
- fi
-
- if linux_chkconfig_builtin DRM_SIMPLEDRM; then
- # wrt prebuilts, Fedora is pushing =y and gentoo-kernel-bin uses its
- # configs (bug #840439), but without Fedora's kernel patch to
- # workaround this issue (which is unlikely to work for us anyway)
- # https://github.com/NVIDIA/open-gpu-kernel-modules/issues/228
- warn+=(
- " CONFIG_DRM_SIMPLEDRM: is builtin (=y), and may conflict with NVIDIA"
- " (i.e. blanks when X/wayland starts, and tty loses display)."
- " For prebuilt kernels, unfortunately no known good workarounds."
- )
- fi
-
- if ! linux_chkconfig_present FB_EFI &&
- ! linux_chkconfig_present FB_SIMPLE &&
- ! linux_chkconfig_present FB_VESA
- then
- # nvidia-drivers does not handle the tty (beside mode restoration) but,
- # given few options are viable, try to warn if all missing
- warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
- " needed to get a display for the tty console. In most cases, it is"
- " recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
- " or not using the tty may be able to safely ignore this warning."
- )
- fi
-
- if kernel_is -ge 5 18 13; then
- if linux_chkconfig_present FB_SIMPLE; then
- warn+=(
- " CONFIG_FB_SIMPLE: is set, recommended to disable and switch to FB_EFI or"
- " FB_VESA as it currently may be broken with >=kernel-5.18.13 + NVIDIA:"
- " https://github.com/NVIDIA/open-gpu-kernel-modules/issues/341"
- " (feel free to ignore this if it works for you)"
- )
- fi
-
- if linux_chkconfig_present SYSFB_SIMPLEFB &&
- { linux_chkconfig_present FB_EFI || linux_chkconfig_present FB_VESA; }
- then
- warn+=(
- " CONFIG_SYSFB_SIMPLEFB: is set, this may prevent FB_EFI or FB_VESA"
- " from providing a working tty console display (ignore if unused)."
- )
- fi
- fi
-
- (( ${#warn[@]} )) &&
- ewarn "Detected potential configuration issues with used kernel:${warn[*]/#/$'\n'}"
}
src_prepare() {
@@ -323,8 +260,9 @@ If wish to continue using this hardware, should consider switching
to the Nouveau open source driver.
https://nvidia.custhelp.com/app/answers/detail/a_id/3142/
-For general information on using ${PN}, please see:
-https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+For additional information or for troubleshooting issues, please see
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers and NVIDIA's own
+documentation that is installed alongside this README."
readme.gentoo_create_doc
if use modules; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild
index 885d53d2f474..9236174320c5 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.199.02.ebuild
@@ -107,69 +107,6 @@ pkg_setup() {
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
linux-mod-r1_pkg_setup
-
- # do some extra checks manually as it gets messy to handle builtin-only
- # and some other conditional checks through CONFIG_CHECK
- # TODO?: maybe move other custom checks here for uniformity
- local warn=()
-
- if linux_chkconfig_builtin DRM_NOUVEAU; then
- # suggest =m given keeps KMS_HELPER enabled and can serve as fallback
- warn+=(
- " CONFIG_DRM_NOUVEAU: is builtin (=y), and will prevent loading NVIDIA"
- " modules (can be safely kept as a module (=m) instead)."
- )
- fi
-
- if linux_chkconfig_builtin DRM_SIMPLEDRM; then
- # wrt prebuilts, Fedora is pushing =y and gentoo-kernel-bin uses its
- # configs (bug #840439), but without Fedora's kernel patch to
- # workaround this issue (which is unlikely to work for us anyway)
- # https://github.com/NVIDIA/open-gpu-kernel-modules/issues/228
- warn+=(
- " CONFIG_DRM_SIMPLEDRM: is builtin (=y), and may conflict with NVIDIA"
- " (i.e. blanks when X/wayland starts, and tty loses display)."
- " For prebuilt kernels, unfortunately no known good workarounds."
- )
- fi
-
- if ! linux_chkconfig_present FB_EFI &&
- ! linux_chkconfig_present FB_SIMPLE &&
- ! linux_chkconfig_present FB_VESA
- then
- # nvidia-drivers does not handle the tty (beside mode restoration) but,
- # given few options are viable, try to warn if all missing
- warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
- " needed to get a display for the tty console. In most cases, it is"
- " recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
- " or not using the tty may be able to safely ignore this warning."
- )
- fi
-
- if kernel_is -ge 5 18 13; then
- if linux_chkconfig_present FB_SIMPLE; then
- warn+=(
- " CONFIG_FB_SIMPLE: is set, recommended to disable and switch to FB_EFI or"
- " FB_VESA as it currently may be broken with >=kernel-5.18.13 + NVIDIA:"
- " https://github.com/NVIDIA/open-gpu-kernel-modules/issues/341"
- " (feel free to ignore this if it works for you)"
- )
- fi
-
- if linux_chkconfig_present SYSFB_SIMPLEFB &&
- { linux_chkconfig_present FB_EFI || linux_chkconfig_present FB_VESA; }
- then
- warn+=(
- " CONFIG_SYSFB_SIMPLEFB: is set, this may prevent FB_EFI or FB_VESA"
- " from providing a working tty console display (ignore if unused)."
- )
- fi
- fi
-
- (( ${#warn[@]} )) &&
- ewarn "Detected potential configuration issues with used kernel:${warn[*]/#/$'\n'}"
}
src_prepare() {
@@ -303,8 +240,9 @@ $(use amd64 && usev !abi_x86_32 "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
(typically using wine / steam) will not be able to use GPU acceleration.")
-For general information on using ${PN}, please see:
-https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+For additional information or for troubleshooting issues, please see
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers and NVIDIA's own
+documentation that is installed alongside this README."
readme.gentoo_create_doc
if use modules; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild
index 61453ca0a97d..270d42f08bfc 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.125.06.ebuild
@@ -116,69 +116,6 @@ pkg_setup() {
selection of another option that requires it such as CONFIG_KVM."
linux-mod-r1_pkg_setup
-
- # do some extra checks manually as it gets messy to handle builtin-only
- # and some other conditional checks through CONFIG_CHECK
- # TODO?: maybe move other custom checks here for uniformity
- local warn=()
-
- if linux_chkconfig_builtin DRM_NOUVEAU; then
- # suggest =m given keeps KMS_HELPER enabled and can serve as fallback
- warn+=(
- " CONFIG_DRM_NOUVEAU: is builtin (=y), and will prevent loading NVIDIA"
- " modules (can be safely kept as a module (=m) instead)."
- )
- fi
-
- if linux_chkconfig_builtin DRM_SIMPLEDRM; then
- # wrt prebuilts, Fedora is pushing =y and gentoo-kernel-bin uses its
- # configs (bug #840439), but without Fedora's kernel patch to
- # workaround this issue (which is unlikely to work for us anyway)
- # https://github.com/NVIDIA/open-gpu-kernel-modules/issues/228
- warn+=(
- " CONFIG_DRM_SIMPLEDRM: is builtin (=y), and may conflict with NVIDIA"
- " (i.e. blanks when X/wayland starts, and tty loses display)."
- " For prebuilt kernels, unfortunately no known good workarounds."
- )
- fi
-
- if ! linux_chkconfig_present FB_EFI &&
- ! linux_chkconfig_present FB_SIMPLE &&
- ! linux_chkconfig_present FB_VESA
- then
- # nvidia-drivers does not handle the tty (beside mode restoration) but,
- # given few options are viable, try to warn if all missing
- warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
- " needed to get a display for the tty console. In most cases, it is"
- " recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
- " or not using the tty may be able to safely ignore this warning."
- )
- fi
-
- if kernel_is -ge 5 18 13; then
- if linux_chkconfig_present FB_SIMPLE; then
- warn+=(
- " CONFIG_FB_SIMPLE: is set, recommended to disable and switch to FB_EFI or"
- " FB_VESA as it currently may be broken with >=kernel-5.18.13 + NVIDIA:"
- " https://github.com/NVIDIA/open-gpu-kernel-modules/issues/341"
- " (feel free to ignore this if it works for you)"
- )
- fi
-
- if linux_chkconfig_present SYSFB_SIMPLEFB &&
- { linux_chkconfig_present FB_EFI || linux_chkconfig_present FB_VESA; }
- then
- warn+=(
- " CONFIG_SYSFB_SIMPLEFB: is set, this may prevent FB_EFI or FB_VESA"
- " from providing a working tty console display (ignore if unused)."
- )
- fi
- fi
-
- (( ${#warn[@]} )) &&
- ewarn "Detected potential configuration issues with used kernel:${warn[*]/#/$'\n'}"
}
src_prepare() {
@@ -348,8 +285,9 @@ $(use amd64 && usev !abi_x86_32 "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
(typically using wine / steam) will not be able to use GPU acceleration.")
-For general information on using ${PN}, please see:
-https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+For additional information or for troubleshooting issues, please see
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers and NVIDIA's own
+documentation that is installed alongside this README."
readme.gentoo_create_doc
if use modules; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.27.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.27.ebuild
index 0528f317bbca..1afcffb0421d 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.27.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.27.ebuild
@@ -117,69 +117,6 @@ pkg_setup() {
selection of another option that requires it such as CONFIG_KVM."
linux-mod-r1_pkg_setup
-
- # do some extra checks manually as it gets messy to handle builtin-only
- # and some other conditional checks through CONFIG_CHECK
- # TODO?: maybe move other custom checks here for uniformity
- local warn=()
-
- if linux_chkconfig_builtin DRM_NOUVEAU; then
- # suggest =m given keeps KMS_HELPER enabled and can serve as fallback
- warn+=(
- " CONFIG_DRM_NOUVEAU: is builtin (=y), and will prevent loading NVIDIA"
- " modules (can be safely kept as a module (=m) instead)."
- )
- fi
-
- if linux_chkconfig_builtin DRM_SIMPLEDRM; then
- # wrt prebuilts, Fedora is pushing =y and gentoo-kernel-bin uses its
- # configs (bug #840439), but without Fedora's kernel patch to
- # workaround this issue (which is unlikely to work for us anyway)
- # https://github.com/NVIDIA/open-gpu-kernel-modules/issues/228
- warn+=(
- " CONFIG_DRM_SIMPLEDRM: is builtin (=y), and may conflict with NVIDIA"
- " (i.e. blanks when X/wayland starts, and tty loses display)."
- " For prebuilt kernels, unfortunately no known good workarounds."
- )
- fi
-
- if ! linux_chkconfig_present FB_EFI &&
- ! linux_chkconfig_present FB_SIMPLE &&
- ! linux_chkconfig_present FB_VESA
- then
- # nvidia-drivers does not handle the tty (beside mode restoration) but,
- # given few options are viable, try to warn if all missing
- warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
- " needed to get a display for the tty console. In most cases, it is"
- " recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
- " or not using the tty may be able to safely ignore this warning."
- )
- fi
-
- if kernel_is -ge 5 18 13; then
- if linux_chkconfig_present FB_SIMPLE; then
- warn+=(
- " CONFIG_FB_SIMPLE: is set, recommended to disable and switch to FB_EFI or"
- " FB_VESA as it currently may be broken with >=kernel-5.18.13 + NVIDIA:"
- " https://github.com/NVIDIA/open-gpu-kernel-modules/issues/341"
- " (feel free to ignore this if it works for you)"
- )
- fi
-
- if linux_chkconfig_present SYSFB_SIMPLEFB &&
- { linux_chkconfig_present FB_EFI || linux_chkconfig_present FB_VESA; }
- then
- warn+=(
- " CONFIG_SYSFB_SIMPLEFB: is set, this may prevent FB_EFI or FB_VESA"
- " from providing a working tty console display (ignore if unused)."
- )
- fi
- fi
-
- (( ${#warn[@]} )) &&
- ewarn "Detected potential configuration issues with used kernel:${warn[*]/#/$'\n'}"
}
src_prepare() {
@@ -349,8 +286,9 @@ $(use amd64 && usev !abi_x86_32 "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
(typically using wine / steam) will not be able to use GPU acceleration.")
-For general information on using ${PN}, please see:
-https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+For additional information or for troubleshooting issues, please see
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers and NVIDIA's own
+documentation that is installed alongside this README."
readme.gentoo_create_doc
if use modules; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
index 1e24166af1ae..66b37eefdede 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-535.54.03.ebuild
@@ -119,69 +119,6 @@ pkg_setup() {
selection of another option that requires it such as CONFIG_KVM."
linux-mod-r1_pkg_setup
-
- # do some extra checks manually as it gets messy to handle builtin-only
- # and some other conditional checks through CONFIG_CHECK
- # TODO?: maybe move other custom checks here for uniformity
- local warn=()
-
- if linux_chkconfig_builtin DRM_NOUVEAU; then
- # suggest =m given keeps KMS_HELPER enabled and can serve as fallback
- warn+=(
- " CONFIG_DRM_NOUVEAU: is builtin (=y), and will prevent loading NVIDIA"
- " modules (can be safely kept as a module (=m) instead)."
- )
- fi
-
- if linux_chkconfig_builtin DRM_SIMPLEDRM; then
- # wrt prebuilts, Fedora is pushing =y and gentoo-kernel-bin uses its
- # configs (bug #840439), but without Fedora's kernel patch to
- # workaround this issue (which is unlikely to work for us anyway)
- # https://github.com/NVIDIA/open-gpu-kernel-modules/issues/228
- warn+=(
- " CONFIG_DRM_SIMPLEDRM: is builtin (=y), and may conflict with NVIDIA"
- " (i.e. blanks when X/wayland starts, and tty loses display)."
- " For prebuilt kernels, unfortunately no known good workarounds."
- )
- fi
-
- if ! linux_chkconfig_present FB_EFI &&
- ! linux_chkconfig_present FB_SIMPLE &&
- ! linux_chkconfig_present FB_VESA
- then
- # nvidia-drivers does not handle the tty (beside mode restoration) but,
- # given few options are viable, try to warn if all missing
- warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
- " needed to get a display for the tty console. In most cases, it is"
- " recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
- " or not using the tty may be able to safely ignore this warning."
- )
- fi
-
- if kernel_is -ge 5 18 13; then
- if linux_chkconfig_present FB_SIMPLE; then
- warn+=(
- " CONFIG_FB_SIMPLE: is set, recommended to disable and switch to FB_EFI or"
- " FB_VESA as it currently may be broken with >=kernel-5.18.13 + NVIDIA:"
- " https://github.com/NVIDIA/open-gpu-kernel-modules/issues/341"
- " (feel free to ignore this if it works for you)"
- )
- fi
-
- if linux_chkconfig_present SYSFB_SIMPLEFB &&
- { linux_chkconfig_present FB_EFI || linux_chkconfig_present FB_VESA; }
- then
- warn+=(
- " CONFIG_SYSFB_SIMPLEFB: is set, this may prevent FB_EFI or FB_VESA"
- " from providing a working tty console display (ignore if unused)."
- )
- fi
- fi
-
- (( ${#warn[@]} )) &&
- ewarn "Detected potential configuration issues with used kernel:${warn[*]/#/$'\n'}"
}
src_prepare() {
@@ -356,8 +293,9 @@ $(use amd64 && usev !abi_x86_32 "
Note that without USE=abi_x86_32 on ${PN}, 32bit applications
(typically using wine / steam) will not be able to use GPU acceleration.")
-For general information on using ${PN}, please see:
-https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+For additional information or for troubleshooting issues, please see
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers and NVIDIA's own
+documentation that is installed alongside this README."
readme.gentoo_create_doc
if use modules; then