summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-21 04:19:01 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:47 +0000
commitc6ef20a641c29e61dc540afdc086c7abf7f39f93 (patch)
treeffa5a49961053c09e030410c4fe8a4ce7ca4af5c /x11-themes
parentx11-wm/marco: add 1.27.0 (diff)
downloadgentoo-c6ef20a641c29e61dc540afdc086c7abf7f39f93.tar.gz
gentoo-c6ef20a641c29e61dc540afdc086c7abf7f39f93.tar.bz2
gentoo-c6ef20a641c29e61dc540afdc086c7abf7f39f93.zip
x11-themes/mate-icon-theme: add 1.27.0
Closes: https://bugs.gentoo.org/906549 Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/mate-icon-theme/Manifest1
-rw-r--r--x11-themes/mate-icon-theme/mate-icon-theme-1.27.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme/Manifest b/x11-themes/mate-icon-theme/Manifest
index a4f0014777fa..392d7848a649 100644
--- a/x11-themes/mate-icon-theme/Manifest
+++ b/x11-themes/mate-icon-theme/Manifest
@@ -1 +1,2 @@
DIST mate-icon-theme-1.26.0.tar.xz 21872216 BLAKE2B 9acccace3483a7e8d4a2958bc14119a42f76dcdad2c455d0f3f10653cc689ed3a4cca7d122474b2bff0b5100e586ea5fabf137a1d9b11545eeaa84745d9d576b SHA512 937d65710c1b7cc79ba0b71cd1a480597f20035380ffd5f0528c45c86bc8963189116d2c02332352170b7cd12fba5dd91f94cee9626104ab55c576d58f0636b8
+DIST mate-icon-theme-1.27.0.tar.xz 21875136 BLAKE2B d86603cad3ddb3df40fadcc752ac43bf1271cb2e860eb37906fbf12c6eb2e3dd19b6600769374910a22ad41fa72481efa52f13d2235fb3e9ea1fe773fb15de0d SHA512 aa2fad6d56c3ba60053fb0363dc1d944bb3797968ebf1c728890cc841bcc617b94d8c963cb590a215aaa7a24e8e92cbdcd7b7834369f1792dda8cfffd244f6ce
diff --git a/x11-themes/mate-icon-theme/mate-icon-theme-1.27.0.ebuild b/x11-themes/mate-icon-theme/mate-icon-theme-1.27.0.ebuild
new file mode 100644
index 000000000000..b755e9788798
--- /dev/null
+++ b/x11-themes/mate-icon-theme/mate-icon-theme-1.27.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE default icon themes"
+LICENSE="GPL-2"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+RESTRICT="binchecks strip"
+
+src_configure() {
+ mate_src_configure --enable-icon-mapping
+}