summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/vacuum/Manifest1
-rw-r--r--net-im/vacuum/vacuum-1.3.0_pre20180105.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/net-im/vacuum/Manifest b/net-im/vacuum/Manifest
index 949259c12b5a..e5af4287f2e2 100644
--- a/net-im/vacuum/Manifest
+++ b/net-im/vacuum/Manifest
@@ -1 +1,2 @@
DIST vacuum-1.2.5.tar.gz 2242073 BLAKE2B 3c326fa38422e99ecc1edaca51932dbb18a8cefdbc757f6b39099ec5af07a07094f3d961ec98c65eb9c4b5e4937d6c5a4d814095b8257b5a95e94c68077f9259 SHA512 85e36ed312beb59b667f376d45511f3c9414ba8165746cc1da15992eac4716995aa01da505a2f2dd58c8d64822f25c9106691be26a534e01a21f0201049300fc
+DIST vacuum-im-1.3.0.20180105-Alpha.tar.gz 2658247 BLAKE2B 823984f49687805c8e859984d6dfc9afcbdff864eef2f81825562dca11281286d5e736a986ed40e10bb915b7ee4f972dba10b073ea738cd8153f887c74b89f1b SHA512 83d830494c272145c3ad923ebb2897a8ab6323a301bdd0fc2b972f84b246e2de4eff29a93d92da97ed4deb6018c52e38e6fc5941c54722e1c37de207bca0c687
diff --git a/net-im/vacuum/vacuum-1.3.0_pre20180105.ebuild b/net-im/vacuum/vacuum-1.3.0_pre20180105.ebuild
new file mode 100644
index 000000000000..0b60a4d2b10a
--- /dev/null
+++ b/net-im/vacuum/vacuum-1.3.0_pre20180105.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="de es pl ru uk"
+
+inherit cmake-utils l10n
+
+MY_PN="${PN}-im"
+MY_PV="${PV/_pre/.}-Alpha"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Qt Crossplatform Jabber client"
+HOMEPAGE="http://www.vacuum-im.org/"
+SRC_URI="https://github.com/Vacuum-IM/${MY_PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/37" # subslot = libvacuumutils soname version
+KEYWORDS="~amd64 ~x86"
+PLUGINS=( adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver messagecarbons multiuserchat pepmanager privacylists privatestorage recentcontacts registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries )
+SPELLCHECKER_BACKENDS="aspell +enchant hunspell"
+IUSE="${PLUGINS[@]/#/+} ${SPELLCHECKER_BACKENDS} +spell"
+
+REQUIRED_USE="
+ annotations? ( privatestorage )
+ avatars? ( vcard )
+ birthdayreminder? ( vcard )
+ bookmarks? ( privatestorage )
+ captchaforms? ( dataforms )
+ commands? ( dataforms )
+ datastreamsmanager? ( dataforms )
+ filemessagearchive? ( messagearchiver )
+ filestreamsmanager? ( datastreamsmanager )
+ filetransfer? ( filestreamsmanager datastreamsmanager )
+ messagecarbons? ( servicediscovery )
+ pepmanager? ( servicediscovery )
+ recentcontacts? ( privatestorage )
+ registration? ( dataforms )
+ remotecontrol? ( commands dataforms )
+ servermessagearchive? ( messagearchiver )
+ sessionnegotiation? ( dataforms )
+ spell? ( ^^ ( ${SPELLCHECKER_BACKENDS//+/} ) )
+"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtlockedfile[qt5(+)]
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ net-dns/libidn
+ sys-libs/zlib[minizip]
+ x11-libs/libXScrnSaver
+ adiummessagestyle? ( dev-qt/qtwebkit:5 )
+ filemessagearchive? ( dev-qt/qtsql:5[sqlite] )
+ messagearchiver? ( dev-qt/qtsql:5[sqlite] )
+ spell? (
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )
+ hunspell? ( app-text/hunspell )
+ )
+"
+RDEPEND="${DEPEND}
+ !net-im/vacuum-spellchecker
+"
+
+DOCS=( AUTHORS CHANGELOG README TRANSLATORS )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Force usage of system libraries
+ rm -rf src/thirdparty/{hunspell,idn,minizip,qtlockedfile,zlib} || die
+
+ # Supress find thirdparty library in the system
+ sed -i -r -e "/find_library.+qxtglobalshortcut/d" \
+ CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="$(get_libdir)"
+ -DINSTALL_SDK=ON
+ -DLANGS="$(l10n_get_locales)"
+ -DINSTALL_DOCS=OFF
+ -DFORCE_BUNDLED_MINIZIP=OFF
+ -DPLUGIN_statistics=OFF
+ -DPLUGIN_spellchecker=$(usex spell)
+ )
+
+ for x in ${PLUGINS[@]}; do
+ mycmakeargs+=( -DPLUGIN_${x}=$(usex $x) )
+ done
+
+ for i in ${SPELLCHECKER_BACKENDS//+/}; do
+ use "${i}" && mycmakeargs+=( -DSPELLCHECKER_BACKEND="${i}" )
+ done
+
+ cmake-utils_src_configure
+}