summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.08.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index d6ec315950e3..dce27fda226f 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,3 +1,4 @@
DIST dolphin-plugins-23.08.5.tar.xz 274124 BLAKE2B c8b43bd7f87c7221023e75e3f66b450844b379d5bfc95e37ce01dfe983ba3dc234a319da2aaf0596e6eb54319bc4310c718b57d52d070f0f86cd67c6f67a8c4b SHA512 2dd30070660df63b988cda2e14f3ddc27a0cf451119d2a6b121cb9cbeb8788b94498ef25ca434501843784a8e24c4539fe17cc0ab5a158befbc9db5792944852
DIST dolphin-plugins-24.05.2.tar.xz 305512 BLAKE2B 4f5a2b8e7e7131d55610622669398c537f5ef2a0f69bdcce431d28efd1784e31bd57fccabe93d380d38b7cfbbedb0f7ef79deb6de297deba57420373767c9a38 SHA512 7e8df3f14f0db6114a85e3077a515ea598f436d52ce6d199ead97119604455e06cc8585281cd2aa49068134505bce8bcce461976fad791d5729d278344a30c56
DIST dolphin-plugins-24.08.0.tar.xz 316660 BLAKE2B 00140dcea345f15caa0bbb50845ad4719cf92420c505ad510c505e9e7a4d0ea8aeb4cd23133bca0f44de34bbf98704545eb9c28f34d5fc8988f2b2154e3db8c2 SHA512 8d72253ecf3b44b4a81ff4ab952913683b2b679220620f153dae4b045e008faccc768e40e48d6dbf41a49a15409e4fa728feee30decbf2a4a35741bf9db87fa3
+DIST dolphin-plugins-24.08.1.tar.xz 317532 BLAKE2B 1f8bbcbcf79ca80e0744cbf5a1ecc4507d1e222c6ef179e01aac62361625d550702d014e28bb409d87cafad5bd57ae5d25bbc289177685681e84aa4261ac4b17 SHA512 d123197d4669611f0d12ad128967686d11b865865472028e60916e85bc4f0a5159e023a2784cba04e069ea5dbd9fd0801617b73e4033cffe1f6d815895aac59c
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.08.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.08.1.ebuild
new file mode 100644
index 000000000000..69481f3fa6cc
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.08.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.5.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}