summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/lpe')
-rw-r--r--app-editors/lpe/Manifest1
-rw-r--r--app-editors/lpe/files/lpe-1.2.6.13-make-382.patch23
-rw-r--r--app-editors/lpe/lpe-1.2.6.13.ebuild50
-rw-r--r--app-editors/lpe/metadata.xml7
4 files changed, 81 insertions, 0 deletions
diff --git a/app-editors/lpe/Manifest b/app-editors/lpe/Manifest
new file mode 100644
index 000000000000..ce44a2747e8e
--- /dev/null
+++ b/app-editors/lpe/Manifest
@@ -0,0 +1 @@
+DIST lpe_1.2.6.13-0.1.tar.gz 600523 SHA256 7828147e8b8bcf518e6d7f2241b480fe3bbaa1285d3c7c74b8c7160222d76816 SHA512 f02769baca396285fe8f98c934f6274185d2bf8b08f3b007cbfa4e6aadb455abfb7cab13d53a3d1fa71ea0c29c4222784dcbc9a7508501c7d1839671503758ed WHIRLPOOL 885c1eaace95a47a78017a3ccf04c6cb053e14978f153270608175a6d3c5e0332d95556a0cafeb9f41abcaf36fe77acd36bf9ebf618bfbfe92de711cbf2262cc
diff --git a/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
new file mode 100644
index 000000000000..f8d96ef087e9
--- /dev/null
+++ b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/335324
+
+--- intl/Makefile.in
++++ intl/Makefile.in
+@@ -202,12 +202,12 @@
+ # The dependency for intlh.inst is different in gettext and all other
+ # packages. Because we cannot you GNU make features we have to solve
+ # the problem while rewriting Makefile.in.
+-@GT_YES@intlh.inst: intlh.inst.in ../config.status
+-@GT_YES@ cd .. \
+-@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
+-@GT_YES@ $(SHELL) ./config.status
+-@GT_NO@.PHONY: intlh.inst
+-@GT_NO@intlh.inst:
++intlh.inst: intlh.inst.in ../config.status
++ cd .. \
++ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
++ $(SHELL) ./config.status
++.PHONY: intlh.inst
++intlh.inst:
+
+ # Tell versions [3.59,3.63) of GNU make not to export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/app-editors/lpe/lpe-1.2.6.13.ebuild b/app-editors/lpe/lpe-1.2.6.13.ebuild
new file mode 100644
index 000000000000..914b1cb8b9ff
--- /dev/null
+++ b/app-editors/lpe/lpe-1.2.6.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a lightweight programmers editor"
+HOMEPAGE="http://packages.qa.debian.org/l/lpe.html"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}-0.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-linux"
+IUSE="nls"
+
+RDEPEND=">=sys-libs/slang-2.2.4
+ >=sys-libs/ncurses-5.7-r7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make-382.patch
+
+ # You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
+ # replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
+ # That is, if you need eautoreconf
+ sed -i \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs-only-l ncurses):" \
+ src/Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake \
+ libdir="${ED}/usr/$(get_libdir)" \
+ prefix="${ED}/usr" \
+ datadir="${ED}/usr/share" \
+ mandir="${ED}/usr/share/man" \
+ infodir="${ED}/usr/share/info" \
+ docdir="${ED}/usr/share/doc/${PF}" \
+ exdir="${ED}/usr/share/doc/${PF}/examples" \
+ install
+
+ prune_libtool_files --all
+}
diff --git a/app-editors/lpe/metadata.xml b/app-editors/lpe/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-editors/lpe/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>