summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/apheleia')
-rw-r--r--app-emacs/apheleia/Manifest1
-rw-r--r--app-emacs/apheleia/apheleia-4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/apheleia/Manifest b/app-emacs/apheleia/Manifest
index cfbd3ad05e0d..f5188edab336 100644
--- a/app-emacs/apheleia/Manifest
+++ b/app-emacs/apheleia/Manifest
@@ -1 +1,2 @@
DIST apheleia-4.0.tar.gz 170327 BLAKE2B 82e5b545045ef8e5e17dd6930efe21c6eb5d04f6e22d0ce07e13af7c09237b93c09ff756e8e024751ecfc46d0809e408bfdc14e192cd9ded5cce955cd67a66bb SHA512 5cc5a12a8418372ade1ba968e34d8eae067d2c3401aeabd860b562a66a6efd1cc1b21eba6ff1d1e96a4e7aff18d26097e8758774f3fa2d5e663bdb9407647936
+DIST apheleia-4.1.tar.gz 178011 BLAKE2B c48b9f98e7d985b8a6a30c8945ce92d512eecd9b8ec5403f26870ca3a38cefb40d35e7757875964898e537eb65b48d85573be909685dc4dc06f56584d989b1e7 SHA512 37e946651aa084cf322eaa45c3fd72cc3d6089da237b2ce02f2ba5481eb60c63030b654c78a614c70943b2825df184249ac8fe53a013f75cde54c31062dd0c6b
diff --git a/app-emacs/apheleia/apheleia-4.1.ebuild b/app-emacs/apheleia/apheleia-4.1.ebuild
new file mode 100644
index 000000000000..86c631d1652c
--- /dev/null
+++ b/app-emacs/apheleia/apheleia-4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="Reformat GNU Emacs buffers stably without moving point"
+HOMEPAGE="https://github.com/radian-software/apheleia/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/radian-software/${PN}.git"
+else
+ SRC_URI="https://github.com/radian-software/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md CHANGELOG.md )
+SITEFILE="50${PN}-gentoo.el"