summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/4store/4store-1.1.5-r1.ebuild2
-rw-r--r--dev-db/cdb/cdb-0.75-r4.ebuild9
-rw-r--r--dev-db/henplus/henplus-0.9.8-r1.ebuild4
-rw-r--r--dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild6
-rw-r--r--dev-db/hyperdex/hyperdex-1.7.1.ebuild6
-rw-r--r--dev-db/hyperdex/hyperdex-1.8.0.ebuild6
-rw-r--r--dev-db/hyperdex/hyperdex-1.8.1.ebuild6
-rw-r--r--dev-db/hyperdex/hyperdex-9999.ebuild6
-rw-r--r--dev-db/libodbc++/libodbc++-0.2.5-r2.ebuild3
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.9.2.ebuild2
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild8
11 files changed, 28 insertions, 30 deletions
diff --git a/dev-db/4store/4store-1.1.5-r1.ebuild b/dev-db/4store/4store-1.1.5-r1.ebuild
index cbbefd39efa2..bc3835b91931 100644
--- a/dev-db/4store/4store-1.1.5-r1.ebuild
+++ b/dev-db/4store/4store-1.1.5-r1.ebuild
@@ -39,7 +39,7 @@ src_install() {
# patch the Makefiles to use /usr/ instead of /usr/local/
find . -name "Makefile" -execdir sed -e "s#/usr/local/#/usr/#" -i {} \;
- MAKEOPTS="-j1" emake DESTDIR="${D}" install || die "emake install failed"
+ MAKEOPTS="-j1" emake DESTDIR="${D}" install
dodir /var/log/4store
fowners fourstore:fourstore \
diff --git a/dev-db/cdb/cdb-0.75-r4.ebuild b/dev-db/cdb/cdb-0.75-r4.ebuild
index 89db70153cf3..4ba24d9d243a 100644
--- a/dev-db/cdb/cdb-0.75-r4.ebuild
+++ b/dev-db/cdb/cdb-0.75-r4.ebuild
@@ -32,21 +32,20 @@ src_configure() {
}
src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest \
- || die "dobin failed"
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest
# ok so ... first off, some automakes fail at finding
# cdb.a, so install that now
- dolib *.a || die "dolib failed"
+ dolib *.a
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "dosym failed"
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a
# uint32.h needs installation too, otherwise compiles depending
# on it will fail
insinto /usr/include/cdb
- doins cdb*.h buffer.h alloc.h uint32.h || die "doins failed"
+ doins cdb*.h buffer.h alloc.h uint32.h
dodoc CHANGES FILES README SYSDEPS TODO VERSION
}
diff --git a/dev-db/henplus/henplus-0.9.8-r1.ebuild b/dev-db/henplus/henplus-0.9.8-r1.ebuild
index a1d41261fac3..c42f56c5c950 100644
--- a/dev-db/henplus/henplus-0.9.8-r1.ebuild
+++ b/dev-db/henplus/henplus-0.9.8-r1.ebuild
@@ -35,8 +35,8 @@ src_install () {
java-pkg_dolauncher ${PN} -pre "${FILESDIR}/${PN}.pre" \
--main henplus.HenPlus
- dodoc README || die
- dohtml doc/HenPlus.html || die
+ dodoc README
+ dohtml doc/HenPlus.html
use doc && java-pkg_dojavadoc javadoc/api
use source && java-pkg_dosrc "src/${PN}"
diff --git a/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild b/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
index ba8e0bd4d3de..0a3b4c5bc249 100644
--- a/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
@@ -54,8 +54,8 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex
find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
}
diff --git a/dev-db/hyperdex/hyperdex-1.7.1.ebuild b/dev-db/hyperdex/hyperdex-1.7.1.ebuild
index ba8e0bd4d3de..0a3b4c5bc249 100644
--- a/dev-db/hyperdex/hyperdex-1.7.1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.7.1.ebuild
@@ -54,8 +54,8 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex
find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
}
diff --git a/dev-db/hyperdex/hyperdex-1.8.0.ebuild b/dev-db/hyperdex/hyperdex-1.8.0.ebuild
index 107843edc025..de31c1703020 100644
--- a/dev-db/hyperdex/hyperdex-1.8.0.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.8.0.ebuild
@@ -55,9 +55,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex
find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
}
diff --git a/dev-db/hyperdex/hyperdex-1.8.1.ebuild b/dev-db/hyperdex/hyperdex-1.8.1.ebuild
index 107843edc025..de31c1703020 100644
--- a/dev-db/hyperdex/hyperdex-1.8.1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.8.1.ebuild
@@ -55,9 +55,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex
find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
}
diff --git a/dev-db/hyperdex/hyperdex-9999.ebuild b/dev-db/hyperdex/hyperdex-9999.ebuild
index d1d8b48d8504..24f6526f77b6 100644
--- a/dev-db/hyperdex/hyperdex-9999.ebuild
+++ b/dev-db/hyperdex/hyperdex-9999.ebuild
@@ -52,8 +52,8 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Failed to install"
- newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
- newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex
find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
}
diff --git a/dev-db/libodbc++/libodbc++-0.2.5-r2.ebuild b/dev-db/libodbc++/libodbc++-0.2.5-r2.ebuild
index 2ff9b64fa4bf..ca2d04023a40 100644
--- a/dev-db/libodbc++/libodbc++-0.2.5-r2.ebuild
+++ b/dev-db/libodbc++/libodbc++-0.2.5-r2.ebuild
@@ -74,8 +74,7 @@ src_configure() {
#--without-qt \
econf \
${commonconf} \
- ${commonconf2} \
- || die "econf failed"
+ ${commonconf2}
done
}
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.9.2.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.9.2.ebuild
index fbece53dcc9b..1bf18d49625f 100644
--- a/dev-db/phpmyadmin/phpmyadmin-4.9.2.ebuild
+++ b/dev-db/phpmyadmin/phpmyadmin-4.9.2.ebuild
@@ -37,7 +37,7 @@ pkg_setup() {
src_install() {
webapp_src_preinst
- dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog
rm -f LICENSE README* RELEASE-DATE-${MY_PV}
if ! use setup; then
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
index a7c0ed8ebb55..5ce9ea0274ad 100644
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
@@ -42,19 +42,19 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ emake DESTDIR="${D}" install
if use examples; then
insinto /usr/share/${PF}/example
- doins example/* || die "Install failed"
+ doins example/*
fi
if use doc; then
insinto /usr/share/doc/${PF}
- doins -r doc/* || die "Install failed"
+ doins -r doc/*
fi
}
src_test() {
- emake -j1 check || die "Tests failed"
+ emake -j1 check
}