summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/conway-polynomials')
-rw-r--r--dev-python/conway-polynomials/Manifest1
-rw-r--r--dev-python/conway-polynomials/conway-polynomials-0.10.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/conway-polynomials/Manifest b/dev-python/conway-polynomials/Manifest
index 21c10c107e81..cf82c7974e30 100644
--- a/dev-python/conway-polynomials/Manifest
+++ b/dev-python/conway-polynomials/Manifest
@@ -1 +1,2 @@
DIST conway-polynomials-0.9.tar.gz 245106 BLAKE2B 3b44b337151428a18f8fc01bfa92ffe4019d2427242efed3a9edec93e2054f706ad3735505a5d90382a1c4c8e9846080de1d34538f053ba2ccda88e91fcc5fc6 SHA512 15f0dcd69f2ffb78f4f4a7d8e11ac0e37fb23bea124778b24a4bff228a00f2f09e830e49225f0b574869f88e9c90e9114921e240eb462c10071c124d04fe90a2
+DIST conway_polynomials-0.10.tar.gz 307447 BLAKE2B f079041954dc280204ae7d0dcb467c1cd982ff1f4a46eb8193ae3bb20c47f7394c1f5de31dd573f240a89b9e2f174d97744af944ce498cd6a6cc029389ca7517 SHA512 8ddaea35ba5974cea7ede93c5fde8d481a484cd5c5c2d310e64a7fb9bb22f6781a36cc30d1e75fc79c47af2241b34102cff60e5776963859bfee5f3799772fc8
diff --git a/dev-python/conway-polynomials/conway-polynomials-0.10.ebuild b/dev-python/conway-polynomials/conway-polynomials-0.10.ebuild
new file mode 100644
index 000000000000..a60b97eac7be
--- /dev/null
+++ b/dev-python/conway-polynomials/conway-polynomials-0.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to Frank Lübeck's Conway polynomial database"
+HOMEPAGE="
+ https://github.com/sagemath/conway-polynomials/
+ https://pypi.org/project/conway-polynomials/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest