summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/robot_localization/files')
-rw-r--r--dev-ros/robot_localization/files/nowerror.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-ros/robot_localization/files/nowerror.patch b/dev-ros/robot_localization/files/nowerror.patch
index 936ad259bc6f..31feb81abecd 100644
--- a/dev-ros/robot_localization/files/nowerror.patch
+++ b/dev-ros/robot_localization/files/nowerror.patch
@@ -1,13 +1,13 @@
-Index: robot_localization-2.6.2/CMakeLists.txt
+Index: robot_localization-2.6.8/CMakeLists.txt
===================================================================
---- robot_localization-2.6.2.orig/CMakeLists.txt
-+++ robot_localization-2.6.2/CMakeLists.txt
-@@ -36,7 +36,7 @@ if(NOT EIGEN3_FOUND)
- set(EIGEN_PACKAGE Eigen)
- endif()
+--- robot_localization-2.6.8.orig/CMakeLists.txt
++++ robot_localization-2.6.8/CMakeLists.txt
+@@ -44,7 +44,7 @@ endif()
+ set(CMAKE_CXX_STANDARD 14)
--set_directory_properties(PROPERTIES COMPILE_OPTIONS "-std=c++14;-Wall;-Werror")
-+set_directory_properties(PROPERTIES COMPILE_OPTIONS "-std=c++14;-Wall")
+ if(NOT MSVC)
+- set_directory_properties(PROPERTIES COMPILE_OPTIONS "-Wall;-Werror")
++ set_directory_properties(PROPERTIES COMPILE_OPTIONS "-Wall")
+ endif()
add_definitions(-DEIGEN_NO_DEBUG -DEIGEN_MPL2_ONLY)
- set(ROSLINT_CPP_OPTS "--filter=-build/c++11,-runtime/references")