summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo/bigloo-4.4c_p4-r2.ebuild (renamed from dev-scheme/bigloo/bigloo-4.4c_p4-r1.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-scheme/bigloo/bigloo-4.4c_p4-r1.ebuild b/dev-scheme/bigloo/bigloo-4.4c_p4-r2.ebuild
index 0d56b78e294e..32f3aac80a14 100644
--- a/dev-scheme/bigloo/bigloo-4.4c_p4-r1.ebuild
+++ b/dev-scheme/bigloo/bigloo-4.4c_p4-r2.ebuild
@@ -132,6 +132,13 @@ src_configure() {
ebegin "Configuring Bigloo with the following options: ${myconf[@]}"
sh ./configure "${myconf[@]}"
eend $? || die "configure script failed"
+
+ # When Emacs version is too high (e.g. 28) bigloo will skip compiling
+ # and installing the Emacs support files.
+ # The file "bmacs/Makefile" lists all officially supported Emacs versions.
+ if use emacs ; then
+ sed "/^EMACSBRAND=/s|generic|emacs23|" -i Makefile.config || die
+ fi
}
src_compile() {