summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone-durandal/Manifest1
-rw-r--r--games-fps/alephone-durandal/alephone-durandal-20240822.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/alephone-durandal/Manifest b/games-fps/alephone-durandal/Manifest
index 8c577f82cfda..1bca1ae10ee3 100644
--- a/games-fps/alephone-durandal/Manifest
+++ b/games-fps/alephone-durandal/Manifest
@@ -1 +1,2 @@
DIST Marathon2-20221126-Data.zip 29711060 BLAKE2B aa65a575a2b36a9b07cfc978042aa31485e2e02de7886fc7505ca430e7c8e67d1b2b9a77578777abe1042192f82bd7a40f2ab5e848d6a5d4a2e48ddd0b8f075d SHA512 18911eb415b66d6a698c56a6343eb319d9fd2baa34b408d26e0800f2028e0a5724556530beda8660b5f6b071e1544ad7ee59307888e6d021c7628c295e813147
+DIST Marathon2-20240822-Data.zip 28902408 BLAKE2B a0b2f0c565bd11b0f9360198f121d86ada6d76b2a49cce95a46285674135ec79ecaa267305804b167130603f791956c1aed03d653f1a0768301bdb5148b0e718 SHA512 65cedbc20b70f2ae6382e5dfa28cf1c108c4726b75d7c25fccae8e0d29a0cf60e8bdc8eca23fb4224131527e5be3dca732f4af22389ca61b2e531121969589db
diff --git a/games-fps/alephone-durandal/alephone-durandal-20240822.ebuild b/games-fps/alephone-durandal/alephone-durandal-20240822.ebuild
new file mode 100644
index 000000000000..2de0830a6d26
--- /dev/null
+++ b/games-fps/alephone-durandal/alephone-durandal-20240822.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon 2 (Durandal)"
+HOMEPAGE="https://alephone.lhowon.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon2-${PV}-Data.zip"
+S="${WORKDIR}/Marathon 2"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="durandal"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}