summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch')
-rw-r--r--media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch b/media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch
deleted file mode 100644
index ac73d82f9c34..000000000000
--- a/media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -Naur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-01-08 22:16:00.493079361 +0800
-+++ b/CMakeLists.txt 2020-01-08 22:16:44.790285583 +0800
-@@ -252,6 +252,8 @@
-
- enable_testing()
-
-+INCLUDE ( GNUInstallDirs )
-+
- # Add our cmake modules
-
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
-diff -Naur a/openvdb/CMakeLists.txt b/openvdb/CMakeLists.txt
---- a/openvdb/CMakeLists.txt 2020-01-08 22:16:07.362646127 +0800
-+++ b/openvdb/CMakeLists.txt 2020-01-08 22:19:54.638308684 +0800
-@@ -492,7 +492,7 @@
- install(TARGETS
- openvdb_static
- DESTINATION
-- lib
-+ ${CMAKE_INSTALL_LIBDIR}
- )
- endif()
-
-@@ -500,14 +500,14 @@
- if(WIN32)
- install(TARGETS
- openvdb_shared
-- RUNTIME DESTINATION bin COMPONENT Runtime
-- ARCHIVE DESTINATION lib COMPONENT Runtime
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT Runtime
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Runtime
- )
- else()
- install(TARGETS
- openvdb_shared
- DESTINATION
-- lib
-+ ${CMAKE_INSTALL_LIBDIR}
- )
- endif()
- endif()
-diff -Naur a/openvdb/python/CMakeLists.txt b/openvdb/python/CMakeLists.txt
---- a/openvdb/python/CMakeLists.txt 2020-01-08 22:16:14.452199013 +0800
-+++ b/openvdb/python/CMakeLists.txt 2020-01-08 22:21:45.311324663 +0800
-@@ -232,7 +232,7 @@
- ${PYOPENVDB_INSTALL_DIRECTORY}
- )
-
--install(FILES ${PYTHON_PUBLIC_INCLUDE_NAMES} DESTINATION include/openvdb/python)
-+install(FILES ${PYTHON_PUBLIC_INCLUDE_NAMES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/openvdb/python)
-
- # pytest
-