summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/netpbm')
-rw-r--r--media-libs/netpbm/Manifest1
-rw-r--r--media-libs/netpbm/files/netpbm-11.8.2-fix-C23.patch241
-rw-r--r--media-libs/netpbm/netpbm-11.8.2.ebuild259
3 files changed, 501 insertions, 0 deletions
diff --git a/media-libs/netpbm/Manifest b/media-libs/netpbm/Manifest
index 37680d806ee2..0dc817942a01 100644
--- a/media-libs/netpbm/Manifest
+++ b/media-libs/netpbm/Manifest
@@ -1,2 +1,3 @@
DIST netpbm-11.2.11.tar.xz 3782252 BLAKE2B 422b9cefee2a54a9c222236935291f0c8d1f13f064f4ebd277d0f92974b9ce3d7e3d9ae6a0410d767553704a03c2de14ca8456996a53fca0f95d61f9ae72605f SHA512 3d94c0c8c25873a16c78af960c964f5756b3e7a29463f001345956acc3bf1378b0b0b4fc0c57d7388dced0979ba4e8cee0def2200092544dd96fc7d04304660b
DIST netpbm-11.8.1.tar.xz 3804004 BLAKE2B ed107d258a85c720de178a3e6488ad1b435135ec50227bb1e4ce9f3665a882a382c3a3e858e49055f88ee9bba6026b390291ad211a82299d03f41addaf93e7f9 SHA512 e4b1e8d7468fcd0233e50861e890669c788f95924edb6b6256f93b53d2ab16b7fd2c2099ca238b409fba7c764e51d54a9fbdbb22bb3bb1acf8296afdb807bd4f
+DIST netpbm-11.8.2.tar.xz 3804800 BLAKE2B 9b5bb460c2fbe73495cbb304ea0e1a2a4406838cbb4d0769d2b8147f9ee6156d93852ad36a5ea57a7437b9a1a3cc9f102271163bc4d6bbd004c42c7f81be2318 SHA512 b048b242891cbe56851b3da342de1717e1ab435a327b4eeebb83023e2e7ae57ae66a232df344b4d2b0fb12bc6abcf13d9cec392f19ff06951023ee4c002f9f17
diff --git a/media-libs/netpbm/files/netpbm-11.8.2-fix-C23.patch b/media-libs/netpbm/files/netpbm-11.8.2-fix-C23.patch
new file mode 100644
index 000000000000..c6aaf0288261
--- /dev/null
+++ b/media-libs/netpbm/files/netpbm-11.8.2-fix-C23.patch
@@ -0,0 +1,241 @@
+https://sourceforge.net/p/netpbm/code/4969/
+https://bugs.gentoo.org/943971
+
+--- a/buildtools/libopt.c
++++ b/buildtools/libopt.c
+@@ -85,18 +85,11 @@
+ # define SHLIBPREFIXLIST "lib"
+ #endif
+
++#include <stdbool.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+
+-typedef unsigned char bool;
+-#ifndef TRUE
+-#define TRUE (1)
+-#endif
+-#ifndef FALSE
+-#define FALSE (0)
+-#endif
+-
+ #ifdef DLLVERSTR
+ static const char * dllverstr = DLLVERSTR;
+ #else
+@@ -105,9 +98,9 @@
+
+ bool const explicit =
+ #ifdef EXPLICIT
+-TRUE
++true
+ #else
+-FALSE
++false
+ #endif
+ ;
+
+@@ -132,17 +125,17 @@
+ there is guaranteed always to be one null string at the end of the
+ array.
+
+- In case of error, return *errorP == TRUE and don't allocate any
+- storage. Otherwise, return *errorP = FALSE.
++ In case of error, return *errorP == true and don't allocate any
++ storage. Otherwise, return *errorP = false.
+ -----------------------------------------------------------------------------*/
+ char * prlist;
+
+ prlist = strdup(prefixlist);
+ if (prlist == NULL)
+- *errorP = TRUE;
++ *errorP = true;
+ else {
+ if (strlen(prlist) <= 0)
+- *errorP = TRUE;
++ *errorP = true;
+ else {
+ /* NOTE: Mac OS X, at least, does not have strtok_r().
+ 2001.09.24
+@@ -156,11 +149,11 @@
+ }
+ num_tokens = 0;
+ token = strtok(prlist, " ");
+- *errorP = FALSE; /* initial value */
++ *errorP = false; /* initial value */
+ while (token != NULL && num_tokens < MAX_PREFIXES && !*errorP) {
+ parsed_prefixes[num_tokens] = strdup (token);
+ if (parsed_prefixes[num_tokens] == NULL)
+- *errorP = TRUE;
++ *errorP = true;
+ num_tokens++;
+ token = strtok(NULL, " ");
+ }
+@@ -167,7 +160,7 @@
+ for (i = num_tokens; i < MAX_PREFIXES + 1 && !*errorP; i++) {
+ parsed_prefixes[i] = strdup("");
+ if (parsed_prefixes[i] == NULL)
+- *errorP = TRUE;
++ *errorP = true;
+ }
+ }
+ if (*errorP) {
+@@ -195,7 +188,7 @@
+ (The prefix always starts at the beginning of the filename).
+
+ Iff we don't find a valid library name prefix, return *prefix_good_p
+- == FALSE.
++ == false.
+
+ The list of valid prefixes is compiled in as the blank-delimited
+ string which is the value of the SHLIBPREFIXLIST macro.
+@@ -232,7 +225,7 @@
+ i = 0; /* start with the first entry in shlibprefixlist[] */
+ prefix_length = 0; /* initial value */
+ prefix = shlibprefixlist[i];
+- prefix_good = FALSE; /* initial value */
++ prefix_good = false; /* initial value */
+ while ( (*prefix != '\0' ) && !prefix_good ) {
+ /* stop condition: shlibprefixlist has MAX_PREFIXES+1 entries.
+ * we only ever put tokens in the 0..MAX_PREFIXES-1 positions.
+@@ -243,7 +236,7 @@
+ */
+ prefix_length = strlen(prefix);
+ if (strncmp(filename, prefix, prefix_length) == 0) {
+- prefix_good = TRUE;
++ prefix_good = true;
+ /* at this point, prefix is pointing to the correct
+ * entry, and prefix_length has the correct value.
+ * When we bail out of the while loop because of the
+@@ -280,16 +273,16 @@
+
+ E.g. for "libxyz.so", return "xyz".
+
+- return *valid_library_p == TRUE iff 'filename' validly names a library
++ return *valid_library_p == true iff 'filename' validly names a library
+ that can be expressed in a -l linker option.
+
+- return *static_p == TRUE iff 'filename' indicates a static library.
+- (but undefined if *valid_library_p != TRUE).
++ return *static_p == true iff 'filename' indicates a static library.
++ (but undefined if *valid_library_p != true).
+
+- return *error_p == TRUE iff some error such as out of memory prevents
++ return *error_p == true iff some error such as out of memory prevents
+ parsing.
+
+- Do not allocate any memory if *error_p == TRUE or *valid_library_p == FALSE.
++ Do not allocate any memory if *error_p == true or *valid_library_p == false.
+ -----------------------------------------------------------------------------*/
+ char *lastdot;
+ /* Pointer to last period in 'filename'. Null if none */
+@@ -306,21 +299,21 @@
+ /* This filename doesn't have any suffix, so we don't understand
+ it as a library filename.
+ */
+- *valid_library_p = FALSE;
+- *error_p = FALSE;
++ *valid_library_p = false;
++ *error_p = false;
+ } else {
+ unsigned int prefix_length;
+ bool prefix_good;
+
+ if (strcmp(lastdot + 1, "a") == 0)
+- *static_p = TRUE;
++ *static_p = true;
+ else
+- *static_p = FALSE;
++ *static_p = false;
+
+ parse_prefix(filename, &prefix_good, &prefix_length, error_p);
+ if (!*error_p) {
+ if (!prefix_good) {
+- *valid_library_p = FALSE;
++ *valid_library_p = false;
+ } else {
+ /* Extract everything between <prefix> and "." as
+ the library name root.
+@@ -329,7 +322,7 @@
+
+ libname = strdup(filename + prefix_length);
+ if (libname == NULL)
+- *error_p = TRUE;
++ *error_p = true;
+ else {
+ libname[lastdot - filename - prefix_length] = '\0';
+ if (strlen(dllverstr) > 0) {
+@@ -342,10 +335,10 @@
+ }
+ }
+ if (strlen(libname) == 0) {
+- *valid_library_p = FALSE;
++ *valid_library_p = false;
+ strfree(libname);
+ } else
+- *valid_library_p = TRUE;
++ *valid_library_p = true;
+ }
+ *libname_p = libname;
+ }
+@@ -378,14 +371,14 @@
+ */
+ *filename_p = strdup(filepath);
+ if (*filename_p == NULL)
+- *error_p = TRUE;
++ *error_p = true;
+ else {
+ directory = strdup("");
+ if (directory == NULL) {
+- *error_p = TRUE;
++ *error_p = true;
+ strfree(*filename_p);
+ } else
+- *error_p = FALSE;
++ *error_p = false;
+ }
+ } else {
+ /* Split the string at the slash we just found, into filename and
+@@ -393,14 +386,14 @@
+ */
+ *filename_p = strdup(lastslash+1);
+ if (*filename_p == NULL)
+- *error_p = TRUE;
++ *error_p = true;
+ else {
+ directory = strdup(filepath);
+ if (directory == NULL) {
+- *error_p = TRUE;
++ *error_p = true;
+ strfree(*filename_p);
+ } else {
+- *error_p = FALSE;
++ *error_p = false;
+ directory[lastslash - filepath] = '\0';
+ }
+ }
+@@ -504,12 +497,12 @@
+ char outputLine[1024];
+
+ strcpy(outputLine, ""); /* initial value */
+- runtime = FALSE; /* initial value */
+- error = FALSE; /* no error yet */
++ runtime = false; /* initial value */
++ error = false; /* no error yet */
+
+ for (arg = 1; arg < argc && !error; arg++) {
+ if (strcmp(argv[arg], "-runtime") == 0)
+- runtime = TRUE;
++ runtime = true;
+ else if (strcmp(argv[arg], "-quiet") == 0) {
+ /* Doesn't do anything today */
+ } else {
+@@ -519,7 +512,7 @@
+ if (!error) {
+ if (strlen(outputLine) + strlen(options) + 1 + 1 >
+ sizeof(outputLine))
+- error = TRUE;
++ error = true;
+ else {
+ strcat(outputLine, " ");
+ strcat(outputLine, options);
diff --git a/media-libs/netpbm/netpbm-11.8.2.ebuild b/media-libs/netpbm/netpbm-11.8.2.ebuild
new file mode 100644
index 000000000000..98f2becc519a
--- /dev/null
+++ b/media-libs/netpbm/netpbm-11.8.2.ebuild
@@ -0,0 +1,259 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic multilib toolchain-funcs
+
+# Upstream has 3 flavors of netpbm: super stable, stable and advanced.
+# They only provide a tarball for super stable, but super stable is a bit lagging.
+# So we package the stable branch of their svn (currently versions 11.2.xx) on SLOT "0/stable"
+# and the advanced branch of their svn (currently versions 11.8.yy) on SLOT "0/advanced".
+# The stable branch is stabilized according to usual Gentoo rules, while the
+# advanced branch will not be stabilized.
+# A detailed explanation is here https://netpbm.sourceforge.net/release.html
+
+DESCRIPTION="A set of utilities for converting to/from the netpbm (and related) formats"
+HOMEPAGE="https://netpbm.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="Artistic BSD GPL-2 IJG LGPL-2.1 MIT public-domain"
+SLOT="0/advanced"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="jbig jpeg png postscript rle cpu_flags_x86_sse2 static-libs svga tiff X xml"
+
+# app-text/ghostscript-gpl is really needed for postscript
+# some utilities execute /usr/bin/gs
+# some installed programs are perl scripts
+RDEPEND="
+ dev-lang/perl
+ jbig? ( media-libs/jbigkit:= )
+ jpeg? ( media-libs/libjpeg-turbo:=[static-libs?] )
+ png? (
+ >=media-libs/libpng-1.4:0=
+ sys-libs/zlib
+ )
+ postscript? (
+ app-text/ghostscript-gpl
+ sys-libs/zlib
+ )
+ rle? ( media-libs/urt:= )
+ svga? ( media-libs/svgalib )
+ tiff? ( >=media-libs/tiff-3.5.5:= )
+ xml? ( dev-libs/libxml2 )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-arch/xz-utils
+ app-alternatives/lex
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/netpbm-10.86.21-build.patch
+ "${FILESDIR}"/netpbm-11.0.0-misc-deps.patch
+ "${FILESDIR}"/netpbm-11.1.0-fix-clang-O2.patch
+ "${FILESDIR}"/netpbm-11.6.1-incompatible-pointer-types.patch
+ "${FILESDIR}"/netpbm-11.7.2-lto.patch
+ "${FILESDIR}"/netpbm-11.8.2-fix-C23.patch
+)
+
+netpbm_libtype() {
+ case ${CHOST} in
+ *-darwin*) echo dylib;;
+ *) echo unixshared;;
+ esac
+}
+
+netpbm_libsuffix() {
+ local suffix=$(get_libname)
+ echo ${suffix//\.}
+}
+
+netpbm_ldshlib() {
+ case ${CHOST} in
+ *-darwin*) echo '$(LDFLAGS) -dynamiclib -install_name $(SONAME)';;
+ *) echo '$(LDFLAGS) -shared -Wl,-soname,$(SONAME)';;
+ esac
+}
+
+netpbm_config_lib() {
+ usex ${1} -l${2:-$1} NONE
+}
+
+# for bug #828127
+netpbm_cflags_for_build() {
+ if is-flagq -fPIC; then
+ echo -fPIC
+ fi
+}
+
+src_prepare() {
+ default
+
+ # make sure we use system libs
+ sed '/SUPPORT_SUBDIRS/s:urt::' -i GNUmakefile || die
+ rm -r urt converter/other/jbig/libjbig converter/other/jpeg2000/libjasper || die
+
+ # take care of the importinc stuff ourselves by only doing it once
+ # at the top level and having all subdirs use that one set #149843
+ sed \
+ -e '/^importinc:/s|^|importinc:\nmanual_|' \
+ -e '/-Iimportinc/s|-Iimp|-I"$(BUILDDIR)"/imp|g'\
+ -i common.mk || die
+ sed \
+ -e '/%.c/s: importinc$::' \
+ -i common.mk lib/Makefile lib/util/Makefile || die
+ sed \
+ -e 's:pkg-config:$(PKG_CONFIG):' \
+ -i GNUmakefile converter/other/Makefile other/pamx/Makefile || die
+
+ # The postscript knob is currently bound up with a fork test.
+ if ! use postscript ; then
+ sed \
+ -e 's:$(DONT_HAVE_PROCESS_MGMT):Y:' \
+ -i converter/other/Makefile generator/Makefile || die
+ sed -r \
+ -e 's:(pbmtextps|pnmtops|pstopnm).*::' \
+ -i test/all-in-place.{ok,test} || die
+ sed \
+ -e 's:lps-roundtrip.*::' \
+ -e 's:pbmtextps-dump.*::' \
+ -e 's:pbmtextps.*::' \
+ -i test/Test-Order || die
+ sed \
+ -e '/^$/d' \
+ -i test/all-in-place.ok || die
+ sed \
+ '2iexit 80' \
+ -i test/ps-{alt-,flate-,}roundtrip.test || die
+ fi
+
+ # Do not test png if not built
+ if ! use png ; then
+ sed -E \
+ -e 's:(pamtopng|pngtopam|pnmtopng).*::' \
+ -i test/all-in-place.{ok,test} || die
+ sed \
+ -e '/^$/d' \
+ -i test/all-in-place.ok || die
+
+ sed -E \
+ -e 's:(pamrgbatopng|pngtopnm).*::' \
+ -i test/legacy-names.{ok,test} || die
+ sed \
+ -e '/^$/d' \
+ -i test/legacy-names.ok || die
+ sed \
+ -e 's:png-roundtrip.*::' \
+ -e 's:winicon-roundtrip.*::' \
+ -i test/Test-Order || die
+ fi
+
+ # pbmtext-iso88591 requires LC_ALL=en_US.iso88591, not available on musl
+ # pbmtext-utf8 requires locale, not available on musl
+ # ppmpat-random and pnmindex are broken on musl
+ # bug #907295
+ if use elibc_musl; then
+ sed \
+ -e 's:pbmtext-iso88591.*::' \
+ -e 's:pbmtext-utf8.*::' \
+ -e 's:ppmpat-random.*::' \
+ -e 's:pnmindex.*::' \
+ -i test/Test-Order || die
+ fi
+}
+
+src_configure() {
+ cat config.mk.in - >> config.mk <<-EOF || die "writing config.mk failed"
+ # Misc stuff
+ BUILD_FIASCO = N
+ SYMLINK = ln -sf
+
+ # These vars let src_test work by default
+ PKGDIR_DEFAULT = ${T}/netpbm
+ RESULTDIR_DEFAULT = ${T}/netpbm-test
+
+ # Toolchain options
+ CC = $(tc-getCC) -Wall
+ LD = \$(CC)
+ CC_FOR_BUILD = $(tc-getBUILD_CC)
+ LD_FOR_BUILD = \$(CC_FOR_BUILD)
+ AR = $(tc-getAR)
+ RANLIB = $(tc-getRANLIB)
+ PKG_CONFIG = $(tc-getPKG_CONFIG)
+
+ STRIPFLAG =
+ CFLAGS_SHLIB = -fPIC
+ CFLAGS_FOR_BUILD += $(netpbm_cflags_for_build)
+
+ LDRELOC = \$(LD) -r
+ LDSHLIB = $(netpbm_ldshlib)
+ LINKER_CAN_DO_EXPLICIT_LIBRARY = N # we can, but dont want to
+ LINKERISCOMPILER = Y
+ NETPBMLIBSUFFIX = $(netpbm_libsuffix)
+ NETPBMLIBTYPE = $(netpbm_libtype)
+ STATICLIB_TOO = $(usex static-libs Y N)
+
+ # The var is called SSE, but the code is actually SSE2.
+ WANT_SSE = $(usex cpu_flags_x86_sse2 Y N)
+
+ # Gentoo build options
+ TIFFLIB = $(netpbm_config_lib tiff)
+ # Let tiff worry about its own dependencies #395753
+ TIFFLIB_NEEDS_JPEG = N
+ TIFFLIB_NEEDS_Z = N
+ JPEGLIB = $(netpbm_config_lib jpeg)
+ PNGLIB = $(netpbm_config_lib png)
+ ZLIB = $($(tc-getPKG_CONFIG) --libs zlib)
+ LINUXSVGALIB = $(netpbm_config_lib svga vga)
+ XML2_LIBS = $(netpbm_config_lib xml xml2)
+ JBIGLIB = $(netpbm_config_lib jbig)
+ JBIGHDR_DIR =
+ JASPERLIB = NONE
+ JASPERHDR_DIR =
+ URTLIB = $(netpbm_config_lib rle)
+ URTHDR_DIR =
+ X11LIB = $(netpbm_config_lib X X11)
+ X11HDR_DIR =
+ EOF
+}
+
+src_compile() {
+ emake -j1 pm_config.h version.h manual_importinc #149843
+ emake
+}
+
+src_test() {
+ # The code wants to install everything first and then test the result.
+ emake install.{bin,lib,data}
+ emake check
+}
+
+src_install() {
+ # Subdir make targets like to use `mkdir` all over the place
+ # without any actual dependencies, thus the -j1.
+ emake -j1 package pkgdir="${ED}"/usr
+
+ if [[ $(get_libdir) != "lib" ]] ; then
+ mv "${ED}"/usr/lib "${ED}"/usr/$(get_libdir) || die
+ fi
+
+ # Remove cruft that we don't need, and move around stuff we want
+ rm "${ED}"/usr/{README,VERSION,{pkgconfig,config}_template,pkginfo} || die
+
+ dodir /usr/share
+ mv "${ED}"/usr/misc "${ED}"/usr/share/netpbm || die
+
+ doman userguide/*.[0-9]
+ dodoc README
+
+ cd doc || die
+ dodoc HISTORY USERDOC
+ docinto html
+ dodoc -r ../userguide/*.html
+}