summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/s3cmd/s3cmd-2.0.2.ebuild')
-rw-r--r--net-misc/s3cmd/s3cmd-2.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/s3cmd/s3cmd-2.0.2.ebuild b/net-misc/s3cmd/s3cmd-2.0.2.ebuild
new file mode 100644
index 000000000000..c8ebf64df130
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-2.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5,6}} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="https://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~x86 ~x64-macos"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]"
+
+S="$WORKDIR/${P/_/-}"