summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmhdplop/Manifest1
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmhdplop/Manifest b/x11-plugins/wmhdplop/Manifest
index cab85a579799..ff0775b3fe8b 100644
--- a/x11-plugins/wmhdplop/Manifest
+++ b/x11-plugins/wmhdplop/Manifest
@@ -1 +1,2 @@
DIST wmhdplop-0.9.10.tar.gz 163491 BLAKE2B dd05bcddd4be666e403e7d0ccdbdba9048af6eb15dd72657b657bc4eb8eea1a6a7a78da820f143f6f377949bd9d8df89c5ae129f40374586633f8cdb174b9146 SHA512 9bd79ab5c271e2fbd7d415a1ea20eda5412d7657d9ccfd4781a6d42b834107b65e110231718ad686355e76590cd39f556ebfc9b14e7a4048a68d62503df94f46
+DIST wmhdplop-0.9.11.tar.gz 163931 BLAKE2B 9a30f0ea11fd9abd5419612a413187299945b415ed9231e878aeea5a395627b21d77b99bbac3bd8d2b0673069c2011974355c9056d2dbe46688ed7606e8f9b8c SHA512 e77802945b0c4213212922307416e8f99f1fe99de4ade6200bdd9cd8687926ddc7e67b437109174fb8544eebd8a6aea22ba685624842b54134bff48ea8aaa540
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild
new file mode 100644
index 000000000000..2806056295d9
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="a dockapp for monitoring disk activities with fancy visuals"
+HOMEPAGE="https://www.dockapps.net/wmhdplop"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ media-fonts/corefonts
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.10-cflags.patch
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf --disable-gkrellm
+}