From bd0e0e287e463c298cc0be9f2a5a1ddf0070afd4 Mon Sep 17 00:00:00 2001
From: Maciej Barć <xgqt@gentoo.org>
Date: Mon, 4 Dec 2023 09:14:39 +0100
Subject: dev-lang/fennel: bump to 1.4.0
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Maciej Barć <xgqt@gentoo.org>
---
 dev-lang/fennel/Manifest            |  1 +
 dev-lang/fennel/fennel-1.4.0.ebuild | 52 +++++++++++++++++++++++++++++++++++++
 2 files changed, 53 insertions(+)
 create mode 100644 dev-lang/fennel/fennel-1.4.0.ebuild

(limited to 'dev-lang/fennel')

diff --git a/dev-lang/fennel/Manifest b/dev-lang/fennel/Manifest
index 685acef2fe52..9d478c4292ce 100644
--- a/dev-lang/fennel/Manifest
+++ b/dev-lang/fennel/Manifest
@@ -1 +1,2 @@
 DIST fennel-1.3.1.tar.gz 293564 BLAKE2B 9fc465a06d8df86468197408dbb2c4e1c20a630911d1d999763cb274ed5bafa8dc4260416f10edc294bb9b7e56379f7842137d016059f0f2bc61d15391449447 SHA512 421d479c4527898123020ecc231e5eea38c5f5f1216f4a0bed0a39b8123d6a21ba1b0e876d281dfde447fe000e34a81f706303b4daa2626cc7559c063990cd5f
+DIST fennel-1.4.0.tar.gz 299561 BLAKE2B a94bb15c04b69154dbea1bc562347cef0b9ddd9ec3c3994bf5999593ef89422338f54dfb0bbd6c8e6f487eeb6d1178cc916ed8a92ec7755c43108ff58d3a842e SHA512 0c92496db478eb5445d95057433b54a945c38a40541c6891c1d887a296ce3c89468c688702249488b34192ce1783b4891e292b9b1702a0620e51cc103602694a
diff --git a/dev-lang/fennel/fennel-1.4.0.ebuild b/dev-lang/fennel/fennel-1.4.0.ebuild
new file mode 100644
index 000000000000..6cdd0b3c123f
--- /dev/null
+++ b/dev-lang/fennel/fennel-1.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Fails to build with with "lua5-1".
+LUA_COMPAT=( lua5-{3,4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Lisp-like language that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/
+	https://sr.ht/~technomancy/fennel/"
+
+if [[ "${PV}" == *9999* ]] ; then
+	inherit git-r3
+
+	EGIT_REPO_URI="https://git.sr.ht/~technomancy/${PN}"
+else
+	SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz
+		-> ${P}.tar.gz"
+
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+	${LUA_DEPS}
+"
+BDEPEND="
+	${RDEPEND}
+"
+
+src_prepare() {
+	default
+
+	# Turn off failing tests. bug https://bugs.gentoo.org/906351
+	sed -e 's|"failures",||' -e 's|"repl",||' -i test/init.lua || die
+}
+
+src_test() {
+	emake test
+}
+
+src_install() {
+	emake LUA_LIB_DIR="${ED}/$(lua_get_lmod_dir)" PREFIX="${ED}/usr" install
+
+	dodoc *.md
+}
-- 
cgit v1.2.3-65-gdbad