From b30efc8b34f333da22511442892298e36eb87388 Mon Sep 17 00:00:00 2001
From: Arthur Zamarin <arthurzam@gentoo.org>
Date: Thu, 7 Jul 2022 21:41:38 +0300
Subject: dev-python/urllib3: add 1.26.10

Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
---
 dev-python/urllib3/Manifest               |  1 +
 dev-python/urllib3/urllib3-1.26.10.ebuild | 78 +++++++++++++++++++++++++++++++
 2 files changed, 79 insertions(+)
 create mode 100644 dev-python/urllib3/urllib3-1.26.10.ebuild

(limited to 'dev-python/urllib3')

diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 252dbfc04fdd..ca1a0bac9178 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1 +1,2 @@
+DIST urllib3-1.26.10.tar.gz 297854 BLAKE2B 2523bc197ed9720e2bd011ffa46a46605cab902d66b245cb5229e15e90ac5bac990851d6cb9b6aa2dd5682da2639af7cd8e3c8c27f1210e5ca0c7c10498babd3 SHA512 76c1cc9420c267986c7775a9d9eadfd08e980643c2da16602f755e11a274ffbbf1813f30245fb0d84ee3a99bb3aa33b98893f285cabec8dd4aee1304420cb15b
 DIST urllib3-1.26.9.tar.gz 295258 BLAKE2B 1c6b51e4243c18c25bcb53158e645ea71fe33e0d09ca029256bcbe05bf178ba600dd8911c71730bdefc3cf9f65cdfd5740f579d17d293f9ac7c5d3cbff478b6f SHA512 ac384291b02516dee781c98182625356ac7bc03972612577de5286e159cf161b541cc610b103e0eec1c9f40503049b41e972a9e0998fcd834efe2f40af0e7394
diff --git a/dev-python/urllib3/urllib3-1.26.10.ebuild b/dev-python/urllib3/urllib3-1.26.10.ebuild
new file mode 100644
index 000000000000..47fa4076e5a4
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.10.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="
+	https://github.com/urllib3/urllib3/
+	https://pypi.org/project/urllib3/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+	>=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+	<dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+	dev-python/six[${PYTHON_USEDEP}]
+	brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+	test? (
+		$(python_gen_cond_dep "
+			${RDEPEND}
+			dev-python/brotlicffi[\${PYTHON_USEDEP}]
+			dev-python/mock[\${PYTHON_USEDEP}]
+			dev-python/pytest[\${PYTHON_USEDEP}]
+			dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+			>=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+			>=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+		" python3_{8..11})
+	)
+"
+
+src_prepare() {
+	distutils-r1_src_prepare
+
+	# unbundle urllib3
+	rm src/urllib3/packages/six.py || die
+	find -name '*.py' -exec sed -i \
+		-e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
+		-e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
+		{} + || die
+}
+
+python_test() {
+	local -x CI=1
+	# FIXME: get tornado ported
+	# please keep in sync with BDEPEND!
+	if ! has "${EPYTHON}" python3.{8..11}; then
+		einfo "Skipping tests on ${EPYTHON}"
+		return
+	fi
+
+	local EPYTEST_DESELECT=(
+		# unstable (relies on warning count)
+		test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
+	)
+	has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
+		test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
+	)
+
+	epytest
+}
-- 
cgit v1.2.3-65-gdbad