From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 .../spamassassin-botnet-0.8-r1.ebuild              | 50 ++++++++++++++++++++++
 1 file changed, 50 insertions(+)
 create mode 100644 mail-filter/spamassassin-botnet/spamassassin-botnet-0.8-r1.ebuild

(limited to 'mail-filter/spamassassin-botnet/spamassassin-botnet-0.8-r1.ebuild')

diff --git a/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8-r1.ebuild b/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8-r1.ebuild
new file mode 100644
index 000000000000..6f90396a7692
--- /dev/null
+++ b/mail-filter/spamassassin-botnet/spamassassin-botnet-0.8-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+MY_PN="${PN/b/B}"
+MY_PN="${MY_PN/spamassassin-/}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="SpamAssassin plugin that attempts to detect messages sent by a botnet"
+HOMEPAGE="http://people.ucsc.edu/~jrudd/spamassassin/"
+SRC_URI="http://people.ucsc.edu/~jrudd/spamassassin/${MY_P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=mail-filter/spamassassin-3.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_compile() {
+	# make sure it doesn't try to look for the .pm in the same dir as the .cf
+	sed -rie 's/^(loadplugin.+)[ ]+Botnet.pm/\1/' Botnet.cf
+}
+
+src_install() {
+	perl_set_version
+
+	local plugin_dir=${VENDOR_LIB}/Mail/SpamAssassin/Plugin
+
+	insinto ${plugin_dir}
+	doins ${MY_PN}.pm
+
+	insinto /etc/mail/spamassassin/
+	doins ${MY_PN}.cf
+
+	dodoc ${MY_PN}{{.{api,credits,variants},}.txt,.pl}
+}
+
+pkg_postinst() {
+	echo
+	elog "You need to restart spamassassin (as root) before this plugin will work:"
+	elog "/etc/init.d/spamd restart"
+	echo
+}
-- 
cgit v1.2.3-65-gdbad