From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 media-libs/giblib/giblib-1.2.4-r1.ebuild | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
 create mode 100644 media-libs/giblib/giblib-1.2.4-r1.ebuild

(limited to 'media-libs/giblib/giblib-1.2.4-r1.ebuild')

diff --git a/media-libs/giblib/giblib-1.2.4-r1.ebuild b/media-libs/giblib/giblib-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..52edced574fa
--- /dev/null
+++ b/media-libs/giblib/giblib-1.2.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils libtool
+
+DESCRIPTION="a graphics library built on top of imlib2"
+HOMEPAGE="http://freecode.com/projects/giblib http://www.linuxbrit.co.uk/giblib/"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+
+LICENSE="feh"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/imlib2-1.0.3[X]
+	x11-libs/libX11
+	x11-libs/libXext
+	>=media-libs/freetype-2.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+	sed -i 's:@LDFLAGS@::' giblib-config.in giblib.pc.in || die #430724
+	sed -i "/^docsdir/s:=.*:= @datadir@/doc/${PF}:" Makefile.in || die
+	epunt_cxx
+	elibtoolize # otherwise it doesnt install the .so -> .so.x symlink on fbsd
+}
+
+src_configure() {
+	econf $(use_enable static-libs static)
+}
-- 
cgit v1.2.3-65-gdbad