summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-08-26 19:54:06 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-08-26 19:54:06 +0000
commit6fecb3861750930fb3c6ac8b4d860710ca1490e3 (patch)
treeb2880355d8a7ee2c24c1ae6f017cfa04bbe2fcdd /app-crypt/gnupg
parentyntax cleanups, version bump as we now use --libexecdir=... (diff)
downloadhistorical-6fecb3861750930fb3c6ac8b4d860710ca1490e3.tar.gz
historical-6fecb3861750930fb3c6ac8b4d860710ca1490e3.tar.bz2
historical-6fecb3861750930fb3c6ac8b4d860710ca1490e3.zip
yntax cleanups, version bump as we now use --libexecdir=...
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/Manifest4
-rw-r--r--app-crypt/gnupg/gnupg-1.2.3-r1.ebuild59
2 files changed, 61 insertions, 2 deletions
diff --git a/app-crypt/gnupg/Manifest b/app-crypt/gnupg/Manifest
index b7a71f51002d..74e5dc041901 100644
--- a/app-crypt/gnupg/Manifest
+++ b/app-crypt/gnupg/Manifest
@@ -1,6 +1,6 @@
MD5 caf2a95ab1fd8d5cadf1b14752fa2838 gnupg-1.2.3.ebuild 1624
-MD5 2ebc1603b0ec923450b86f967a1fbbe3 gnupg-1.2.3-r1.ebuild 1697
-MD5 25061320d52b09c3b2659c7b134ffb48 ChangeLog 3620
+MD5 4c1ee3c28a241e7b2675ac1162b076cb gnupg-1.2.3-r1.ebuild 1700
+MD5 7ffbbf902f99b8103028111dd5113800 ChangeLog 3881
MD5 1e79df8d1b4cfa3dd38e7b8e832db358 gnupg-1.2.2-r1.ebuild 1624
MD5 baee9407222e66ea7d35126e2352c558 gnupg-1.2.2.ebuild 1621
MD5 773ecd19392b8f793d7626c9814e1e0b files/digest-gnupg-1.2.2-r1 65
diff --git a/app-crypt/gnupg/gnupg-1.2.3-r1.ebuild b/app-crypt/gnupg/gnupg-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..db5e2eef4d54
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.3-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.3-r1.ebuild,v 1.1 2003/08/26 19:54:01 taviso Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc"
+IUSE="X zlib ldap nls"
+
+DEPEND="dev-lang/perl
+ X? ( x11-misc/xloadimage )
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable X photo-viewers`"
+ myconf="${myconf} `use_with zlib included-zlib`"
+
+ # Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if ! use sparc; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf} \
+ --libexecdir=/usr/lib/gnupg \
+ --enable-external-hkp || die "configure failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall libexecdir="${D}/usr/lib/gnupg" || die
+
+ rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README \
+ THANKS TODO VERSION doc/{FAQ,HACKING,DETAILS,ChangeLog,OpenPGP,faq.raw}
+
+ docinto sgml
+ dodoc doc/*.sgml
+
+ dohtml doc/faq.html
+
+ chmod u+s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}