summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-02-03 11:16:08 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-02-03 11:16:08 +0000
commit149dd9e276b49c743683f63b26b511c9fb8571a8 (patch)
tree90c555cf5d78275ad7b97a7a5c6830e8a30be04f /app-crypt
parentAdded as per bug #35574 (diff)
downloadhistorical-149dd9e276b49c743683f63b26b511c9fb8571a8.tar.gz
historical-149dd9e276b49c743683f63b26b511c9fb8571a8.tar.bz2
historical-149dd9e276b49c743683f63b26b511c9fb8571a8.zip
Added as per bug #35574
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm-module/ChangeLog11
-rw-r--r--app-crypt/tpm-module/Manifest14
-rw-r--r--app-crypt/tpm-module/files/digest-tpm-module-2.01
-rw-r--r--app-crypt/tpm-module/metadata.xml10
-rw-r--r--app-crypt/tpm-module/tpm-module-2.0.ebuild28
5 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/tpm-module/ChangeLog b/app-crypt/tpm-module/ChangeLog
new file mode 100644
index 000000000000..49237c617551
--- /dev/null
+++ b/app-crypt/tpm-module/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-crypt/tpm-module
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-module/ChangeLog,v 1.1 2005/02/03 11:16:08 dragonheart Exp $
+
+*tpm-module-2.0 (03 Feb 2005)
+
+ 03 Feb 2005; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +tpm-module-2.0.ebuild:
+ Added as per bug #35574. Thanks to Henrik Brix Andersen
+ <brix@NOHATEMAIL.gentoo.org>
+
diff --git a/app-crypt/tpm-module/Manifest b/app-crypt/tpm-module/Manifest
new file mode 100644
index 000000000000..eefea7b8cbc3
--- /dev/null
+++ b/app-crypt/tpm-module/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 830a9ee4906df8f7a2155402d74d34b0 tpm-module-2.0.ebuild 622
+MD5 340fbfef19426331492d7063aad76a62 metadata.xml 317
+MD5 2f45ca1b9e03604d48173ec1099ab633 ChangeLog 433
+MD5 95e1fe65a5cd55c3dd7954669f46f8bd files/digest-tpm-module-2.0 59
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCAgf/mdTrptrqvGERAovNAJ9vJhIlXcuWFV9VR9pCZb03xV6ckgCeIUk7
+R+AkoMVI0nHeLJYWxlAO08c=
+=h0sH
+-----END PGP SIGNATURE-----
diff --git a/app-crypt/tpm-module/files/digest-tpm-module-2.0 b/app-crypt/tpm-module/files/digest-tpm-module-2.0
new file mode 100644
index 000000000000..ed3659b9c169
--- /dev/null
+++ b/app-crypt/tpm-module/files/digest-tpm-module-2.0
@@ -0,0 +1 @@
+MD5 287fd479fb24882702bcfd8b0405b327 TPM-2.0.tar.gz 134437
diff --git a/app-crypt/tpm-module/metadata.xml b/app-crypt/tpm-module/metadata.xml
new file mode 100644
index 000000000000..6acf5d98e734
--- /dev/null
+++ b/app-crypt/tpm-module/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+</maintainer>
+<longdescription>Library to manipulate TPM</longdescription>
+</pkgmetadata>
diff --git a/app-crypt/tpm-module/tpm-module-2.0.ebuild b/app-crypt/tpm-module/tpm-module-2.0.ebuild
new file mode 100644
index 000000000000..ffd869c9470d
--- /dev/null
+++ b/app-crypt/tpm-module/tpm-module-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-module/tpm-module-2.0.ebuild,v 1.1 2005/02/03 11:16:08 dragonheart Exp $
+
+inherit linux-mod
+
+MY_P=tpm-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Driver for TPM chips"
+
+HOMEPAGE="http://www.research.ibm.com/gsal/tcpa/"
+SRC_URI="http://www.research.ibm.com/gsal/tcpa/TPM-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+BUILD_PARAMS="KDIR=${KV_DIR}"
+BUILD_TARGETS="default"
+MODULE_NAMES="tpm(crypto:)"
+
+src_unpack() {
+ unpack ${A}
+
+ convert_to_m ${S}/Makefile
+}