summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-08-28 02:13:16 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-08-28 02:13:16 +0000
commit59780ce74bd31f3afafd1f34b07c476aef5b4bc8 (patch)
treecf1ca97d0ae105e3ab43416cda6cb6d148c7d9fa /app-emacs/sml-mode
parentbug 18860 (diff)
downloadhistorical-59780ce74bd31f3afafd1f34b07c476aef5b4bc8.tar.gz
historical-59780ce74bd31f3afafd1f34b07c476aef5b4bc8.tar.bz2
historical-59780ce74bd31f3afafd1f34b07c476aef5b4bc8.zip
bug 18860
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/Manifest5
-rw-r--r--app-emacs/sml-mode/files/50sml-mode-gentoo.el2
-rw-r--r--app-emacs/sml-mode/files/digest-sml-mode-3.9.51
-rw-r--r--app-emacs/sml-mode/sml-mode-3.9.5.ebuild43
4 files changed, 48 insertions, 3 deletions
diff --git a/app-emacs/sml-mode/Manifest b/app-emacs/sml-mode/Manifest
index af426b434ae4..8b08c46be0ba 100644
--- a/app-emacs/sml-mode/Manifest
+++ b/app-emacs/sml-mode/Manifest
@@ -1,5 +1,4 @@
-MD5 8dc4578d3ddf64717fa172e846e08ff1 sml-mode-3.9.5.ebuild 826
-MD5 e0d039af8dccbe4a14bc23d1d7de3a13 sml-mode-3.9.5.ebuild]~ 6007
-MD5 8dc4578d3ddf64717fa172e846e08ff1 sml-mode-3.9.5.ebuild] 826
+MD5 f93363aebac76ef7e984816b51ed309d sml-mode-3.9.5.ebuild 964
+MD5 a971f25273eeca4b1abb89268fede6ea ChangeLog 390
MD5 44144fe26337a173aac5ad08c0b67808 files/50sml-mode-gentoo.el 39
MD5 e8471d35a605788298c9a77c5171aafc files/digest-sml-mode-3.9.5 65
diff --git a/app-emacs/sml-mode/files/50sml-mode-gentoo.el b/app-emacs/sml-mode/files/50sml-mode-gentoo.el
new file mode 100644
index 000000000000..7c52fef2f427
--- /dev/null
+++ b/app-emacs/sml-mode/files/50sml-mode-gentoo.el
@@ -0,0 +1,2 @@
+
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/sml-mode/files/digest-sml-mode-3.9.5 b/app-emacs/sml-mode/files/digest-sml-mode-3.9.5
new file mode 100644
index 000000000000..ce2b7470227c
--- /dev/null
+++ b/app-emacs/sml-mode/files/digest-sml-mode-3.9.5
@@ -0,0 +1 @@
+MD5 6496ac75c6db10b4ee34ba03a04375be sml-mode-3.9.5.tar.gz 61639
diff --git a/app-emacs/sml-mode/sml-mode-3.9.5.ebuild b/app-emacs/sml-mode/sml-mode-3.9.5.ebuild
new file mode 100644
index 000000000000..45000a2d407a
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-3.9.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-3.9.5.ebuild,v 1.1 2003/08/28 02:13:14 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="ftp://ftp.research.bell-labs.com/dist/smlnj/contrib/emacs/"
+SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/contrib/emacs/sml-mode-3.9.5.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+S=${WORKDIR}/${P}
+
+SITEFILE=50sml-mode-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cat ${FILESDIR}/${SITEFILE} ${S}/sml-mode-startup.el >${WORKDIR}/${SITEFILE}
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${WORKDIR}/${SITEFILE}
+ doinfo *.info*
+ dodoc BUGS ChangeLog NEWS README TODO INSTALL
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}