summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-05-27 13:17:51 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-05-27 13:17:51 +0000
commita1d957ba7d13e8bade92340cdbf356d01f6ea5f0 (patch)
tree705d61bc0ff0915f37c7a255b9c6115f10d3fa7f /app-laptop
parentSecond try on fixing the emacs bindings (diff)
downloadhistorical-a1d957ba7d13e8bade92340cdbf356d01f6ea5f0.tar.gz
historical-a1d957ba7d13e8bade92340cdbf356d01f6ea5f0.tar.bz2
historical-a1d957ba7d13e8bade92340cdbf356d01f6ea5f0.zip
Fixed evas patch.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/macosd/ChangeLog6
-rw-r--r--app-laptop/macosd/Manifest4
-rw-r--r--app-laptop/macosd/files/0.1.9-evas-pbbuttonsd.patch91
3 files changed, 98 insertions, 3 deletions
diff --git a/app-laptop/macosd/ChangeLog b/app-laptop/macosd/ChangeLog
index 5da8bee415d7..217d07c95f6e 100644
--- a/app-laptop/macosd/ChangeLog
+++ b/app-laptop/macosd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/macosd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.4 2005/04/13 21:25:21 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.5 2005/05/27 13:17:51 josejx Exp $
+
+ 27 May 2005; Joseph Jezak <josejx@gentoo.org>
+ files/0.1.9-evas-pbbuttonsd.patch:
+ Fixed evas patch.
12 Apr 2005; Joseph Jezak <josejx@gentoo.org>
-files/macosd-0.1.7-include-fix.diff, +files/0.1.9-evas-pbbuttonsd.patch,
diff --git a/app-laptop/macosd/Manifest b/app-laptop/macosd/Manifest
index 0a7a0bfdd105..7614402d2fcd 100644
--- a/app-laptop/macosd/Manifest
+++ b/app-laptop/macosd/Manifest
@@ -1,5 +1,5 @@
-MD5 e7f486f11ec98530036621eb5bae7aaf ChangeLog 706
+MD5 19d0d52f33ef789af1bb8bf53426dda9 ChangeLog 812
MD5 3acd133b5a1dc947584d001570dea373 macosd-0.1.9.ebuild 1341
MD5 185c57b922f3a6264b9421ce45f098f5 metadata.xml 1045
MD5 1dcb5edab66af7f0a128b77c7d2b09b8 files/digest-macosd-0.1.9 65
-MD5 d41d8cd98f00b204e9800998ecf8427e files/0.1.9-evas-pbbuttonsd.patch 0
+MD5 e11c404b0ef630f5a364a0d4db4603d0 files/0.1.9-evas-pbbuttonsd.patch 3310
diff --git a/app-laptop/macosd/files/0.1.9-evas-pbbuttonsd.patch b/app-laptop/macosd/files/0.1.9-evas-pbbuttonsd.patch
index e69de29bb2d1..8c5526f3e254 100644
--- a/app-laptop/macosd/files/0.1.9-evas-pbbuttonsd.patch
+++ b/app-laptop/macosd/files/0.1.9-evas-pbbuttonsd.patch
@@ -0,0 +1,91 @@
+diff -Naur ./PBBEvas.cc macosd/PBBEvas.cc
+--- ./PBBEvas.cc 2004-09-10 13:34:23.000000000 -0400
++++ macosd/PBBEvas.cc 2005-04-12 07:22:31.000000000 -0400
+@@ -517,15 +517,17 @@
+ ButtonPressMask |
+ ButtonReleaseMask | PointerMotionMask, &ev))
+ {
++ Evas_Button_Flags flags = EVAS_BUTTON_NONE;
++ /* FIXME - Add flags for double & triple click! */
+ switch (ev.type)
+ {
+ case ButtonPress:
+ evas->EventFeedMouseMove (ev.xbutton.x, ev.xbutton.y);
+- evas->EventFeedMouseDown (ev.xbutton.button);
++ evas->EventFeedMouseDown (ev.xbutton.button, flags);
+ break;
+ case ButtonRelease:
+ evas->EventFeedMouseMove (ev.xbutton.x, ev.xbutton.y);
+- evas->EventFeedMouseUp (ev.xbutton.button);
++ evas->EventFeedMouseUp (ev.xbutton.button, flags);
+ break;
+ case MotionNotify:
+ evas->EventFeedMouseMove (ev.xmotion.x, ev.xmotion.y);
+diff -Naur ./configure macosd/configure
+--- ./configure 2004-09-10 13:34:23.000000000 -0400
++++ macosd/configure 2005-04-12 07:26:57.000000000 -0400
+@@ -34,7 +34,7 @@
+ "Pbbuttonsd is not installed on your system."
+
+ pkgcheck xosd -config XOSD atleast 2.2.0
+-pkgcheck evas -config EVAS atleast 1.0.0
++pkgcheck evas -config EVAS atleast 0.9.9
+
+ if [ "$WITHXOSD" = 0 -a "$WITHEVAS" = 0 ] ; then
+ status_error \
+diff -Naur ./gfx/include/EvasHelper.hh macosd/gfx/include/EvasHelper.hh
+--- ./gfx/include/EvasHelper.hh 2004-04-24 11:00:21.000000000 -0400
++++ macosd/gfx/include/EvasHelper.hh 2005-04-12 07:16:53.000000000 -0400
+@@ -128,17 +128,17 @@
+ };
+ */
+
+- void EventFeedMouseDown (int b) {
+- evas_event_feed_mouse_down (ob, b);
++ void EventFeedMouseDown (int b, Evas_Button_Flags flags) {
++ evas_event_feed_mouse_down (ob, b, flags, NULL);
+ };
+- void EventFeedMouseUp (int b) {
+- evas_event_feed_mouse_up (ob, b);
++ void EventFeedMouseUp (int b, Evas_Button_Flags flags) {
++ evas_event_feed_mouse_up (ob, b, flags, NULL);
+ };
+ void EventFeedMouseMove (int x, int y) {
+- evas_event_feed_mouse_move (ob, x, y);
++ evas_event_feed_mouse_move (ob, x, y, NULL);
+ };
+ void EventFeedmouseIn () {
+- evas_event_feed_mouse_in (ob);
++ evas_event_feed_mouse_in (ob, NULL);
+ };
+
+ /*
+@@ -147,11 +147,11 @@
+ void EventFeedKeyUpData (const char *keyname, const void *data) {
+ };
+ */
+- void EventFeedKeyDown (const char *keyname) {
+- evas_event_feed_key_down (ob, keyname);
++ void EventFeedKeyDown (const char *keyname, const char *keysymbol, const char *key_compose) {
++ evas_event_feed_key_down (ob, keyname, keysymbol, key_compose, NULL, NULL);
+ };
+- void EventFeedKeyUp (const char *keyname) {
+- evas_event_feed_key_up (ob, keyname);
++ void EventFeedKeyUp (const char *keyname, const char *keysymbol, const char *key_compose) {
++ evas_event_feed_key_up (ob, keyname, keysymbol, key_compose, NULL, NULL);
+ };
+
+
+diff -Naur ./PBB.cc macosd/PBB.cc
+--- ./PBB.cc 2005-04-11 17:04:13.000000000 -0400
++++ macosd/PBB.cc 2004-03-30 05:20:27.000000000 -0500
+@@ -44,7 +44,7 @@
+ {
+ using namespace std;
+
+- int rc = ipc_init (LIBMODE_CLIENT, 1);
++ int rc = ipc_init ("macosd", LIBMODE_CLIENT, 1);
+ if (rc != 0) {
+ switch (rc) {
+ case E_NOSERVER:
+