summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 19:30:51 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 19:30:51 +0000
commit98493fadd56f3659784580420c229c0a3c3d0584 (patch)
treea11777778d2f137bf741d9a6e453684ff91b0199 /app-misc/cdctl
parentQA: Respect CC/CXX (bug 243612) and CFLAGS/LDFLAGS (bug 243616) (diff)
downloadhistorical-98493fadd56f3659784580420c229c0a3c3d0584.tar.gz
historical-98493fadd56f3659784580420c229c0a3c3d0584.tar.bz2
historical-98493fadd56f3659784580420c229c0a3c3d0584.zip
QA: Respect CC (bug 243620) and CFLAGS (bug 240062)
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.28 x86_64
Diffstat (limited to 'app-misc/cdctl')
-rw-r--r--app-misc/cdctl/ChangeLog7
-rw-r--r--app-misc/cdctl/cdctl-0.15.ebuild19
2 files changed, 18 insertions, 8 deletions
diff --git a/app-misc/cdctl/ChangeLog b/app-misc/cdctl/ChangeLog
index 6f0f153698a3..0991fcc7c38c 100644
--- a/app-misc/cdctl/ChangeLog
+++ b/app-misc/cdctl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/cdctl
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/ChangeLog,v 1.10 2007/05/14 16:47:40 bangert Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/ChangeLog,v 1.11 2008/12/30 19:30:51 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> cdctl-0.15.ebuild:
+ QA: Respect CC (bug 243620) and CFLAGS (bug 240062)
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/app-misc/cdctl/cdctl-0.15.ebuild b/app-misc/cdctl/cdctl-0.15.ebuild
index dda3fc22dc26..ced95cd11a32 100644
--- a/app-misc/cdctl/cdctl-0.15.ebuild
+++ b/app-misc/cdctl/cdctl-0.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/cdctl-0.15.ebuild,v 1.18 2006/08/08 21:26:20 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdctl/cdctl-0.15.ebuild,v 1.19 2008/12/30 19:30:51 angelos Exp $
inherit eutils
@@ -17,12 +17,19 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-Makefile.in.patch
- epatch ${FILESDIR}/${P}-cdc_ioctls.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.in.patch
+ epatch "${FILESDIR}"/${P}-cdc_ioctls.patch
+}
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
dodoc NEWS NUTSANDBOLTS PUBLICKEY README
}