summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2007-06-28 17:28:07 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2007-06-28 17:28:07 +0000
commit788504b2dc0cd2aa7e1e980f8f4feeae1904a45f (patch)
treede8427545addfd3b11d7c434251fdbe2fe516514 /app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild
parentdigest fix (diff)
downloadhistorical-788504b2dc0cd2aa7e1e980f8f4feeae1904a45f.tar.gz
historical-788504b2dc0cd2aa7e1e980f8f4feeae1904a45f.tar.bz2
historical-788504b2dc0cd2aa7e1e980f8f4feeae1904a45f.zip
patch for unicode support added; in the moment only main functions enabled for unicode
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild')
-rw-r--r--app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild b/app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..e1b2f46b6bcf
--- /dev/null
+++ b/app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/graphlcd-base/graphlcd-base-0.1.5-r1.ebuild,v 1.1 2007/06/28 17:28:07 hd_brummy Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Graphical LCD Driver"
+HOMEPAGE="http://graphlcd.berlios.de/"
+SRC_URI="http://download.berlios.de/graphlcd/${P}.tgz
+ mirror://vdrfiles/${PN}/${P}_utf8.diff.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="truetype unicode g15"
+
+DEPEND=""
+
+RDEPEND="truetype? ( media-libs/freetype
+ media-fonts/corefonts )
+ g15? ( app-misc/g15daemon )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ sed -i Make.config -e "s:usr\/local:usr:" -e "s:FLAGS *=:FLAGS ?=:"
+ epatch ${FILESDIR}/${P}-nostrip.patch
+
+ use !truetype && sed -i "s:HAVE_FREETYPE2:#HAVE_FREETYPE2:" Make.config
+
+ use unicode && epatch ${WORKDIR}/${P}_utf8.diff && \
+ sed -i "s:#HAVE_FREETYPE2:HAVE_FREETYPE2:" Make.config
+}
+
+src_install() {
+
+ make DESTDIR=${D}/usr LIBDIR=${D}/usr/$(get_libdir) install || die "make install failed"
+
+ insinto /etc
+ doins graphlcd.conf
+
+ dodoc docs/*
+}