summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-08 01:40:34 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-08 01:40:34 +0000
commit400c2ea5f177a12992f44e00ad4e94b9641083fe (patch)
tree321df7d422bcb7336d8605435994e871438e79b8 /app-sci
parentnew ebuild (diff)
downloadhistorical-400c2ea5f177a12992f44e00ad4e94b9641083fe.tar.gz
historical-400c2ea5f177a12992f44e00ad4e94b9641083fe.tar.bz2
historical-400c2ea5f177a12992f44e00ad4e94b9641083fe.zip
new package spice: a general-purpose circuit simulation program
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/spice/ChangeLog18
-rw-r--r--app-sci/spice/files/digest-spice-3.5.51
-rw-r--r--app-sci/spice/spice-3.5.5.ebuild48
3 files changed, 67 insertions, 0 deletions
diff --git a/app-sci/spice/ChangeLog b/app-sci/spice/ChangeLog
new file mode 100644
index 000000000000..4693a13c5624
--- /dev/null
+++ b/app-sci/spice/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-misc/spice
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spice/ChangeLog,v 1.1 2002/08/08 01:40:34 george Exp $
+
+*spice-3.5.5 (7 Aug 2002)
+
+ 07 Aug 2002; G. Shapovalov <george@gentoo.org> spice-3.5.5.ebuild, files/digest-spice-3.5.5:
+
+ initial release
+
+ SPICE 3 is a general-purpose circuit simulation program for nonlinear dc,
+ nonlinear transient, and linear ac analyses. Circuits may contain resistors,
+ capacitors, inductors, mutual inductors, independent voltage and current
+ sources, four types of dependent sources, transmission lines, and the four
+ most common semiconductor devices: diodes, BJT's, JFET's, and MOSFET's. This
+ version includes support for the Bsim3 model (V3.1).
+
+ ebuild submitted by: Chris Bainbridge <chrb@dcs.ed.ac.uk>
diff --git a/app-sci/spice/files/digest-spice-3.5.5 b/app-sci/spice/files/digest-spice-3.5.5
new file mode 100644
index 000000000000..3ff5101991a1
--- /dev/null
+++ b/app-sci/spice/files/digest-spice-3.5.5
@@ -0,0 +1 @@
+MD5 b4a86690d2d56db3045a27ff75245356 spice3f5sfix.tar.gz 1377263
diff --git a/app-sci/spice/spice-3.5.5.ebuild b/app-sci/spice/spice-3.5.5.ebuild
new file mode 100644
index 000000000000..5cfbe6bdd350
--- /dev/null
+++ b/app-sci/spice/spice-3.5.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spice/spice-3.5.5.ebuild,v 1.1 2002/08/08 01:40:34 george Exp $
+
+DESCRIPTION="SPICE 3 is a general-purpose circuit simulation program"
+HOMEPAGE="http://bwrc.eecs.berkeley.edu/Classes/IcBook/SPICE/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/circuits/spice3f5sfix.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/spice3f5sfix/
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/conf
+ sed -e "s:termcap:ncurses:g" linux > linux.1
+ sed -e "s:joe:emacs:g" linux.1 > linux.2
+ sed -e "s:-O2 -s:${CFLAGS}:g" linux.2 > linux.3
+ sed -e "s:SPICE_DIR)/lib:SPICE_DIR)/lib/spice:g" linux.3 > linux.4
+ sed -e "s:/usr/local/spice:/usr:g" linux.4 > linux
+}
+
+src_compile() {
+ ./util/build linux
+ obj/bin/makeidx lib/helpdir/spice.txt
+}
+
+src_install () {
+ # install binaries
+ install -d ${D}/usr/bin
+ install -s obj/bin/spice3 ${D}/usr/bin
+ ln -s /usr/bin/spice3 ${D}/usr/bin/spice
+ install -s obj/bin/help ${D}/usr/bin/spice.help
+ install -s obj/bin/nutmeg ${D}/usr/bin
+ install -s obj/bin/sconvert ${D}/usr/bin
+ install -s obj/bin/multidec ${D}/usr/bin
+ install -s obj/bin/proc2mod ${D}/usr/bin
+ # install runtime stuff
+ rm -f lib/make*
+ mkdir -p ${D}/usr/lib/spice
+ cp -R lib/* ${D}/usr/lib/spice/
+ # install docs
+ doman man/man1/*
+ dodoc doc readme readme.Linux notes/spice2
+}