summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:35:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:35:11 +0000
commitb17759f701685e65334b5c3b0e448a0c0272d063 (patch)
tree45f0f66ed78375a6bf5b1036cd9afe6a966e5111 /app-text/par
parentFixing bug #68962 (diff)
downloadhistorical-b17759f701685e65334b5c3b0e448a0c0272d063.tar.gz
historical-b17759f701685e65334b5c3b0e448a0c0272d063.tar.bz2
historical-b17759f701685e65334b5c3b0e448a0c0272d063.zip
use $(tc-getCC)
Diffstat (limited to 'app-text/par')
-rw-r--r--app-text/par/Manifest2
-rw-r--r--app-text/par/par-1.52.ebuild17
2 files changed, 11 insertions, 8 deletions
diff --git a/app-text/par/Manifest b/app-text/par/Manifest
index ed271c69fab3..fb8da3ddf427 100644
--- a/app-text/par/Manifest
+++ b/app-text/par/Manifest
@@ -1,4 +1,4 @@
-MD5 db480f2065f0be55c06e00190c384db6 par-1.52.ebuild 666
MD5 004a3f02bebdb0f00362b47b79eabc78 ChangeLog 818
MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
+MD5 b051e50d3b17f81a7292844c5c18b730 par-1.52.ebuild 703
MD5 377f79113df08ba4adf2ae40c33f3ec7 files/digest-par-1.52 57
diff --git a/app-text/par/par-1.52.ebuild b/app-text/par/par-1.52.ebuild
index 31a55c8dd54b..b583771564d4 100644
--- a/app-text/par/par-1.52.ebuild
+++ b/app-text/par/par-1.52.ebuild
@@ -1,26 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/par/par-1.52.ebuild,v 1.5 2004/09/11 15:20:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/par/par-1.52.ebuild,v 1.6 2004/10/26 13:35:11 vapier Exp $
-MY_P="Par${PV/./}"
+inherit toolchain-funcs
-DESCRIPTION="par is a paragraph reformatter, vaguely similar to fmt, but better"
+MY_P="Par${PV/./}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
HOMEPAGE="http://www.nicemice.net/par/"
SRC_URI="http://www.nicemice.net/par/${MY_P/./}.tar.gz"
-LICENSE="freedist"
+LICENSE="freedist"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~mips ~amd64"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
IUSE=""
+
DEPEND="virtual/libc"
+
S=${WORKDIR}/${MY_P}
src_compile() {
- make -f protoMakefile CC="cc -c $CFLAGS"
+ make -f protoMakefile CC="$(tc-getCC) -c $CFLAGS"
}
src_install() {
- newbin par par-format
+ newbin par par-format || die
doman par.1
dodoc releasenotes par.doc
}