summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-03 12:28:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-03 12:28:10 +0000
commit22e1acfad7793eb18c04bbd1c6d60cdd9cf61cd8 (patch)
tree6b0c382da4967bf799bbd94e738ce0972add49ca /dev-python/pygame
parentBump to alpha9, fixes #282896 (diff)
downloadhistorical-22e1acfad7793eb18c04bbd1c6d60cdd9cf61cd8.tar.gz
historical-22e1acfad7793eb18c04bbd1c6d60cdd9cf61cd8.tar.bz2
historical-22e1acfad7793eb18c04bbd1c6d60cdd9cf61cd8.zip
Bump to 1.9.1. Small patch by Lorenz Quack. Fixes #280445
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog10
-rw-r--r--dev-python/pygame/files/config.patch26
-rw-r--r--dev-python/pygame/pygame-1.9.1.ebuild65
3 files changed, 99 insertions, 2 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 316daf1a660b..3d6e55d4b629 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygame
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.61 2009/07/15 02:00:12 neurogeek Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.62 2009/09/03 12:28:09 patrick Exp $
+
+*pygame-1.9.1 (03 Sep 2009)
+
+ 03 Sep 2009; Patrick Lauer <patrick@gentoo.org> +pygame-1.9.1.ebuild,
+ +files/config.patch:
+ Bump to 1.9.1. Small patch by Lorenz Quack. Fixes #280445
15 Jul 2009; Jesus Rivero <neurogeek@gentoo.org>
+files/pygame-1.8.1_icon_path.patch, pygame-1.8.1-r1.ebuild:
diff --git a/dev-python/pygame/files/config.patch b/dev-python/pygame/files/config.patch
new file mode 100644
index 000000000000..b3dab162ce0e
--- /dev/null
+++ b/dev-python/pygame/files/config.patch
@@ -0,0 +1,26 @@
+Index: config_unix.py
+===================================================================
+--- config_unix.py (revision 2567)
++++ config_unix.py (working copy)
+@@ -174,7 +174,7 @@
+
+ for d in DEPS[1:]:
+ if not d.found:
+- if not confirm("""
++ if "-auto" not in sys.argv and not confirm("""
+ Warning, some of the pygame dependencies were not found. Pygame can still
+ compile and install, but games that depend on those missing dependencies
+ will not run. Would you like to continue the configuration?"""):
+Index: config_msys.py
+===================================================================
+--- config_msys.py (revision 2567)
++++ config_msys.py (working copy)
+@@ -283,7 +283,7 @@
+
+ for d in DEPS[1:]:
+ if not d.found:
+- if not confirm("""
++ if "-auto" not in sys.argv and not confirm("""
+ Warning, some of the pygame dependencies were not found. Pygame can still
+ compile and install, but games that depend on those missing dependencies
+ will not run. Would you like to continue the configuration?"""):
diff --git a/dev-python/pygame/pygame-1.9.1.ebuild b/dev-python/pygame/pygame-1.9.1.ebuild
new file mode 100644
index 000000000000..a04760c00238
--- /dev/null
+++ b/dev-python/pygame/pygame-1.9.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.1.ebuild,v 1.1 2009/09/03 12:28:09 patrick Exp $
+
+EAPI="2"
+
+inherit distutils multilib eutils
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+HOMEPAGE="http://www.pygame.org/"
+SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc X"
+
+RDEPEND=">=media-libs/libsdl-1.2.5[X?]
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2[png,jpeg]
+ >=media-libs/sdl-mixer-1.2.4
+ dev-python/numpy
+ >=media-libs/smpeg-0.4.4-r1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S=${WORKDIR}/${P}release
+
+src_prepare() {
+ epatch "${FILESDIR}/config.patch"
+}
+
+src_compile() {
+ python config.py -auto
+ sed -i -e 's:X11R6/lib:lib64:g' Setup
+ use X || sed -i -e 's:scrap :#scrap :' Setup
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS=WHATSNEW
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}/examples"
+ fi
+}
+
+src_test() {
+ python_version
+
+ #Skip tests that depend on DISPLAY being set. Bug #223055
+ SKIP_TESTS="display_test image__save_gl_surface_test movie_test"
+
+ for test_ in $SKIP_TESTS
+ do
+ einfo "Removing test: ${test_}"
+ rm -rf "${S}/test/${test_}.py"
+ done
+
+ PYTHONPATH="$(ls -d build/lib.*)" "${python}" run_tests.py || die "tests failed"
+}