summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 18:34:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 18:34:56 +0000
commit23824c28f0e29791d7eb0418f857b98f24fc08a0 (patch)
treeecebc8aa83e9cf4f48a19839aae53f7c06c6f4eb /eclass
parentRename get_python() to PYTHON(). Set BUILDDIR in python_execute_function(). (diff)
downloadhistorical-23824c28f0e29791d7eb0418f857b98f24fc08a0.tar.gz
historical-23824c28f0e29791d7eb0418f857b98f24fc08a0.tar.bz2
historical-23824c28f0e29791d7eb0418f857b98f24fc08a0.zip
Use PYTHON() instead of get_python().
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils.eclass13
1 files changed, 7 insertions, 6 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 96572d8baefe..c06b007d769d 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.57 2009/08/02 00:30:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.58 2009/08/05 18:34:56 arfrever Exp $
# @ECLASS: distutils.eclass
# @MAINTAINER:
@@ -71,8 +71,8 @@ distutils_src_prepare() {
distutils_src_compile() {
if ! has "${EAPI:-0}" 0 1 2 || [[ -n "${SUPPORT_PYTHON_ABIS}" ]]; then
build_modules() {
- echo "$(get_python)" setup.py build -b "build-${PYTHON_ABI}" "$@"
- "$(get_python)" setup.py build -b "build-${PYTHON_ABI}" "$@"
+ echo "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" "$@"
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" "$@"
}
python_execute_function build_modules "$@"
else
@@ -86,6 +86,7 @@ distutils_src_compile() {
# It also installs the "standard docs" (CHANGELOG, Change*, KNOWN_BUGS, MAINTAINERS,
# PKG-INFO, CONTRIBUTORS, TODO, NEWS, MANIFEST*, README*, and AUTHORS)
distutils_src_install() {
+ local pylibdir
# Mark the package to be rebuilt after a python upgrade.
python_need_rebuild
@@ -96,11 +97,11 @@ distutils_src_install() {
# a package uses distutils but does not install anything
# in site-packages. (eg. dev-java/java-config-2.x)
# - liquidx (14/08/2006)
- pylibdir="$("$(get_python)" -c 'from distutils.sysconfig import get_python_lib; print(get_python_lib())')"
+ pylibdir="$("$(PYTHON)" -c 'from distutils.sysconfig import get_python_lib; print(get_python_lib())')"
[[ -n "${pylibdir}" ]] && dodir "${pylibdir}"
- echo "$(get_python)" setup.py build -b "build-${PYTHON_ABI}" install --root="${D}" --no-compile "$@"
- "$(get_python)" setup.py build -b "build-${PYTHON_ABI}" install --root="${D}" --no-compile "$@"
+ echo "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${D}" --no-compile "$@"
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${D}" --no-compile "$@"
}
python_execute_function install_modules "$@"
else