summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-12 04:52:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-12 04:52:27 +0000
commit6667b3a98cdf3cb1bd4bd2571a2e26c8a0bc30af (patch)
tree9b20e4fbd703a9dd2dfbc7c08c0c14c62ad8cd32 /games-arcade
parentold (diff)
downloadhistorical-6667b3a98cdf3cb1bd4bd2571a2e26c8a0bc30af.tar.gz
historical-6667b3a98cdf3cb1bd4bd2571a2e26c8a0bc30af.tar.bz2
historical-6667b3a98cdf3cb1bd4bd2571a2e26c8a0bc30af.zip
old
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild60
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch51
-rw-r--r--games-arcade/bub-n-bros/files/bub-n-bros-1.5-python25.patch32
-rw-r--r--games-arcade/bub-n-bros/files/digest-bub-n-bros-1.53
4 files changed, 0 insertions, 146 deletions
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild
deleted file mode 100644
index 7b2f2b5010e2..000000000000
--- a/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.5.ebuild,v 1.2 2007/08/13 19:14:10 coldwind Exp $
-
-inherit eutils games
-
-MY_P=${P/-n-}
-DESCRIPTION="A multiplayer clone of the famous Bubble Bobble game"
-HOMEPAGE="http://bub-n-bros.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="dev-lang/python"
-RDEPEND="dev-python/pygame"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-home.patch
- epatch "${FILESDIR}"/${P}-python25.patch
-}
-
-src_compile() {
- # Compile the "statesaver" extension module to enable the Clock bonus
- cd "${S}"/bubbob
- python setup.py build_ext -i || die
-
- # Compile the extension module required for the X Window client
- cd "${S}"/display
- python setup.py build_ext -i || die
-
- # Build images
- cd "${S}"/bubbob/images
- python buildcolors.py || die
-}
-
-src_install() {
- local dir=$(games_get_libdir)/${PN}
-
- exeinto "${dir}"
- doexe *.py || die "doexe failed"
-
- insinto "${dir}"
- doins -r bubbob common display java http2 metaserver || die "doins failed"
-
- dodir "${GAMES_BINDIR}"
- dosym "${dir}"/BubBob.py "${GAMES_BINDIR}"/bubnbros || die "dosym failed"
-
- newicon http2/data/bob.png ${PN}.png
- make_desktop_entry bubnbros Bub-n-Bros
-
- rm -rf $(find "${D}/${dir}" -name CVS -type d)
- prepgamesdirs
-}
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch
deleted file mode 100644
index a52dc15c0e16..000000000000
--- a/games-arcade/bub-n-bros/files/bub-n-bros-1.5-home.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- bubbob/images.py
-+++ bubbob/images.py
-@@ -427,7 +427,6 @@
- # check and maybe regenerate the colored image files
- file = os.path.join('images', 'buildcolors.py')
- g = {'__name__': '__auto__', '__file__': file}
-- execfile(file, g)
- # replace the entries 'filename_%d.ppm' by a family of entries,
- # one for each color
- sprmap = {}
---- display/pclient.py
-+++ display/pclient.py
-@@ -155,8 +155,8 @@
- if mode[-1].has_key('cfgfile'):
- self.trackcfgfile = mode[-1]['cfgfile']
- else:
-- self.trackcfgfile = os.path.join(DataChunk.SOURCEDIR,
-- 'http2', 'config.txt')
-+ self.trackcfgfile = os.path.join(os.environ.get('HOME'),
-+ '.bubnbros')
- self.udpsock = None
- self.udpsock_low = None
- self.udpsock2 = None
---- http2/httppages.py
-+++ http2/httppages.py
-@@ -38,7 +38,7 @@
-
-
- class PageServer:
-- CONFIGFILE = 'config.txt'
-+ CONFIGFILE = '.bubnbros'
- localservers = None
-
- def __init__(self, Game):
-@@ -46,7 +46,7 @@
- self.seed = hex(random.randrange(0x1000, 0x10000))
- #self.unique_actions = {}
- self.localhost = gamesrv.HOSTNAME
-- self.filename = os.path.join(LOCALDIR, self.CONFIGFILE)
-+ self.filename = os.path.join(os.environ.get('HOME'), self.CONFIGFILE)
- data = self.loadoptionfile()
- self.globaloptions = Options(data.get('*', {}))
- self.localoptions = Options(data.get(self.localhost, {}))
-@@ -336,7 +336,6 @@
- 'buildcolors.py')
- if os.path.exists(file):
- g = {'__name__': '__auto__', '__file__': file}
-- execfile(file, g)
-
- if port:
- address = '%s:%s' % (host, port)
diff --git a/games-arcade/bub-n-bros/files/bub-n-bros-1.5-python25.patch b/games-arcade/bub-n-bros/files/bub-n-bros-1.5-python25.patch
deleted file mode 100644
index 447d51527cdc..000000000000
--- a/games-arcade/bub-n-bros/files/bub-n-bros-1.5-python25.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -ur bubbros-1.5.orig/bubbob/statesaver.c bubbros-1.5/bubbob/statesaver.c
---- bubbros-1.5.orig/bubbob/statesaver.c 2007-08-13 18:08:58.000000000 +0200
-+++ bubbros-1.5/bubbob/statesaver.c 2007-08-13 18:09:32.000000000 +0200
-@@ -44,7 +44,7 @@
- Py_INCREF(g); /* exhausted -- can return 'g' itself */
- return g;
- }
-- if (f->f_nfreevars || f->f_ncells) {
-+ if (PySequence_Length(co->co_freevars) || PySequence_Length(co->co_cellvars)) {
- PyErr_SetString(PyExc_ValueError, "generator has cell or free vars");
- return NULL;
- }
-@@ -67,6 +67,8 @@
- PyFrameObject* f;
- PyFrameObject* f2;
- PyCodeObject* co;
-+ PyCodeObject* code;
-+ PyCodeObject* code2;
- int i, res;
-
- if (g != g2)
-@@ -94,8 +96,8 @@
- PyErr_SetString(PyExc_TypeError, "returned gi_frame");
- return -1;
- }
-- f2 = (PyFrameObject*) x;
-- if (f2->f_stacksize != f->f_stacksize) {
-+ code2 = (PyFrameObject*) x;
-+ if (code2->co_stacksize != code->co_stacksize) {
- PyErr_SetString(PyExc_TypeError, "stack size mismatch");
- return -1;
- }
diff --git a/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.5 b/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.5
deleted file mode 100644
index c0d86d4cad44..000000000000
--- a/games-arcade/bub-n-bros/files/digest-bub-n-bros-1.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 431fd06ba7f838f61c9200e291060365 bubbros-1.5.tar.bz2 8856240
-RMD160 dafe5004569ed4313d0e470627337810fefec820 bubbros-1.5.tar.bz2 8856240
-SHA256 91db9aa59f2adcd6f79cff475b457901aea82ffe0ebc557012eb3a0a36a3b05b bubbros-1.5.tar.bz2 8856240