summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-22 00:12:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-22 00:12:03 +0000
commitf9d203d4a5a1a1c3ed2b5360187f4267993515ac (patch)
treeb4c37eace7a2f6c1e00120934b198f1fe12e7738 /games-emulation/snes9express
parentfixup autotools, add support for games eclass, and add amd64 KEYWORDS (diff)
downloadhistorical-f9d203d4a5a1a1c3ed2b5360187f4267993515ac.tar.gz
historical-f9d203d4a5a1a1c3ed2b5360187f4267993515ac.tar.bz2
historical-f9d203d4a5a1a1c3ed2b5360187f4267993515ac.zip
add games.eclass support and amd64 KEYWORDS
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-emulation/snes9express')
-rw-r--r--games-emulation/snes9express/Manifest10
-rw-r--r--games-emulation/snes9express/snes9express-1.42.ebuild35
2 files changed, 26 insertions, 19 deletions
diff --git a/games-emulation/snes9express/Manifest b/games-emulation/snes9express/Manifest
index 904244f8d740..56d116b8dcc3 100644
--- a/games-emulation/snes9express/Manifest
+++ b/games-emulation/snes9express/Manifest
@@ -1,5 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 8152dd0afb80b8991f9d3354c05fda78 metadata.xml 226
MD5 73f164cb9749723b05ca4bb7fb510648 snes9express-1.42.ebuild 772
MD5 d91c21d1f3bbce04e7de7e4a2ec9b509 ChangeLog 690
MD5 56710e5516c8de9fbd8a3f2332859393 files/snes9express-1.42-fix.patch 249
MD5 4b260d8bf99869f59d2ea478d201e559 files/digest-snes9express-1.42 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC4DnggIKl8Uu19MoRAlNwAJ9ntQRTJE3LAyKa7fV0ETWLvPwvxACePGRC
+qC3PGwC25KysfWKTUutEDXw=
+=7KBM
+-----END PGP SIGNATURE-----
diff --git a/games-emulation/snes9express/snes9express-1.42.ebuild b/games-emulation/snes9express/snes9express-1.42.ebuild
index 1fde12ccc27a..925bb03861f5 100644
--- a/games-emulation/snes9express/snes9express-1.42.ebuild
+++ b/games-emulation/snes9express/snes9express-1.42.ebuild
@@ -1,33 +1,30 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9express/snes9express-1.42.ebuild,v 1.6 2005/06/15 18:35:21 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9express/snes9express-1.42.ebuild,v 1.7 2005/07/22 00:12:03 vapier Exp $
-inherit eutils
+inherit games eutils
DESCRIPTION="A graphical interface for the X11 versions of snes9x"
-SRC_URI="mirror://sourceforge/snes9express/${P}.tar.gz"
HOMEPAGE="http://www.linuxgames.com/snes9express/"
+SRC_URI="mirror://sourceforge/snes9express/${P}.tar.gz"
+
LICENSE="GPL-2"
-DEPEND=">=x11-libs/gtk+-2.0.0
- sys-libs/glibc"
-RDEPEND="games-emulation/snes9x"
-IUSE=""
SLOT="0"
-KEYWORDS="~ppc ~x86 ~amd64"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-2*"
+RDEPEND="${DEPEND}
+ games-emulation/snes9x"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-fix.patch
-}
-
-src_compile() {
- econf || die "./configure failed"
- emake || die "compilation failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix.patch
}
-src_install () {
- emake DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README || \
- die "Installation of docs failed"
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
}