summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
commitab4f2946553cbc625cd82c853072cb36467fe40e (patch)
treece4c3749e9e4fb10f2366b302c0ed63113ba1041 /games-strategy/crimson
parentminor version update. resolves bug 27641 (diff)
downloadhistorical-ab4f2946553cbc625cd82c853072cb36467fe40e.tar.gz
historical-ab4f2946553cbc625cd82c853072cb36467fe40e.tar.bz2
historical-ab4f2946553cbc625cd82c853072cb36467fe40e.zip
mmm strategy games
Diffstat (limited to 'games-strategy/crimson')
-rw-r--r--games-strategy/crimson/ChangeLog25
-rw-r--r--games-strategy/crimson/Manifest5
-rw-r--r--games-strategy/crimson/crimson-0.3.5.ebuild46
-rw-r--r--games-strategy/crimson/crimson-0.3.6.ebuild47
-rw-r--r--games-strategy/crimson/files/digest-crimson-0.3.51
-rw-r--r--games-strategy/crimson/files/digest-crimson-0.3.61
6 files changed, 125 insertions, 0 deletions
diff --git a/games-strategy/crimson/ChangeLog b/games-strategy/crimson/ChangeLog
new file mode 100644
index 000000000000..68c492c768c9
--- /dev/null
+++ b/games-strategy/crimson/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for app-games/crimson
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/ChangeLog,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+*crimson-0.3.6 (04 Sep 2003)
+
+ 04 Sep 2003; Michael Sterrett <msterret@gentoo.org> crimson-0.3.6.ebuild:
+ version bump (bugs 27918 and 27916)
+
+*crimson-0.3.5 (10 Aug 2003)
+
+ 10 Aug 2003; Michael Sterrett <msterret@gentoo.org> crimson-0.3.5.ebuild:
+ version bump (bug 15359)
+
+ Note that this version is not save-game compatible with older versions.
+
+*crimson-0.3.4 (19 Jul 2003)
+
+ 19 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
+*crimson-0.3.0 (07 Mar 2003)
+
+ 07 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Sami Näätänen <sami.naatanen@kolumbus.fi> #15359.
diff --git a/games-strategy/crimson/Manifest b/games-strategy/crimson/Manifest
new file mode 100644
index 000000000000..1e1ad25be79d
--- /dev/null
+++ b/games-strategy/crimson/Manifest
@@ -0,0 +1,5 @@
+MD5 5907935d07bddc00664d584f79e85d41 ChangeLog 844
+MD5 9da2e4774b5d7fc8352ee1e5a77ef766 crimson-0.3.6.ebuild 1122
+MD5 e1f86d30834f3ee173a24a904af487de crimson-0.3.5.ebuild 1114
+MD5 4b64ed31d5393441841c632c6966b4ab files/digest-crimson-0.3.6 66
+MD5 571a373b01d27d864351481dd6ca1d2b files/digest-crimson-0.3.5 66
diff --git a/games-strategy/crimson/crimson-0.3.5.ebuild b/games-strategy/crimson/crimson-0.3.5.ebuild
new file mode 100644
index 000000000000..929acf5b6acd
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.3.5.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://www.lanipage.de/jens/"
+SRC_URI="http://www.lanipage.de/jens/crimson/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND=">=libsdl-1.1.5
+ >=sdl-mixer-1.2.4
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ egamesconf \
+ `use_enable zlib` \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc NEWS README* THANKS TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Crimson Fields ${PV} is not save-game compatible with previous versions."
+ echo
+ einfo "If you have older save files and you wish to continue those games,"
+ einfo "you'll need to remerge the version with which you started"
+ einfo "those save-games."
+ echo
+
+ games_pkg_postinst
+}
diff --git a/games-strategy/crimson/crimson-0.3.6.ebuild b/games-strategy/crimson/crimson-0.3.6.ebuild
new file mode 100644
index 000000000000..22a99f54ab70
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.3.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.3.6.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND=">=libsdl-1.1.5
+ >=sdl-mixer-1.2.4
+ dev-libs/libxslt
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ egamesconf \
+ `use_enable zlib` \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc NEWS README* THANKS TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Crimson Fields ${PV} is not save-game compatible with previous versions."
+ echo
+ einfo "If you have older save files and you wish to continue those games,"
+ einfo "you'll need to remerge the version with which you started"
+ einfo "those save-games."
+ echo
+
+ games_pkg_postinst
+}
diff --git a/games-strategy/crimson/files/digest-crimson-0.3.5 b/games-strategy/crimson/files/digest-crimson-0.3.5
new file mode 100644
index 000000000000..b5d66d42e147
--- /dev/null
+++ b/games-strategy/crimson/files/digest-crimson-0.3.5
@@ -0,0 +1 @@
+MD5 9449aa7b8d75e1960aabf40e04de061e crimson-0.3.5.tar.bz2 520975
diff --git a/games-strategy/crimson/files/digest-crimson-0.3.6 b/games-strategy/crimson/files/digest-crimson-0.3.6
new file mode 100644
index 000000000000..c5afb0b81d87
--- /dev/null
+++ b/games-strategy/crimson/files/digest-crimson-0.3.6
@@ -0,0 +1 @@
+MD5 9acdb9e20e2ebf35e8276aaf71b00bbc crimson-0.3.6.tar.bz2 521026