summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/smokekde/smokekde-4.9.1.ebuild
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/smokekde/smokekde-4.9.1.ebuild')
-rw-r--r--kde-base/smokekde/smokekde-4.9.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/smokekde/smokekde-4.9.1.ebuild b/kde-base/smokekde/smokekde-4.9.1.ebuild
new file mode 100644
index 000000000000..4d1bcb5a1a81
--- /dev/null
+++ b/kde-base/smokekde/smokekde-4.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokekde/smokekde-4.9.1.ebuild,v 1.1 2012/09/04 18:45:35 johu Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - KDE bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug kate okular semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep smokeqt)
+ attica? ( dev-libs/libattica )
+ kate? ( $(add_kdebase_dep kate) )
+ okular? ( $(add_kdebase_dep okular) )
+ semantic-desktop? ( $(add_kdebase_dep kdepimlibs) )
+"
+RDEPEND="${DEPEND}"
+
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}