summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-16 16:45:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-16 16:45:24 +0000
commitb8c309b1c1d4c5418cd599a9f25e0591d8664c35 (patch)
tree893d887d52a077dedab6d8af39958a6aa07a4925 /kde-base
parentUse global USE flag "postscript" instead of local USE flag "gs" for PostScrip... (diff)
downloadhistorical-b8c309b1c1d4c5418cd599a9f25e0591d8664c35.tar.gz
historical-b8c309b1c1d4c5418cd599a9f25e0591d8664c35.tar.bz2
historical-b8c309b1c1d4c5418cd599a9f25e0591d8664c35.zip
Use global USE flag "postscript" instead of local USE flag "ps" for PostScript support
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.7.4.ebuild8
-rw-r--r--kde-base/cantor/cantor-4.8.3.ebuild8
-rw-r--r--kde-base/cantor/metadata.xml1
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/metadata.xml1
-rw-r--r--kde-base/okular/okular-4.7.4.ebuild8
-rw-r--r--kde-base/okular/okular-4.8.3.ebuild8
8 files changed, 28 insertions, 20 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index d1169ce0b54e..ca3a0b6cc14a 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.70 2012/05/24 11:37:47 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.71 2012/06/16 16:45:24 ssuominen Exp $
+
+ 16 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> cantor-4.7.4.ebuild,
+ cantor-4.8.3.ebuild, metadata.xml:
+ Use global USE flag "postscript" instead of local USE flag "ps" for
+ PostScript support
24 May 2012; Johannes Huber <johu@gentoo.org> -cantor-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/cantor/cantor-4.7.4.ebuild b/kde-base/cantor/cantor-4.7.4.ebuild
index ac3e531bf48e..b4ae2c72654d 100644
--- a/kde-base/cantor/cantor-4.7.4.ebuild
+++ b/kde-base/cantor/cantor-4.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.7.4.ebuild,v 1.5 2012/02/18 14:46:38 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.7.4.ebuild,v 1.6 2012/06/16 16:45:24 ssuominen Exp $
EAPI=4
@@ -10,11 +10,11 @@ inherit kde4-base
DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug ps +R"
+IUSE="debug postscript +R"
# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
RDEPEND="
- ps? ( app-text/libspectre )
+ postscript? ( app-text/libspectre )
R? ( dev-lang/R )
"
DEPEND="${RDEPEND}
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
src_configure() {
mycmakeargs+="
- $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with postscript LibSpectre)
$(cmake-utils_use_with R)
"
kde4-base_src_configure
diff --git a/kde-base/cantor/cantor-4.8.3.ebuild b/kde-base/cantor/cantor-4.8.3.ebuild
index 6120ff912940..c48b95612c8b 100644
--- a/kde-base/cantor/cantor-4.8.3.ebuild
+++ b/kde-base/cantor/cantor-4.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.8.3.ebuild,v 1.4 2012/05/24 08:05:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.8.3.ebuild,v 1.5 2012/06/16 16:45:24 ssuominen Exp $
EAPI=4
@@ -10,12 +10,12 @@ inherit kde4-base
DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="analitza debug ps +R"
+IUSE="analitza debug postscript +R"
# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
RDEPEND="
analitza? ( $(add_kdebase_dep analitza) )
- ps? ( app-text/libspectre )
+ postscript? ( app-text/libspectre )
R? ( dev-lang/R )
"
DEPEND="${RDEPEND}
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}
src_configure() {
mycmakeargs=(
$(cmake-utils_use_with analitza)
- $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with postscript LibSpectre)
$(cmake-utils_use_with R)
)
kde4-base_src_configure
diff --git a/kde-base/cantor/metadata.xml b/kde-base/cantor/metadata.xml
index 77971e25cb8e..9e268d5263b1 100644
--- a/kde-base/cantor/metadata.xml
+++ b/kde-base/cantor/metadata.xml
@@ -4,7 +4,6 @@
<herd>kde</herd>
<use>
<flag name="analitza">Enable support <pkg>kde-base/analitza</pkg></flag>
- <flag name="ps">Enable rendering EPS files</flag>
<flag name="R">Enable R backend support</flag>
</use>
</pkgmetadata>
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 824fd2299b8a..38d14b15226e 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.140 2012/05/24 11:38:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.141 2012/06/16 16:44:50 ssuominen Exp $
+
+ 16 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> okular-4.7.4.ebuild,
+ okular-4.8.3.ebuild, metadata.xml:
+ Use global USE flag "postscript" instead of local USE flag "ps" for
+ PostScript support
24 May 2012; Johannes Huber <johu@gentoo.org> -okular-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/okular/metadata.xml b/kde-base/okular/metadata.xml
index f639223a0bcf..a23f58cf78b7 100644
--- a/kde-base/okular/metadata.xml
+++ b/kde-base/okular/metadata.xml
@@ -4,7 +4,6 @@
<use>
<flag name="chm">Enable support for Microsoft Compiled HTML Help files</flag>
<flag name="ebook">Add E-Book support</flag>
- <flag name="ps">Add PostScript support</flag>
</use>
<herd>kde</herd>
</pkgmetadata>
diff --git a/kde-base/okular/okular-4.7.4.ebuild b/kde-base/okular/okular-4.7.4.ebuild
index c5e2f134b7d1..122fa9a1a8ed 100644
--- a/kde-base/okular/okular-4.7.4.ebuild
+++ b/kde-base/okular/okular-4.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.7.4.ebuild,v 1.5 2012/05/21 21:52:57 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.7.4.ebuild,v 1.6 2012/06/16 16:44:50 ssuominen Exp $
EAPI=4
@@ -10,7 +10,7 @@ inherit kde4-base
DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="chm crypt debug djvu ebook +jpeg +ps +pdf +tiff"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
DEPEND="
media-libs/freetype
@@ -22,7 +22,7 @@ DEPEND="
ebook? ( app-text/ebook-tools )
jpeg? ( virtual/jpeg:0 )
pdf? ( >=app-text/poppler-0.12.3-r3[qt4,-exceptions(-)] )
- ps? ( app-text/libspectre )
+ postscript? ( app-text/libspectre )
tiff? ( media-libs/tiff )
"
RDEPEND="${DEPEND}"
@@ -34,7 +34,7 @@ src_configure() {
$(cmake-utils_use_with djvu DjVuLibre)
$(cmake-utils_use_with ebook EPub)
$(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with postscript LibSpectre)
$(cmake-utils_use_with pdf PopplerQt4)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with tiff)
diff --git a/kde-base/okular/okular-4.8.3.ebuild b/kde-base/okular/okular-4.8.3.ebuild
index 22aa7d96341d..aa0e9aabaa6a 100644
--- a/kde-base/okular/okular-4.8.3.ebuild
+++ b/kde-base/okular/okular-4.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.8.3.ebuild,v 1.5 2012/05/24 10:07:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.8.3.ebuild,v 1.6 2012/06/16 16:44:50 ssuominen Exp $
EAPI=4
@@ -10,7 +10,7 @@ inherit kde4-base
DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="chm crypt debug djvu ebook +jpeg +ps +pdf +tiff"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
DEPEND="
media-libs/freetype
@@ -22,7 +22,7 @@ DEPEND="
ebook? ( app-text/ebook-tools )
jpeg? ( virtual/jpeg:0 )
pdf? ( >=app-text/poppler-0.12.3-r3[qt4,-exceptions(-)] )
- ps? ( app-text/libspectre )
+ postscript? ( app-text/libspectre )
tiff? ( media-libs/tiff )
"
RDEPEND="${DEPEND}"
@@ -34,7 +34,7 @@ src_configure() {
$(cmake-utils_use_with djvu DjVuLibre)
$(cmake-utils_use_with ebook EPub)
$(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with postscript LibSpectre)
$(cmake-utils_use_with pdf PopplerQt4)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with tiff)