summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-09-13 04:49:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-09-13 04:49:34 +0000
commitd05f0b7f973398405f220dd771c8228b637fe27e (patch)
treed97f88a236157c1d91b11dab520f7a0023457f9a /media-gfx/scrot/scrot-0.8_p13.ebuild
parentDrop deprecated python versions. (diff)
downloadhistorical-d05f0b7f973398405f220dd771c8228b637fe27e.tar.gz
historical-d05f0b7f973398405f220dd771c8228b637fe27e.tar.bz2
historical-d05f0b7f973398405f220dd771c8228b637fe27e.zip
Use latest patchset.
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'media-gfx/scrot/scrot-0.8_p13.ebuild')
-rw-r--r--media-gfx/scrot/scrot-0.8_p13.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/scrot/scrot-0.8_p13.ebuild b/media-gfx/scrot/scrot-0.8_p13.ebuild
new file mode 100644
index 000000000000..7c7e1cfd7a6f
--- /dev/null
+++ b/media-gfx/scrot/scrot-0.8_p13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/scrot/scrot-0.8_p13.ebuild,v 1.1 2014/09/13 04:49:27 ssuominen Exp $
+
+EAPI=5
+
+MY_PV=${PV/_p/-}
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="http://scrot.sourcearchive.com/"
+SRC_URI="http://${PN}.sourcearchive.com/downloads/${MY_PV}/${PN}_0.8.orig.tar.gz
+ http://${PN}.sourcearchive.com/downloads/${MY_PV}/${PN}_${MY_PV}.debian.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/imlib2-1.0.3
+ >=media-libs/giblib-1.2.3"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-0.8
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -r "${D}"/usr/doc
+ dodoc AUTHORS ChangeLog
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}