summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-21 04:36:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-21 04:36:09 +0000
commitc85a5ac0b70a2a08e0093d0b99a6548eaf5ab0ae (patch)
treebcc73dd1f18dda9bf50a7da7f01252535d1686da /media-libs/sdl-sound
parentold (diff)
downloadhistorical-c85a5ac0b70a2a08e0093d0b99a6548eaf5ab0ae.tar.gz
historical-c85a5ac0b70a2a08e0093d0b99a6548eaf5ab0ae.tar.bz2
historical-c85a5ac0b70a2a08e0093d0b99a6548eaf5ab0ae.zip
touchups
Diffstat (limited to 'media-libs/sdl-sound')
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild8
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.1.ebuild23
2 files changed, 16 insertions, 15 deletions
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild
index d5008f578f1c..919bb7a7c655 100644
--- a/media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild
+++ b/media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild,v 1.1 2004/10/01 06:32:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1-r1.ebuild,v 1.2 2005/06/21 04:36:09 vapier Exp $
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="A library that handles the decoding of sound file formats"
@@ -9,7 +9,7 @@ SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ppc sparc amd64"
+KEYWORDS="amd64 ppc sparc x86"
IUSE="flac mikmod oggvorbis speex physfs"
DEPEND=">=media-libs/libsdl-1.2
@@ -20,7 +20,7 @@ DEPEND=">=media-libs/libsdl-1.2
media-libs/libogg )
physfs? ( dev-games/physfs )"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_compile() {
econf \
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
index 02f9ac122664..c86121d172b4 100644
--- a/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
+++ b/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild,v 1.7 2004/06/24 23:22:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild,v 1.8 2005/06/21 04:36:09 vapier Exp $
inherit eutils
MY_P="${P/sdl-/SDL_}"
-S=${WORKDIR}/${MY_P}
DESCRIPTION="A library that handles the decoding of sound file formats"
HOMEPAGE="http://icculus.org/SDL_sound/"
SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ppc sparc amd64"
+KEYWORDS="amd64 ppc sparc x86"
IUSE="flac mikmod oggvorbis speex physfs"
DEPEND=">=media-libs/libsdl-1.2
@@ -24,10 +23,12 @@ DEPEND=">=media-libs/libsdl-1.2
media-libs/libogg )
physfs? ( dev-games/physfs )"
+S=${WORKDIR}/${MY_P}
+
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/gcc331.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/gcc331.patch
rm aclocal.m4
# the patch above plus this overkill ripped off the bootstrap scipt from
@@ -41,11 +42,11 @@ src_unpack() {
src_compile() {
econf \
- `use_enable flac` \
- `use_enable mikmod` \
- `use_enable oggvorbis ogg` \
- `use_enable physfs` \
- `use_enable speex` \
+ $(use_enable flac) \
+ $(use_enable mikmod) \
+ $(use_enable oggvorbis ogg) \
+ $(use_enable physfs) \
+ $(use_enable speex) \
--enable-midi \
|| die
emake || die "emake failed"