summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-25 06:29:04 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-25 06:29:04 +0000
commit2bb6a72f2d293572a6a3e187a0082da06cc49598 (patch)
treebe94ad264c752bdd759d162a2a95468bcaccdd97 /media-libs
parentAdded ~sparc keyword. (diff)
downloadhistorical-2bb6a72f2d293572a6a3e187a0082da06cc49598.tar.gz
historical-2bb6a72f2d293572a6a3e187a0082da06cc49598.tar.bz2
historical-2bb6a72f2d293572a6a3e187a0082da06cc49598.zip
Initial import. Ebuild submitted by Sandy McArthur <sandymac@gentoo.org>. Closes bug #34297.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/daaplib/ChangeLog10
-rw-r--r--media-libs/daaplib/Manifest4
-rw-r--r--media-libs/daaplib/daaplib-0.1.1a.ebuild42
-rw-r--r--media-libs/daaplib/files/digest-daaplib-0.1.1a1
-rw-r--r--media-libs/daaplib/metadata.xml10
5 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/daaplib/ChangeLog b/media-libs/daaplib/ChangeLog
new file mode 100644
index 000000000000..c6872c51653c
--- /dev/null
+++ b/media-libs/daaplib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/daaplib
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/daaplib/ChangeLog,v 1.1 2004/03/25 06:29:04 eradicator Exp $
+
+*daaplib-0.1.1a (24 Mar 2004)
+
+ 24 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ daaplib-0.1.1a.ebuild, metadata.xml:
+ Initial import. Ebuild submitted by Sandy McArthur <sandymac@gentoo.org>.
+ Closes bug #34297.
diff --git a/media-libs/daaplib/Manifest b/media-libs/daaplib/Manifest
new file mode 100644
index 000000000000..92a3cada5d35
--- /dev/null
+++ b/media-libs/daaplib/Manifest
@@ -0,0 +1,4 @@
+MD5 af10bf7110134a393e9ee1fe4d76284b ChangeLog 447
+MD5 e0934685987460e4e7365ed85004b098 daaplib-0.1.1a.ebuild 1055
+MD5 0589e7641e96ea672f142cb3fd282e8b metadata.xml 397
+MD5 c4e1bf55fa774a3c2698e7e9bd20fa0a files/digest-daaplib-0.1.1a 62
diff --git a/media-libs/daaplib/daaplib-0.1.1a.ebuild b/media-libs/daaplib/daaplib-0.1.1a.ebuild
new file mode 100644
index 000000000000..0edb59b2c78e
--- /dev/null
+++ b/media-libs/daaplib/daaplib-0.1.1a.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/daaplib/daaplib-0.1.1a.ebuild,v 1.1 2004/03/25 06:29:04 eradicator Exp $
+
+DESCRIPTION="a tiny, portable C++ library to read and write low-level DAAP streams in memory"
+HOMEPAGE="http://www.deleet.de/projekte/daap/daaplib/"
+SRC_URI="http://deleet.de/projekte/daap/daaplib/${PN}.${PV}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}.${PV}/daaplib/src
+
+src_compile() {
+ # There is no configure step
+ emake || die
+
+ if use static; then
+ ranlib libdaaplib.a
+ else
+ c++ -shared --soname=libdaaplib.so -o libdaaplib.so taginput.o tagoutput.o registry.o
+ fi
+}
+
+src_install() {
+ # Not an autoconf make file :(
+
+ if use static; then
+ dolib.a libdaaplib.a
+ else
+ dolib.so libdaaplib.so
+ fi
+
+ mkdir -p ${D}/usr/include/
+ cp -r ../include/daap ${D}/usr/include/
+ chmod -R a+r ${D}/usr/include/daap
+
+ dodoc ../../COPYING ../../README
+}
diff --git a/media-libs/daaplib/files/digest-daaplib-0.1.1a b/media-libs/daaplib/files/digest-daaplib-0.1.1a
new file mode 100644
index 000000000000..9f276633e571
--- /dev/null
+++ b/media-libs/daaplib/files/digest-daaplib-0.1.1a
@@ -0,0 +1 @@
+MD5 038df4ac53780074e6e642a6e928f4fb daaplib.0.1.1a.zip 26059
diff --git a/media-libs/daaplib/metadata.xml b/media-libs/daaplib/metadata.xml
new file mode 100644
index 000000000000..36593b43175f
--- /dev/null
+++ b/media-libs/daaplib/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>
+ daaplib is a very tiny and portable C++ library which helps to read
+ and write low-level DAAP streams in memory. the code is
+ straightforward and can mirror the structure of the data fairly well
+ </longdescription>
+</pkgmetadata>