summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:49:31 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:49:31 +0000
commitd3cb1215e51c23fd6ebd8a9704ad7f4c5da64a86 (patch)
tree88f939cc09705bdecd9e9890c9f4429082b2d54f /media-plugins/mythmusic
parentdoh, typo fix (diff)
downloadhistorical-d3cb1215e51c23fd6ebd8a9704ad7f4c5da64a86.tar.gz
historical-d3cb1215e51c23fd6ebd8a9704ad7f4c5da64a86.tar.bz2
historical-d3cb1215e51c23fd6ebd8a9704ad7f4c5da64a86.zip
initial check-in
Diffstat (limited to 'media-plugins/mythmusic')
-rw-r--r--media-plugins/mythmusic/ChangeLog30
-rw-r--r--media-plugins/mythmusic/Manifest2
-rw-r--r--media-plugins/mythmusic/mythmusic-0.10.ebuild87
3 files changed, 119 insertions, 0 deletions
diff --git a/media-plugins/mythmusic/ChangeLog b/media-plugins/mythmusic/ChangeLog
new file mode 100644
index 000000000000..c71d4a1f92e2
--- /dev/null
+++ b/media-plugins/mythmusic/ChangeLog
@@ -0,0 +1,30 @@
+# ChangeLog for media-plugins/mythmusic
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/ChangeLog,v 1.1 2003/07/08 23:49:00 johnm Exp $
+
+ 03 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythmusic-0.8.ebuild:
+ Set KEYWORDS to ~x86.
+
+*mythmusic-0.10 (01 Jul 2003)
+
+ 01 Jul 2003; Max Kalika <max@lsit.ucsb.edu> mythmusic-0.10.ebuild:
+ Bump version to 0.10. Add similar note as mythtv regarding the importance of
+ keeping database up to date between upgrades.
+
+ 22 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythmusic-0.9.ebuild:
+ Cleanup and consistancy: depend on sed-4, die if sed fails. Drop unused
+ myconf setting.
+
+ 18 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythmusic-0.9.ebuild:
+ Change depend to media-tv/mythtv.
+
+*mythmusic-0.9 (09 Jun 2003)
+
+ 09 Jun 2003; Max Kalika <max@lsit.ucsb.edu> mythmusic-0.9.ebuild:
+ Bump to 0.9. Make all sed operations inline. Drop all config file handling
+ as it is all done online in the database now.
+
+*mythmusic-0.8 (27 Mar 2003)
+
+ 26 Mar 2003; Max Kalika <max@lsit.ucsb.edu> mythmusic-0.9.ebuild:
+ Initial import.
diff --git a/media-plugins/mythmusic/Manifest b/media-plugins/mythmusic/Manifest
new file mode 100644
index 000000000000..9360d0992422
--- /dev/null
+++ b/media-plugins/mythmusic/Manifest
@@ -0,0 +1,2 @@
+MD5 0d61fa79c6af734143453a0bb2b77510 mythmusic-0.10.ebuild 2108
+MD5 064551a2a6923231e71c3beb12a19758 ChangeLog 1156
diff --git a/media-plugins/mythmusic/mythmusic-0.10.ebuild b/media-plugins/mythmusic/mythmusic-0.10.ebuild
new file mode 100644
index 000000000000..61651b235da1
--- /dev/null
+++ b/media-plugins/mythmusic/mythmusic-0.10.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/mythmusic-0.10.ebuild,v 1.1 2003/07/08 23:49:00 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE="opengl sdl X"
+DESCRIPTION="Music player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-tv/mythtv-${PV}
+ media-sound/mad
+ media-sound/cdparanoia
+ media-libs/libvorbis
+ media-libs/libcdaudio
+ >=media-libs/flac-1.0.4
+ >=sys-apps/sed-4
+ X? ( dev-libs/fftw )
+ opengl? ( virtual/opengl dev-libs/fftw )
+ sdl? ( >=media-libs/libsdl-1.2.5 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} `use_enable X fftw`"
+ myconf="${myconf} `use_enable opengl`"
+ myconf="${myconf} `use_enable sdl`"
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ econf ${myconf}
+
+ emake || die "compile problem"
+
+}
+
+src_install() {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins musicdb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc musicdb/README README.db
+
+}
+
+pkg_postinst() {
+
+ einfo "If this is the first time you install MythMusic,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+
+ echo
+
+}